Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 12th March 2006, 19:04
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
No, I don't want you to post a directory, I want you to have a look into that directory and see if there's some FTP related file. If you find one, post its contents here.

If you're in doubt, please post the output of
Code:
ls -la /etc/xinetd.d/
I am away for the weekend but I will take a look tonight when I get home.
Reply With Quote
Sponsored Links
  #12  
Old 13th March 2006, 01:47
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Okay in /etc/xinetd.d/ I found 2 files that are clearly FTP...

tftp
Code:
# default: off
# description: tftp service is provided primarily for booting or when a \
# 	router need an upgrade. Most sites run this only on machines acting as
# 	"boot servers".
service tftp
{
	socket_type     = dgram
	protocol        = udp
	wait            = yes
	user            = root
	server          = /usr/sbin/in.tftpd
	server_args     = -s /tftpboot
	disable         = yes
}
and vsftp
Code:
# default: off
# description:
#   The vsftpd FTP server serves FTP connections. It uses
#   normal, unencrypted usernames and passwords for authentication.
# vsftpd is designed to be secure.
#
# NOTE: This file contains the configuration for xinetd to start vsftpd.
#       the configuration file for vsftp itself is in /etc/vsftpd.conf
service ftp
{
#        server_args             =
#        log_on_success          += DURATION USERID
#        log_on_failure          += USERID
#        nice                    = 10
	socket_type     = stream
	protocol        = tcp
	wait            = no
	user            = root
	server          = /usr/sbin/vsftpd
}
and the output of ls -la /etc/xinetd.d/
Code:
drwxr-xr-x    2 root root  704 Feb 27 20:13 .
drwxr-xr-x  105 root root 9088 Mar 12 18:36 ..
-rw-r--r--    1 root root  228 Feb 27 20:10 chargen
-rw-r--r--    1 root root  248 Feb 27 20:10 chargen-udp
-rw-r--r--    1 root root  260 Feb 27 20:10 cups-lpd
-rw-r--r--    1 root root  376 Feb 27 20:10 cvs
-rw-r--r--    1 root root  228 Feb 27 20:10 daytime
-rw-r--r--    1 root root  248 Feb 27 20:10 daytime-udp
-rw-r--r--    1 root root  220 Feb 27 20:10 echo
-rw-r--r--    1 root root  239 Feb 27 20:10 echo-udp
-rw-r--r--    1 root root  404 Feb 27 20:10 fam
-rw-r--r--    1 root root  167 Feb 27 20:10 i4l-vbox
-rw-r--r--    1 root root  985 Feb 27 20:10 imap
-rw-r--r--    1 root root  364 Feb 27 20:10 nagios-nrpe
-rw-r--r--    1 root root  480 Feb 27 20:10 netstat
-rw-r--r--    1 root root  216 Feb 27 20:10 qpopper
-rw-r--r--    1 root root  234 Feb 27 20:10 rsync
-rw-r--r--    1 root root  338 Feb 27 20:10 sane-port
-rw-r--r--    1 root root  237 Feb 27 20:10 servers
-rw-r--r--    1 root root  239 Feb 27 20:10 services
-rw-r--r--    1 root root  111 Feb 27 20:13 smb
-rw-r--r--    1 root root  248 Feb 27 20:10 swat
-rw-r--r--    1 root root  462 Feb 27 20:10 systat
-rw-r--r--    1 root root  387 Mar  8 18:51 tftp
-rw-r--r--    1 root root  254 Feb 27 20:10 time
-rw-r--r--    1 root root  248 Feb 27 20:10 time-udp
-rw-r--r--    1 root root 2400 Feb 27 20:10 vnc
-rw-r--r--    1 root root  653 Feb 27 20:10 vsftpd
Reply With Quote
  #13  
Old 13th March 2006, 12:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Put
Code:
disable         = yes
into /etc/xinetd.d/vsftp:

Code:
# default: off
# description:
#   The vsftpd FTP server serves FTP connections. It uses
#   normal, unencrypted usernames and passwords for authentication.
# vsftpd is designed to be secure.
#
# NOTE: This file contains the configuration for xinetd to start vsftpd.
#       the configuration file for vsftp itself is in /etc/vsftpd.conf
service ftp
{
#        server_args             =
#        log_on_success          += DURATION USERID
#        log_on_failure          += USERID
#        nice                    = 10
	socket_type     = stream
	protocol        = tcp
	wait            = no
	user            = root
	server          = /usr/sbin/vsftpd
        disable         = yes
}
and restart xinetd:
Code:
/etc/init.d/xinetd restart
Then restart ProFTPd:
Code:
/etc/init.d/proftpd restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 14th March 2006, 00:26
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
Put
Code:
disable         = yes
into /etc/xinetd.d/vsftp:

Code:
# default: off
# description:
#   The vsftpd FTP server serves FTP connections. It uses
#   normal, unencrypted usernames and passwords for authentication.
# vsftpd is designed to be secure.
#
# NOTE: This file contains the configuration for xinetd to start vsftpd.
#       the configuration file for vsftp itself is in /etc/vsftpd.conf
service ftp
{
#        server_args             =
#        log_on_success          += DURATION USERID
#        log_on_failure          += USERID
#        nice                    = 10
	socket_type     = stream
	protocol        = tcp
	wait            = no
	user            = root
	server          = /usr/sbin/vsftpd
        disable         = yes
}
and restart xinetd:
Code:
/etc/init.d/xinetd restart
Then restart ProFTPd:
Code:
/etc/init.d/proftpd restart
I did this and still can't go to the site. I have looked at everything again and just cannot seem to find the missing link.

One thing I noticed that is different is that in FC4 the ftp directory was in /var, in SuSe10 it is in /srv. Maybe using my FC4 proftpd.conf is conflicting with this but I cannot see how since /etc/init.d/proftpd is pointing to /etc/proftpd.conf.

In SuSe the log files are not in /var/log but I guess they won't generate until I can actually get to the site and log in, is that correct?
Reply With Quote
  #15  
Old 14th March 2006, 01:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What does
Code:
netstat -tap
show?

Quote:
Originally Posted by latcarf

In SuSe the log files are not in /var/log but I guess they won't generate until I can actually get to the site and log in, is that correct?
That's right.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 14th March 2006, 01:31
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
What does
Code:
netstat -tap
show?
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:imaps                 *:*                     LISTEN      18733/xinetd
tcp        0      0 *:cvspserver            *:*                     LISTEN      18733/xinetd
tcp        0      0 *:pop3s                 *:*                     LISTEN      18733/xinetd
tcp        0      0 *:printer               *:*                     LISTEN      18733/xinetd
tcp        0      0 *:time                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:smpnameres            *:*                     LISTEN      18733/xinetd
tcp        0      0 *:sane-port             *:*                     LISTEN      18733/xinetd
tcp        0      0 *:echo                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:5801                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:rsync                 *:*                     LISTEN      18733/xinetd
tcp        0      0 *:5802                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:5803                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:systat                *:*                     LISTEN      18733/xinetd
tcp        0      0 *:netbios-ssn           *:*                     LISTEN      5346/smbd
tcp        0      0 *:vboxd                 *:*                     LISTEN      18733/xinetd
tcp        0      0 *:5901                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:pop2                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:daytime               *:*                     LISTEN      18733/xinetd
tcp        0      0 *:5902                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:pop3                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:5903                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:netstat               *:*                     LISTEN      18733/xinetd
tcp        0      0 *:imap                  *:*                     LISTEN      18733/xinetd
tcp        0      0 *:sunrpc                *:*                     LISTEN      4674/portmap
tcp        0      0 *:chargen               *:*                     LISTEN      18733/xinetd
tcp        0      0 *:ftp                   *:*                     LISTEN      20567/proftpd: (acc
tcp        0      0 server1:domain          *:*                     LISTEN      4926/named
tcp        0      0 localhost:domain        *:*                     LISTEN      4926/named
tcp        0      0 *:ipp                   *:*                     LISTEN      4933/cupsd
tcp        0      0 *:smtp                  *:*                     LISTEN      5084/master
tcp        0      0 localhost:953           *:*                     LISTEN      4926/named
tcp        0      0 *:microsoft-ds          *:*                     LISTEN      5346/smbd
tcp        0      0 *:www-http              *:*                     LISTEN      5455/httpd2-prefork
tcp        0      0 *:domain                *:*                     LISTEN      4926/named
tcp        0      0 *:ssh                   *:*                     LISTEN      4907/sshd
tcp        0      0 *:smtp                  *:*                     LISTEN      5084/master
tcp        0      0 localhost:953           *:*                     LISTEN      4926/named
If I am reading this right it shows it running...

I have my router set to the SuSe box which is 192.168.2.3 21:21 but the ftp site is still currently running off the FC4 box 192.168.2.5. As soon as I go into the FC4 box and run service proftpd stop and try to go to the ftp site I get "the connection refused" message. Same process I went though with www until I finally got it configured correctly.

Last edited by latcarf; 14th March 2006 at 01:38.
Reply With Quote
  #17  
Old 14th March 2006, 10:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Yes, ProFTPd is running.

Please check your router settings again. Maybe you must restart it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 14th March 2006, 12:36
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
Yes, ProFTPd is running.

Please check your router settings again. Maybe you must restart it.
I have tried that without success... however, I believe I have found the problem. In SuSe Yast, Security and Users, Firewall there is an "Allowed Services" section. The only services that appear to be allowed are HTTP and Samba. When I click the Services to Allow list to add another service proftpd (or vsftpd) are not listed, only tftp. Seems all I have to do is figure out how to add proftpd or set the firewall outside of Yast. maybe....
Reply With Quote
  #19  
Old 14th March 2006, 19:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by latcarf
In SuSe Yast, Security and Users, Firewall there is an "Allowed Services" section. The only services that appear to be allowed are HTTP and Samba. When I click the Services to Allow list to add another service proftpd (or vsftpd) are not listed, only tftp. Seems all I have to do is figure out how to add proftpd or set the firewall outside of Yast.
Sounds reasonable.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 21st March 2006, 02:43
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
 
Lightbulb SuSe Reload, proftpd to vsftpd

I never could get proftpd to work and hosed SuSe YaST in the process. I did a fresh load of SuSe and decided to try vsftpd since it comes with the distro.

I had some issues which I attribute to being a newb I have one last problem I cannot seem to figure out... I can connect via Konsole and Internet, no problem. I cannot transfer (write) to the site, problem. I think I have the conf correct but here it is, anyone see anything wrong?
Code:
# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# If you do not change anything here you will have a minimum setup for an
# anonymus FTP server.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.

# General Settings
#
# Uncomment this to enable any form of FTP write command.
#
write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
#
dirmessage_enable=YES
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#
#nopriv_user=ftpsecure
#
# You may fully customise the login banner string:
#
ftpd_banner="Welcome to The Fractal Farm FTP service."
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#
#ls_recurse_enable=YES
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#
#deny_email_enable=YES
#
# (default follows)
#
#banned_email_file=/etc/vsftpd.banned_emails
#
# If  enabled,  all  user  and  group  information in
# directory listings will be displayed as "ftp".
#
#hide_ids=YES


# Local FTP user Settings
# 
# Uncomment this to allow local users to log in.
#
local_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#
#local_umask=022
#
# Uncomment to put local users in a chroot() jail in their home directory
# after login.
#
#chroot_local_user=YES
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#
#chroot_list_enable=YES
#
# (default follows)
#
#chroot_list_file=/etc/vsftpd.chroot_list
#
# The maximum data transfer rate permitted, in bytes per second, for
# local authenticated users. The default is 0 (unlimited).
#
#local_max_rate=7200


# Anonymus FTP user Settings
#
# Allow anonymous FTP?
#
anonymous_enable=YES
#
# Anonymous users will only be allowed to download files which are
# world readable.
#
anon_world_readable_only=YES
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#
anon_upload_enable=YES
#
# Default umask for anonymus users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#
#anon_umask=022
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#
#anon_mkdir_write_enable=YES
#
# Uncomment this to enable anonymus FTP users to perform other write operations
# like deletion and renaming.
#
#anon_other_write_enable=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#
#chown_uploads=YES
#chown_username=whoever
#
# The maximum data transfer rate permitted, in bytes per second, for anonymous
# authenticated users. The default is 0 (unlimited).
#
#anon_max_rate=7200


# Log Settings
#
# Log to the syslog daemon instead of using an logfile.
#
syslog_enable=YES
#
# Uncomment this to log all FTP requests and responses.
#
#log_ftp_protocol=YES
#
# Activate logging of uploads/downloads.
#
#xferlog_enable=YES
#
# You may override where the log file goes if you like. The default is shown
# below.
#
#vsftpd_log_file=/var/log/vsftpd.log
# 
# If you want, you can have your log file in standard ftpd xferlog format.
# Note: This disables the normal logging unless you enable dual_log_enable below. 
#
#xferlog_std_format=YES
#
# You may override where the log file goes if you like. The default is shown
# below.
#
#xferlog_file=/var/log/xferlog
#
# Enable this to have booth logfiles. Standard xferlog and vsftpd's own style log.
#
#dual_log_enable=YES
#
# Uncomment this to enable session status information in the system process listing.
#
#setproctitle_enable=YES


# Transfer Settings
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
#
connect_from_port_20=YES
#
# You may change the default value for timing out an idle session.
#
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#
#data_connection_timeout=120
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# Set to NO if you want to disallow the  PASV  method of obtaining a data
# connection.
#
pasv_enable=YES
#
# PAM setting. Do NOT change this unless you know what you do!
#
pam_service_name=vsftpd
#
# Set listen=YES if you want vsftpd to run standalone
#
listen=YES
I checked folder permissions and Groups and Users have permssions to View and Modify with only the Owner allowed to rename and delete.

Here is netstat -tap just in case...
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:printer               *:*                     LISTEN      29569/xinetd
tcp        0      0 *:time                  *:*                     LISTEN      29569/xinetd
tcp        0      0 *:smpnameres            *:*                     LISTEN      29569/xinetd
tcp        0      0 *:sane-port             *:*                     LISTEN      29569/xinetd
tcp        0      0 *:echo                  *:*                     LISTEN      29569/xinetd
tcp        0      0 *:5801                  *:*                     LISTEN      29569/xinetd
tcp        0      0 *:rsync                 *:*                     LISTEN      29569/xinetd
tcp        0      0 *:5802                  *:*                     LISTEN      29569/xinetd
tcp        0      0 *:5803                  *:*                     LISTEN      29569/xinetd
tcp        0      0 *:systat                *:*                     LISTEN      29569/xinetd
tcp        0      0 *:netbios-ssn           *:*                     LISTEN      26746/smbd
tcp        0      0 *:5901                  *:*                     LISTEN      29569/xinetd
tcp        0      0 *:daytime               *:*                     LISTEN      29569/xinetd
tcp        0      0 *:5902                  *:*                     LISTEN      29569/xinetd
tcp        0      0 *:5903                  *:*                     LISTEN      29569/xinetd
tcp        0      0 *:netstat               *:*                     LISTEN      29569/xinetd
tcp        0      0 *:sunrpc                *:*                     LISTEN      8013/portmap
tcp        0      0 *:chargen               *:*                     LISTEN      29569/xinetd
tcp        0      0 *:ftp                   *:*                     LISTEN      27830/vsftpd
tcp        0      0 *:ipp                   *:*                     LISTEN      20511/cupsd
tcp        0      0 localhost:smtp          *:*                     LISTEN      8209/master
tcp        0      0 *:microsoft-ds          *:*                     LISTEN      26746/smbd
tcp        0      0 *:www-http              *:*                     LISTEN      19489/httpd2-prefor
tcp        0      0 *:ssh                   *:*                     LISTEN      8308/sshd
tcp        0      0 localhost:smtp          *:*                     LISTEN      8209/master
I always get this when I restart vsftpd and did some searching but really didn't see where it was a problem but I dont have enough experience yet to say it is not the problem
Code:
server1:~ # /usr/sbin/vsftpd &
500 OOPS: could not bind listening IPv4 socket
[1] 885
[1]   Exit 1                  /usr/sbin/vsftpd
server1:~ #
Better yet... is "&" Start or Restart, and what is Stop!?

(Up to now I have used Gnome but majority seems to think KDE is better so I went with it when I reloaded SuSe)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Updating of the SUSE 9.3 system bogdinator Installation/Configuration 1 7th March 2006 14:45
Is there also a Perfect Setup for SuSE 9.1 bluegrass Installation/Configuration 7 18th January 2006 18:16
The Perfect Setup - SUSE 9.3 (firewall?!) bogdinator HOWTO-Related Questions 7 12th December 2005 13:31
Suse 9.3 - Setting up the basics (File and Print Services) creativehook Suggest HOWTO 1 16th October 2005 21:50
Upgrading from SUSE 9.3 to 10.0 dlplnx Installation/Configuration 1 6th October 2005 11:37


All times are GMT +2. The time now is 15:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.