Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th December 2008, 05:35
ahuacatlan ahuacatlan is offline
Junior Member
 
Join Date: Dec 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig login fails after installation

Hi,
I've just installed ISPConfig on Gentoo linux.

logging in as admin with pass admin doesn't work.

I ran a script to troubleshoot the install. It shows:

/root/ispconfig/php/php -q /tmp/test_ispconfig.php
*****************************
* ISPConfig Setup Test V 1.2
*****************************

Including Config: /home/admispconfig/ispconfig/lib/config.inc.php OK
Database Host: 127.0.0.1
Database Name: db_ispconfig
Database User: root
Database Password found.
Connected successfully to Database
Selecting Database...
Selected DB successfully
Trying default login (user: admin password: admin)...
Table 'db_ispconfig.sys_user' doesn't exist

What should I do about this?
Reply With Quote
Sponsored Links
  #2  
Old 29th December 2008, 07:51
ahuacatlan ahuacatlan is offline
Junior Member
 
Join Date: Dec 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also,

Code:
# /etc/init.d/ispconfig_server start
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!FreshClam is already running!
ISPConfig system is now up and running!
#
Reply With Quote
  #3  
Old 29th December 2008, 08:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
Default

According to the error message it looks as if the ISPConfig installation is not complete or you tried to install ispconfig in a database that already existed. But ISPConfig does not support gentoo, so it might be that it does not work at all. You might try to reinstall ispconfig after running /root/ispconfig/uninstall and make sure that you use the mysql root user to install ispconfig and that the database does not exist.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 29th December 2008, 08:39
ahuacatlan ahuacatlan is offline
Junior Member
 
Join Date: Dec 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the reply. I'm following the Perfect Server guide for installing ISPConfig on Gentoo... so it's supposed to work.

Is this normal?

Code:
# /root/ispconfig/uninstall

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!
#
Reply With Quote
  #5  
Old 29th December 2008, 10:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
 
Default

Quote:
Thanks for the reply. I'm following the Perfect Server guide for installing ISPConfig on Gentoo... so it's supposed to work.
And I'am a developer of ISPConfig and I tell you that gentoo is not a supported platform for ISPConfig. An there is no perfect server guide of the ispconfig project for gentoo, see ispconfig.org:

http://www.ispconfig.org/documentation.htm

Quote:
Is this normal?
If your setup is broken, then yes. Please make sure that you delete the database that you used for ispconfig manually.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig after installation CoDonCo Installation/Configuration 46 14th July 2010 16:54
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Installation of Ispconfig 2.2.8 fails teves Installation/Configuration 5 31st March 2007 10:15
newbie ububtu 6.0.6 error PHP binary line 816 davidsky73 Installation/Configuration 8 17th September 2006 11:51
ISPConfig installation fails the_dude Installation/Configuration 3 11th May 2006 10:13


All times are GMT +2. The time now is 20:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.