Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th March 2006, 14:44
Nejko Nejko is offline
Senior Member
 
Join Date: Jan 2006
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Default Sendmail problem

Hey

i finaly managed to get sendmail half-working It can send emails, but it can not accept them.. i have no idea what should be wrong. i forwarded all ports from 20-144. hoping for fast answer

cya, Nejko
Reply With Quote
Sponsored Links
  #2  
Old 8th March 2006, 21:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's in the mail log when an email is comaing in?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 8th March 2006, 21:52
Nejko Nejko is offline
Senior Member
 
Join Date: Jan 2006
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Mar 8 12:35:10 localhost sendmail[30617]: k28BZAhr030617: to=<nero-server@localhost.localdomain>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=33690, dsn=2.0.0, stat=Sent
Mar 8 13:20:52 localhost sendmail[31247]: k28CKq7e031247: from=nejc@nero-server.com, size=418, class=0, nrcpts=1, msgid=<1141820452.31245@localhost.localdomain>, relay=root@localhost
Mar 8 13:20:52 localhost sendmail[31250]: k28CKqrt031250: from=<nejc@nero-server.com>, size=581, class=0, nrcpts=1, msgid=<1141820452.31245@localhost.localdomain>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
Mar 8 13:20:52 localhost sendmail[31247]: k28CKq7e031247: to=nejc.zurej@siol.net, ctladdr=nejc@nero-server.com (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30418, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (k28CKqrt031250 Message accepted for delivery)
Mar 8 13:20:56 localhost sendmail[31252]: k28CKqrt031250: to=<nejc.zurej@siol.net>, delay=00:00:04, xdelay=00:00:04, mailer=esmtp, pri=120581, relay=mailhub.siol.net. [193.189.160.25], dsn=2.0.0, stat=Sent (Message received: 20060308122045.QPII17682.mailhub.sio...calhos t.localdomain)

that's some lines of the latest..
Reply With Quote
  #4  
Old 8th March 2006, 22:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Looks ok. Please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th March 2006, 22:40
Nejko Nejko is offline
Senior Member
 
Join Date: Jan 2006
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[root@localhost ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:20000 *:* LISTEN 2455/perl
tcp 0 0 *:32769 *:* LISTEN 1830/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 2271/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 1812/portmap
tcp 0 0 *:10000 *:* LISTEN 3930/perl
tcp 0 0 192.168.2.101:domain *:* LISTEN 2767/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 2767/named
tcp 0 0 *:ftp *:* LISTEN 2292/proftpd: (acce
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2129/cupsd
tcp 0 0 localhost.localdomain:5335 *:* LISTEN 2111/mDNSResponder
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2767/named
tcp 0 0 localhost.localdomain:smtp *:* LISTEN 2309/sendmail: acce
tcp 0 0 *:http *:* LISTEN 2333/httpd
tcp 0 0 *:ssh *:* LISTEN 2177/sshd
tcp 0 0 *:https *:* LISTEN 2333/httpd
tcp 0 0 ::ffff:192.168.2.101:ssh ::ffff:192.168.2.100:2957 ESTABLISHED 4700/1
[root@localhost ~]#
Reply With Quote
  #6  
Old 9th March 2006, 11:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

There's no POP3 or IMAP daemon running! That's why you can't fetch your emails with an email client like Outlook or Thunderbird. Please start POP3.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 9th March 2006, 16:07
Nejko Nejko is offline
Senior Member
 
Join Date: Jan 2006
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[root@localhost ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:20000 *:* LISTEN 2455/perl
tcp 0 0 *:32769 *:* LISTEN 1830/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 2271/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 1812/portmap
tcp 0 0 *:10000 *:* LISTEN 3930/perl
tcp 0 0 192.168.2.101:domain *:* LISTEN 2767/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 2767/named
tcp 0 0 *:ftp *:* LISTEN 2292/proftpd: (acce
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2129/cupsd
tcp 0 0 localhost.localdomain:5335 *:* LISTEN 2111/mDNSResponder
tcp 0 0 localhost.localdomain:smtp *:* LISTEN 13435/sendmail: acc
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2767/named
tcp 0 0 192.168.2.101:10000 192.168.2.100:4911 TIME_WAIT -
tcp 0 0 192.168.2.101:10000 192.168.2.100:4912 ESTABLISHED 14631/perl
tcp 0 0 192.168.2.101:10000 192.168.2.100:4913 ESTABLISHED 14632/perl
tcp 0 0 *:imaps *:* LISTEN 13226/dovecot
tcp 0 0 *op3s *:* LISTEN 13226/dovecot
tcp 0 0 *op3 *:* LISTEN 13226/dovecot
tcp 0 0 *:imap *:* LISTEN 13226/dovecot
tcp 0 0 *:http *:* LISTEN 2333/httpd
tcp 0 0 *:ssh *:* LISTEN 2177/sshd
tcp 0 0 *:https *:* LISTEN 2333/httpd
tcp 0 296 ::ffff:192.168.2.101:ssh ::ffff:192.168.2.100:4923 ESTABLISHED 14636/1
[root@localhost ~]#


still no mails to inside..
Reply With Quote
  #8  
Old 9th March 2006, 22:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

You must make Sendmail deliver emails to Maildir instead of mbox.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 9th March 2006, 22:19
Nejko Nejko is offline
Senior Member
 
Join Date: Jan 2006
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can u please explain a bit?

ok, got mbow. so i change it to what?
/////////////////////////////////////////////////////7

i did:
Mail file in home directory: Mail file in home directory

and in dovecot:
Mail file location: Inbox and folders in ~/Maildir

(i'm using webmin)

But still no mails from outside :S

Last edited by Nejko; 9th March 2006 at 22:30.
Reply With Quote
  #10  
Old 9th March 2006, 23:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Do you have a screenshot of the webmin settings?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
Problem with https and IE on Mac os and safari DarkBen Installation/Configuration 11 29th September 2006 18:45
subdomain problem drakos Installation/Configuration 3 25th February 2006 11:24
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 02:56
Installation problem: PHP problem? hgoor Installation/Configuration 7 21st August 2005 23:15


All times are GMT +2. The time now is 05:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.