Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd December 2008, 00:03
friday friday is offline
Member
 
Join Date: Oct 2006
Posts: 31
Thanks: 4
Thanked 0 Times in 0 Posts
Default 2.2.24 Internal Forwards not working. example: jsmith@1.com to jsmith@2.com

Still using 2.2.24 here. Internal forwards are not working when an email name is similar. For instance, if jsmith@1.com has emails forwarded to jsmith@2.com, the email still ends up in jsmith@1.com's Maildir. The account names are different, jsmith for one, johnsmith for the other, but the name prior to the @ symbol are the same. Bug that has been fixed in later releases?
Reply With Quote
Sponsored Links
  #2  
Old 23rd December 2008, 04:57
friday friday is offline
Member
 
Join Date: Oct 2006
Posts: 31
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Here is the log file that says it should have forwarded, but never did


Dec 22 22:28:56 mail postfix/local[16328]: C9EBD7DC786: to=<jsmith@2.com>, orig_to=<jsmith@1.com>, relay=local, delay=2.2, delays=0.58/.01/0/1.6, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSIO")

The names have been altered for this example. Mail is still coming into jsmith@1.com's Mailuser/new, but none for the 2.com address. I do have "keep copy" unchecked, BTW.

I'm tapped out of ideas at this point.
Reply With Quote
  #3  
Old 23rd December 2008, 10:01
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,475
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Quote:
Bug that has been fixed in later releases?
there is no such bug in ISPConfig. Its a problem with your setup.

1) Enable postfix mode in /home/admispconfig/ispconfig/lib/config.inc.php
2) Make sure that the username prefix is enabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
friday (27th December 2008)
  #4  
Old 27th December 2008, 06:42
friday friday is offline
Member
 
Join Date: Oct 2006
Posts: 31
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

I think I may have disabled username prefix, bit I did enable the postfix_style mode in the file you have listed. We'll see how that goes.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix + DKIM - Error in log donb01 Server Operation 2 24th July 2008 17:59
[Postfix+courier+mysql] Postfix Forwards not working? Bales Server Operation 2 3rd April 2008 13:21


All times are GMT +2. The time now is 19:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.