Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th December 2008, 15:17
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
Default Repositories messed up after F10 upgrade...

I recently upgraded our Fedora 9 "Perfect Desktop" to Fedora 10. All went fine, and the system is running smoothly, however when I got some dependency errors, I went to look at my software repositories and I think they are messed up. The Adobe and RPM Fusion ones are fine, but for Fedora and Fedora Updates it shows Fedora 9, not Fedora 10.

Any ideas on how to fix this? Do I need to modify yum.conf?
Reply With Quote
Sponsored Links
  #2  
Old 20th December 2008, 17:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I'd replace references to Fedora 9 in all files in /etc/yum.repos.d.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
jkrell (22nd December 2008)
  #3  
Old 22nd December 2008, 06:41
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
 
Default

Worked like a charm -- I switched all refs to 9 to 10 in /etc/yum.repos.d/ and ran a yum update and 500+ updates later, I am up to date with no dependency problems. Thanks again for your always great help!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dataloss during upgrade because of connection drop whimboo Installation/Configuration 3 20th November 2008 20:56
Upgrade question for "Virtual Users And Domains With Postfix, Courier And MySQL" emresumengen HOWTO-Related Questions 3 1st December 2006 15:33
Messed up ISPConfig-2.2.8 Upgrade Morons Installation/Configuration 4 29th November 2006 12:17
I think I have messed up the upgrade badben Installation/Configuration 1 20th July 2006 12:46
fedor core upgrade rahulgandhi Kernel Questions 1 11th April 2006 15:14


All times are GMT +2. The time now is 16:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.