Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th December 2008, 17:15
gregory gregory is offline
Junior Member
 
Join Date: May 2007
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Unhappy Heartbeat issue when rebooting one node

Hello everyone,

I've a strange problem. I have installed hearbeat and IPVS according the HOWTO's found on howtoforge.com.
Everything is working well. I have tested the HA solution, I stopped heartbeat on one node and see that the second is taking well the resources.
But when I restart one node, the second don't take the resources and my website is down.

When I checked the status heartbeat is stopped on the 2 nodes. I need to start manually one heartbeat on one node.

For me everything seems to be OK, I see on the first node :
master running
(ipvs_syncmaster pid: 4683)

and on the second node:
master stopped
(ipvs_syncbackup pid: 15617)

I have noticed also that if the first node is running (the master) and I rebooted the second one. The "ipvs_syncbackup pid" is not displayed.
I must do a heartbeat restart to have this line.

Could you give some advices to investigate this issue?

Thanks a lot,

Greg.
Reply With Quote
Sponsored Links
  #2  
Old 17th December 2008, 17:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Originally Posted by gregory View Post
But when I restart one node, the second don't take the resources and my website is down.

When I checked the status heartbeat is stopped on the 2 nodes. I need to start manually one heartbeat on one node.
So when you restart heartbeat, it just stops, but doesn't start again? Did you check your syslog?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
gregory (17th December 2008)
  #3  
Old 17th December 2008, 23:03
gregory gregory is offline
Junior Member
 
Join Date: May 2007
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Correct entries are found in my syslog.
But now it's working. I think I don't have enough patience. When I stop the heartbeat manually, the other takes the resources very fast. But when I reboot one node, the other takes the resources correctly but it seems to do it more slower.

Maybe I can review my settings to speed up.

Thanks a lot for the support.

Greg.
Reply With Quote
Reply

Bookmarks

Tags
heartbeat reboot

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue resolving to correct domain name with telnet chillifire Installation/Configuration 12 1st March 2008 01:05
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 20:38
MySQL Cluster HOWTO - Cannot load Virtual IP address samu HOWTO-Related Questions 6 11th January 2007 11:19
Ldirectord and heartbeat with multiple IPs cracker54 Server Operation 5 30th November 2006 17:31
Gentoo Cluster using heartbeat and drbd problem nekromancer Server Operation 1 30th November 2006 10:16


All times are GMT +2. The time now is 03:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.