Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th January 2009, 22:01
chinchunfs chinchunfs is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Error: 111 could not connect to the host "localhost"

hi, i m trying to logon in mailuser section but i recibe the next msg Error: 111 could not connect to the host "localhost", i use courier pop3s and imaps, my system is a Ubuntu 6.06.2 LTS.
Thank You for us Attention and Great Soft how IPSConfig.
Reply With Quote
Sponsored Links
  #2  
Old 20th January 2009, 09:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,003 Times in 3,912 Posts
Default

Please post the output of:

netstat -tap
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st January 2009, 11:12
chinchunfs chinchunfs is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Error: 111 could not connect to the host "localhost"

@ns1:~$ netstat -tap
(No info could be read for "-p": geteuid()=1000 but you should be root.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN -
tcp 0 0 *:netbios-ssn *:* LISTEN -
tcp 0 0 *:81 *:* LISTEN -
tcp 0 0 *:ftp *:* LISTEN -
tcp 0 0 192.168.0.1:domain *:* LISTEN -
tcp 0 0 ns1.madhousetech:domain *:* LISTEN -
tcp 0 0 localhost.locald:domain *:* LISTEN -
tcp 0 0 localhost.localdoma:953 *:* LISTEN -
tcp 0 0 *:smtp *:* LISTEN -
tcp 0 0 *:microsoft-ds *:* LISTEN -
tcp6 0 0 *:imaps *:* LISTEN -
tcp6 0 0 *op3s *:* LISTEN -
tcp6 0 0 *:www *:* LISTEN -
tcp6 0 0 *:ssh *:* LISTEN -
tcp6 0 0 ip6-localhost:953 *:* LISTEN -
tcp6 0 0 *:smtp *:* LISTEN -
tcp6 0 0 *:https *:* LISTEN -
tcp6 0 1652 ::ffff:192.168.0.1%:ssh ::ffff:192.168.0.1:1218 ESTABLISHED-
Reply With Quote
  #4  
Old 21st January 2009, 14:07
djoey djoey is offline
Junior Member
 
Join Date: Dec 2008
Posts: 14
Thanks: 1
Thanked 5 Times in 3 Posts
Default

Looks like imaps and pop3s are listening only on all the ipv6 addresses configured.

localhost = usually synonym for ipv4 address 127.0.0.1

try connecting to:

::1

This should work, however you need to configure courier to not only listen to ipv6 addresses but also ipv4 ones.

Reply With Quote
  #5  
Old 21st January 2009, 19:17
chinchunfs chinchunfs is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Error: 111 could not connect to the host "localhost"

i change my courier imaps and pop3s config, but i get same message from mailuser section Error: 111 could not connect to the host "localhost"

output of: netstat -tap

ns1:/etc/courier# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdo:imaps *:* LISTEN 11680/couriertcpd
tcp 0 0 localhost.localdoop3s *:* LISTEN 11647/couriertcpd
tcp 0 0 *:mysql *:* LISTEN 3595/mysqld
tcp 0 0 *:netbios-ssn *:* LISTEN 3773/smbd
tcp 0 0 *:81 *:* LISTEN 3979/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 4238/proftpd: (acce
tcp 0 0 192.168.0.1:domain *:* LISTEN 4221/named
tcp 0 0 ns1.madhousetech:domain *:* LISTEN 4221/named
tcp 0 0 localhost.locald:domain *:* LISTEN 4221/named
tcp 0 0 *:smtp *:* LISTEN 11800/master
tcp 0 0 localhost.localdoma:953 *:* LISTEN 4221/named
tcp 0 0 *:microsoft-ds *:* LISTEN 3773/smbd
tcp6 0 0 *:www *:* LISTEN 4085/apache2
tcp6 0 0 *:ssh *:* LISTEN 3809/sshd
tcp6 0 0 *:smtp *:* LISTEN 11800/master
tcp6 0 0 ip6-localhost:953 *:* LISTEN 4221/named
tcp6 0 0 *:https *:* LISTEN 4085/apache2
tcp6 0 148 ::ffff:192.168.0.1%:ssh ::ffff:192.168.0.1:1064 ESTABLISHED8615/sshd:
Reply With Quote
  #6  
Old 22nd January 2009, 10:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,003 Times in 3,912 Posts
Default

Please post the content of the file:

/etc/hosts
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 22nd January 2009, 16:40
chinchunfs chinchunfs is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Error: 111 could not connect to the host "localhost"

hi till, this is my /etc/hosts output

ns1:~$ cat /etc/hosts
127.0.0.1 localhost.localdomain localhost
200.49.4.24 ns1.madhousetech.com.ar ns1

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
Reply With Quote
  #8  
Old 23rd January 2009, 13:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,703 Times in 2,546 Posts
Default

Please start pop3 and imap. Currently, only pop3s and imaps are running.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 23rd January 2009, 16:29
chinchunfs chinchunfs is offline
Junior Member
 
Join Date: Jan 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Error: 111 could not connect to the host "localhost"

Thank so much Falko and Till, now mailuser is working perfectly =))
Facundo
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Logwatch/Postfix error av1611 Server Operation 1 18th October 2008 17:04
Mail Question: installed smf forum on centos perfect server setup with ispconfig happz Installation/Configuration 7 22nd August 2008 13:15
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
This is %#@*&^$# embarrassing! domino Smalltalk 34 5th February 2007 21:57


All times are GMT +2. The time now is 02:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.