Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th March 2006, 22:43
badgerbox76 badgerbox76 is offline
Senior Member
 
Join Date: Feb 2006
Posts: 178
Thanks: 6
Thanked 1 Time in 1 Post
Angry ISPConfig Not Running PHPNuke Code!

I have setup a site using ISPConfig and phpnuke http://monitorwaves.no-ip.org/ i have put the phpnuke files in the sharedip directory which ispconfig has made in the apache directory. PHP Scripts is enabled for this site but it is not runing the code. what is wrong?


ISP Site


Group:
Title:
Folder:


Basis

User & Email

Co-Domains

Statistics

Options

Invoice


Server: Server1
Hostname: www
Domain: monitorwaves.no-ip.org
IP Address: 192.168.0.105
Create DNS:
Create DNS-MX:
Space MB: -1
Traffic MB: -1
Traffic Exceedance: suspend
Max. User: -1
Max. Domain: -1
Shell Access: no
CGI Scripts: yes
Standard CGIs: no
PHP Scripts: yes
PHP Safe Mode: no
SSI: no
FTP Access: yes
MySQL: yes
Number of Databases: 3
SSL: no
Anonymous FTP: no
Anon. FTP MB: -1
WAP: no
Individual Error Pages: no
Mailuser Login: no
Apache Directives
(Optional): None

Last edited by badgerbox76; 6th March 2006 at 22:50.
Reply With Quote
Sponsored Links
  #2  
Old 6th March 2006, 23:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by badgerbox76
I have setup a site using ISPConfig and phpnuke http://monitorwaves.no-ip.org/ i have put the phpnuke files in the sharedip directory which ispconfig has made in the apache directory. PHP Scripts is enabled for this site but it is not runing the code. what is wrong?
Why do you put it in the Shared-IP directory and not in the monitorwaves.no-ip.org directory?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th March 2006, 00:26
badgerbox76 badgerbox76 is offline
Senior Member
 
Join Date: Feb 2006
Posts: 178
Thanks: 6
Thanked 1 Time in 1 Post
Default

ok i have moved the files to the /var/www/web10/web directory and i am still having the same problems. i have tryed moving the files all over the place to see if i could get them to work but the problem still goes on. what to do now? Also when i login under the client name i have made and select the web-ftp and put in the same user name and password for the client i get a messages the says could not connect myusername. but i can login under my computer user name and password so how can i set ispconfig up to add the user name of the client to the ftp server and have the web directroy only avalible
http://70.34.184.212:8081/

Last edited by badgerbox76; 7th March 2006 at 02:00.
Reply With Quote
  #4  
Old 7th March 2006, 07:47
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

Quote:
Originally Posted by badgerbox76
ok i have moved the files to the /var/www/web10/web directory and i am still having the same problems. i have tryed moving the files all over the place to see if i could get them to work but the problem still goes on. what to do now? Also when i login under the client name i have made and select the web-ftp and put in the same user name and password for the client i get a messages the says could not connect myusername. but i can login under my computer user name and password so how can i set ispconfig up to add the user name of the client to the ftp server and have the web directroy only avalible
http://70.34.184.212:8081/
First, you will have to enable FTP in the setting of the website. Then create a user and check the "administrator" Checkbox for this user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 7th March 2006, 22:37
badgerbox76 badgerbox76 is offline
Senior Member
 
Join Date: Feb 2006
Posts: 178
Thanks: 6
Thanked 1 Time in 1 Post
Default

Server: Server1
Hostname: www
Domain: monitorwaves.no-ip.org
IP Address: 192.168.0.105
Create DNS:
Create DNS-MX:
Space MB: -1
Traffic MB: -1
Traffic Exceedance: suspend
Max. User: -1
Max. Domain: -1
Shell Access: no
CGI Scripts: yes
I have enabled FTP if you look at my settings for the site and php but the ftp is not creating accounts for the user and the server is not running the php scripts.

Standard CGIs: no
PHP Scripts: yes
PHP Safe Mode: no
SSI: no
FTP Access: yes
MySQL: yes
Number of Databases: 3
SSL: no
Anonymous FTP: no
Anon. FTP MB: -1
WAP: no
Individual Error Pages: no
Mailuser Login: no
Apache Directives
(Optional): None
Reply With Quote
  #6  
Old 7th March 2006, 22:46
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

You added a user to the site and the user does not show up in /etc/passwd ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 7th March 2006, 23:13
badgerbox76 badgerbox76 is offline
Senior Member
 
Join Date: Feb 2006
Posts: 178
Thanks: 6
Thanked 1 Time in 1 Post
Default

yes i have added a user and then i set the user up with a web site with the settings i just gave.

my password file

GNU nano 1.3.8 File: /etc/passwd

list:x:38:38:Mailing List Manager:/var/list:/bin/sh
irc:x:39:39:ircd:/var/run/ircd:/bin/sh
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
nobody:x:65534:65534:nobody:/nonexistent:/bin/sh
dhcp:x:101:101::/nonexistent:/bin/false
syslog:x:102:102::/home/syslog:/bin/false
klog:x:103:103::/home/klog:/bin/false
admin:x:1000:1000:Administrator,,,:/home/admin:/bin/bash
cupsys:x:100:104::/:/bin/false
fetchmail:x:104:65534::/var/run/fetchmail:/bin/sh
messagebus:x:105:109::/var/run/dbus:/bin/false
hal:x:110:110:Hardware abstraction layer,,,:/var/run/hal:/bin/false
saned:x:111:111::/home/saned:/bin/false
gdm:x:106:112:Gnome Display Manager:/var/lib/gdm:/bin/false
hplip:x:107:7:HPLIP system user,,,:/var/run/hplip:/bin/false
sshd:x:108:65534::/var/run/sshd:/bin/false
bind:x:109:113::/var/cache/bind:/bin/false
mysql:x:112:114:MySQL Server,,,:/var/lib/mysql:/bin/false
postfix:x:113:115::/var/spool/postfix:/bin/false
ftp:x:114:65534::/home/ftp:/bin/false
admispconfig:x:1001:1001:Administrator ISPConfig:/home/admispconfig:/bin/bash

Last edited by badgerbox76; 7th March 2006 at 23:20.
Reply With Quote
  #8  
Old 7th March 2006, 23:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by badgerbox76
yes i have added a user and then i set the user up with a web site with the settings i just gave.
I guess you mean you created a customer, and under that customer you created a web site?
A customer is not a system user, it is a user that exists only in ISPConfig and can only log in to ISPConfig.

After you have created the web site in ISPConfig, you must go to the "User & Email" tab and create a user there. This user can use FTP and email.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 8th March 2006, 00:16
badgerbox76 badgerbox76 is offline
Senior Member
 
Join Date: Feb 2006
Posts: 178
Thanks: 6
Thanked 1 Time in 1 Post
Default

Thats good news about the ftp and email but what about the php scripts not runing?

Here is how i have set up the options for my site:

Database Name Database User
web11_db1 web11_u1
Mailserver: localmail
Logsize: 30%
DirectoryIndex: index.php

but the server is still opening up index.html. The files that are in this directory http://70.34.184.212:8081/www.americ...no-ip.org/web/ are PHPnuke files and i have added the mysql file to the data base.


http://70.34.184.212:8081/

Last edited by badgerbox76; 8th March 2006 at 02:15.
Reply With Quote
  #10  
Old 8th March 2006, 08:33
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
 
Default

Please delete the index.html file from ISPConfig in the web directory.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot access ispconfig site Nu2Linux Installation/Configuration 13 3rd January 2009 15:29
Any howTO's on setting up phpnuke with ISPConfig? badgerbox76 HOWTO-Related Questions 1 5th March 2006 15:14
ISPConfig stop running nms General 3 23rd February 2006 22:20
Running ISPConfig on a vserver? tron Installation/Configuration 4 8th December 2005 10:35
Running ISPConfig admin on a different IP hairydog2 Installation/Configuration 2 28th November 2005 10:23


All times are GMT +2. The time now is 20:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.