#1  
Old 6th March 2006, 01:53
jorge jorge is offline
Junior Member
 
Join Date: Nov 2005
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default username and e-mail address

Hello

I know that the users you create with ispconfig are system users, but....
Is there a way to login to ftp sesion or webmail using the e-mail address instead of a "web1_something" username?.

Example:
If you have an email address like jorge@mydomain.com you can log into webmail or ftp using....

username: jorge or jorge@mydomain.com
passwd: *********

Thank you

Jorge
Reply With Quote
Sponsored Links
  #2  
Old 6th March 2006, 07:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,624
Thanks: 793
Thanked 4,996 Times in 3,909 Posts
Default

Hi Jorge,

no, thats not possible because system users can not have an @ in the username.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th March 2007, 07:19
wispman wispman is offline
Junior Member
 
Join Date: Mar 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can someone explain why this is not possible, because I use a website that is hosted with Vdeck panel, and everyday I can login to FTP or webmail or pop3 email using my full email address as my username (including the @).
I am testing out a few panels to host some sites and I like ISPconfig, but this 'web1_' prefix nonsense is just about enough to make me choose something else. At least can't we change it to a user_domain.com suffix or something?
Thanks!
Reply With Quote
  #4  
Old 8th March 2007, 08:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,624
Thanks: 793
Thanked 4,996 Times in 3,909 Posts
Default

It is not possible because linux does not allow @ signs in usernames and ISPConfig uses linux users.

Quote:
I am testing out a few panels to host some sites and I like ISPconfig, but this 'web1_' prefix nonsense is just about enough to make me choose something else.
The web1_ prefix is no nonsense at all, some major commercial controlpanels use the same syntax to separete system users. You can disable it or use the domain name as prefix. Thats all described in the manual.

Quote:
At least can't we change it to a user_domain.com suffix or something?
Sur you can, but you will have to change the ISPConfig sources for this. The sourcecode is in the file /home/admispconfig/ispconfig/lib/plugins/ispconfig_username.plugin.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 9th March 2007, 20:26
wispman wispman is offline
Junior Member
 
Join Date: Mar 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Till,
I don't know how you guys are able to do it, but the level of support direct from the developers is one big advantage with ispconfig.

I have modified the ../ispconfig/lib/plugins/isp_username.plugin.php to implement user suffixes. Seems to be working fine, not extensively tested yet. For those interested, here's the modifications

move the underscore in the system config settings eg. _[DOMAIN]

Quote:


Line 84

from

$out_user = $user_prefix.'<input type="text" name="plugin[user]" size="'.$len_textbox.'" maxlength="'.(32 - strlen($user_prefix)).'" class="text">';

to

$out_user = '<input type="text" name="plugin[user]" size="'.$len_textbox.'" maxlength="'.(32 - strlen($user_prefix)).'" class="text">'.$user_prefix;


Line 87

from

$out_user = $user_prefix.'<input type="text" name="plugin[user]" size="30" maxlength="32" class="text">';

to

$out_user = '<input type="text" name="plugin[user]" size="30" maxlength="32" class="text">'.$user_prefix;

line 144

from

if(!preg_match("/^[a-z][\w\.\-\_]{3,64}$/",$user_prefix . $username)) {

to

if(!preg_match("/^[a-z][\w\.\-\_]{3,64}$/",$username . $user_prefix)) {



line 156

from

$go_api->db->query("UPDATE isp_isp_user SET user_username = '$user_prefix$username', user_email = '$email' where doc_id = $doc_id");

to

$go_api->db->query("UPDATE isp_isp_user SET user_username = '$username$user_prefix', user_email = '$email' where doc_id = $doc_id");

Reply With Quote
  #6  
Old 10th March 2007, 09:14
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
 
Default

Bear in mind that some (older) *nixes limit the recognition of users stored in /etc/passwd by the 1st 8 characters. Using suffixes might bite you if you have users "alongusername_web1" and "alongusername_web2". These users will be identical for all system utilities like ssh, ftp.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41
UebiMiau username lookup patches fcl Tips/Tricks/Mods 0 27th February 2006 12:22
Postfix mail is held in queue indefinitely... squallbsr Server Operation 9 15th January 2006 19:13
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58
Mail not accepting username and password! nformosa General 9 14th September 2005 09:58


All times are GMT +2. The time now is 04:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.