#1  
Old 25th November 2008, 11:23
roshajai roshajai is offline
Junior Member
 
Join Date: Nov 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default SPF doesn't seems to be working

Hi,

I have installed the ispconfig on FC9 by using the perfect server howto, Everything else if working fine. But it seems SPF doesn't seems to be working.

I have added the records for the MX and A records that will send the emails. But i am still getting email from my own email addresses and SPF doesn't seems to checking those, there is also nothing showing up in maillog, which suggests that SPF is working.

I have though tested with 'dig TXT mydomain.com' and it shows the spf1 config in my domain's zone file.

Please suggest if i am doing something wrong, and what i can check.

Thanks

Roshajai
Reply With Quote
Sponsored Links
  #2  
Old 26th November 2008, 12:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

SPF is set in the dns system, so you will not see anything in the mail log about it. If you want to check your spf records, use one of the spf testers:

http://www.openspf.org/Tools
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th November 2008, 12:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

SPF is set in the dns system, so you will not see anything in the mail log about it. If you want to check your spf records, use one of the spf testers:

http://www.openspf.org/Tools
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 27th November 2008, 17:26
roshajai roshajai is offline
Junior Member
 
Join Date: Nov 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I have tested the SPF record against the testers, it is working fine. My SPF record machnism '-all' which says to reject the email if it fail SPF test.

What i am looking is the way where i can use spamassassin to reject emails when SPF is failed, right now spamassassin just give such a email some SPAM score.

Is it possible to tell spamassassin to do so.

Thanks
Reply With Quote
  #5  
Old 28th November 2008, 12:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

SpamAssassin cannot reject emails because it just calculates a score based on which procmail decides what to do.
You could do it if you were using SpamAssassin together with amavisd-new, but with procmail that's not possible.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS stop working MZH General 3 22nd February 2008 11:10
SPF Records mrtornado79 Installation/Configuration 6 30th January 2008 05:53
SPF and multiple IPs Spaetzle Installation/Configuration 3 3rd January 2008 11:50
No SPF record. beryl Installation/Configuration 6 17th May 2007 19:52
ftp not working pesja Installation/Configuration 3 17th July 2006 12:37


All times are GMT +2. The time now is 04:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.