Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd November 2008, 12:27
klonos klonos is offline
Member
 
Join Date: Apr 2007
Posts: 78
Thanks: 5
Thanked 3 Times in 3 Posts
Question ISPconfig - Usename change password -> username already in use

Using ISPconfig 2.2.27

When I go to Customer -> Site Management -> Select IP -> User & Email ->Select user account -> enter new password -> Save ...

It gives me:

Code:
The following error occurred:

The username is already in use.

Next >>
First time I am having issues with ISPconfig, so I don't know where to start troubleshooting from.
__________________
You can support Howtoforge and all the people behind it too. Consider becoming a supporter. It only costs a few and has to offer so much more than it already does. Take a look here
Reply With Quote
Sponsored Links
  #2  
Old 22nd November 2008, 13:58
_X_ _X_ is offline
Senior Member
 
Join Date: Oct 2008
Posts: 247
Thanks: 8
Thanked 37 Times in 35 Posts
Default

Check out if there is something in Recycle Bin (both of them).
Reply With Quote
  #3  
Old 29th November 2008, 11:50
klonos klonos is offline
Member
 
Join Date: Apr 2007
Posts: 78
Thanks: 5
Thanked 3 Times in 3 Posts
Question 'Both of them' ???

... are there two recycle bins? Well, when I check under 'ISP Manager' section I see the following:

Code:
Recycle bin: contents 0 - 30

[Empty recycle bin]
 
Note: Items remaining in recycle bin after emptying are currently in update state. Please try to delete them later.
Hitting the 'Empty recycle bin' has no different effect (there are no items in the first place anyway).

All the other sections' recycle bins are empty:

Code:
Recycle bin: contents 0 - 30

[Empty recycle bin]
Is there any way I can double check this in the MySQL db directly?

PS: Sorry for the late reply, but I was away.
__________________
You can support Howtoforge and all the people behind it too. Consider becoming a supporter. It only costs a few and has to offer so much more than it already does. Take a look here

Last edited by klonos; 29th November 2008 at 11:51. Reason: Forgot something
Reply With Quote
  #4  
Old 29th November 2008, 15:39
_X_ _X_ is offline
Senior Member
 
Join Date: Oct 2008
Posts: 247
Thanks: 8
Thanked 37 Times in 35 Posts
Default

You can try with database check/repair/optimise.

You can check directly in db_ispconfig database for that username but i dont suggest manual editing of database. If you want to manualy edit that database do a backup first so you can revert to previous state if anything goes wrong.
Reply With Quote
  #5  
Old 29th November 2008, 21:51
klonos klonos is offline
Member
 
Join Date: Apr 2007
Posts: 78
Thanks: 5
Thanked 3 Times in 3 Posts
Unhappy

database check/repair/optimize did not work. Still getting that error

I am not going to touch the db unless someone out there knows to point me to the exact thing I need to change and where I am to locate it in the db tables.

Still waiting for any ideas on this one...
__________________
You can support Howtoforge and all the people behind it too. Consider becoming a supporter. It only costs a few and has to offer so much more than it already does. Take a look here
Reply With Quote
  #6  
Old 29th November 2008, 22:31
_X_ _X_ is offline
Senior Member
 
Join Date: Oct 2008
Posts: 247
Thanks: 8
Thanked 37 Times in 35 Posts
Default

info on users can be found in isp_isp_user table in ispconfig db.

check if that username exists there.
Reply With Quote
  #7  
Old 30th November 2008, 11:35
klonos klonos is offline
Member
 
Join Date: Apr 2007
Posts: 78
Thanks: 5
Thanked 3 Times in 3 Posts
Unhappy

Yep! The user entry is there and the only odd thing is the 'user_cron' field that is set to 0 whereas the rest of the user entries have it set to Null.

The thing though is that the error appears for any other user I try to change the password and not just the one's that I noticed having the issue first. So I guess that this is a general problem with changing user passwords and not user specific.
__________________
You can support Howtoforge and all the people behind it too. Consider becoming a supporter. It only costs a few and has to offer so much more than it already does. Take a look here
Reply With Quote
  #8  
Old 30th November 2008, 12:49
_X_ _X_ is offline
Senior Member
 
Join Date: Oct 2008
Posts: 247
Thanks: 8
Thanked 37 Times in 35 Posts
Default

can you change any other setting for users or you cannot change only passwords?
Reply With Quote
  #9  
Old 30th November 2008, 13:20
klonos klonos is offline
Member
 
Join Date: Apr 2007
Posts: 78
Thanks: 5
Thanked 3 Times in 3 Posts
Red face

It turns out that despite this error coming up, the password actually is changed. And you are right, trying to change other settings (I tried real name, mail address and quota) also spits this error, but actually applies the change.

Can I safely ignore this, or should we troubleshoot further? I am using the latest stable 2.x version of ISPconfig and Ubuntu 8.10.
__________________
You can support Howtoforge and all the people behind it too. Consider becoming a supporter. It only costs a few and has to offer so much more than it already does. Take a look here
Reply With Quote
  #10  
Old 30th November 2008, 14:17
_X_ _X_ is offline
Senior Member
 
Join Date: Oct 2008
Posts: 247
Thanks: 8
Thanked 37 Times in 35 Posts
 
Default

well ... since those changes are done in database it points out to problem with mysql so you should take a look at log files to see if that error can be corrected.

personaly I would try to correct that problem because you cannot delete users and that function can be usefull
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.6 Beta released till General 38 21st September 2008 20:15
ERROR 101: wrong username or password ionut147 General 4 8th June 2008 21:37
ISPConfig admin Password linuxuser1 Installation/Configuration 2 21st October 2005 14:38
Mail not accepting username and password! nformosa General 9 14th September 2005 10:58
Wrong username and password iceberg General 9 25th August 2005 22:48


All times are GMT +2. The time now is 21:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.