Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th March 2006, 23:50
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default problems sending receiving mail on Postfix

I am using SuSe 9.3 and installed Postfix following The Perfect Setup - SUSE 9.3 (Postfix With SMTP-AUTH And TLS )

server1:~ # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 mail.57.ro ESMTP Postfix
ehlo localhost
250-mail.57.ro
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.

It seems to be ok
Ive installed Courier-IMAP/Courier-POP3

My postfix main.cf

server1:~ # postconf -n
alias_maps = hash:/etc/aliases
biff = no
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
defer_transports =
disable_dns_lookups = no
home_mailbox = Maildir/
html_directory = /usr/share/doc/packages/postfix/html
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_command =
mailbox_size_limit = 0
mailbox_transport =
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains =
masquerade_exceptions = root
message_size_limit = 10240000
mydestination = $myhostname, localhost.$mydomain, mydomain
mydomain = 57.ro
myhostname = mail.$mydomain
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relayhost =
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_sasl_auth_enable = no
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
strict_rfc821_envelopes = no
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550

My problem is that I don't know howto add an account like user1@57.ro,user2@57.ro,user3@57.ro etc
Don't know how to add user and password for this accounts
I've searched on Internet but nothing matching with my request was found.

If someone can help me thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 5th March 2006, 14:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Have a look here: http://www.howtoforge.com/forums/showthread.php?t=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 5th March 2006, 17:50
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default please detail like for dummies

Thanks very much I've tried but dont understand

Step 1 OK done it
postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart

Step 2

useradd -d /home/sample_user -g users sample_user
passwd sample_user

I dont understand i make a user with the home directory /home/sample_user and group sample_user and the password sample user

Please detail for me like for dummies

Step 3

postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
postconf -e 'mydestination = /etc/postfix/local-host-names'

Ive made a file virtusertable in /etc/postfix
Made a file local-host-names in /etc/postfix

Step 4
Inserted in file /etc/postfix/local-host-names domains to accept emails

Step 5

Inserted in file /etc/postfix/virtusertable

user1@mydomain.ro sample_user
user2@mydomain.ro sample_user
user3@mydomain.ro sample_user
Reply With Quote
  #4  
Old 5th March 2006, 19:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by mavgh1
Step 2

useradd -d /home/sample_user -g users sample_user
passwd sample_user

I dont understand i make a user with the home directory /home/sample_user and group sample_user and the password sample user

Please detail for me like for dummies
You must replace the username, password and home directory appropriately.

Quote:
Originally Posted by mavgh1
Step 5

Inserted in file /etc/postfix/virtusertable

user1@mydomain.ro sample_user
user2@mydomain.ro sample_user
user3@mydomain.ro sample_user
Again, replace sample_user appropriately.

And don't forget to run
Code:
postmap /etc/postfix/virtusertable
/etc/init.d/postfix restart
at the end.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 5th March 2006, 23:45
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default solved half of my problems

Now I can receive emails but cannot send

He said he cannot connect to SSL Server.Looking in log mail i found TLS no entropy and I uncomment in master.cf the line
tlsmgr unix n1000? 1tlsmgr

When I try to send emails he can connect to server(TLS conection established TLSv1 RC4-MD5 ,SASL LOGIN authentification failed) but he did not reconigze user and password.

Last edited by mavgh1; 5th March 2006 at 23:52.
Reply With Quote
  #6  
Old 6th March 2006, 08:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Can you send emails when you connact with plain smtp without TLS?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 6th March 2006, 21:40
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default cannot send Mail with no TLS

I have the same problem SASL conection failed.
I must tell you that I'm running the server behind a router.Everything is configured to work behind the router(DNS,FTP etc and it works).When I receive mail I think there is the same problem he must route packets from Public IP to Private IP.
Thanks anyway for your time and still hope for some help.
Reply With Quote
  #8  
Old 6th March 2006, 23:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the exact error message?
Is saslauthd running? Please post the output of
Code:
ps aux|grep sasl
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 6th March 2006, 23:53
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default this is ps aux|grep sasl

root 6064 0.0 0.2 4060 1176 ? Ss Mar06 0:00 /usr/sbin/sasla uthd -a pam
root 6103 0.0 0.2 4060 1176 ? S Mar06 0:00 /usr/sbin/sasla uthd -a pam
root 6104 0.0 0.2 4060 1176 ? S Mar06 0:00 /usr/sbin/sasla uthd -a pam
root 6105 0.0 0.2 4060 1176 ? S Mar06 0:00 /usr/sbin/sasla uthd -a pam
root 6106 0.0 0.2 4060 1176 ? S Mar06 0:00 /usr/sbin/sasla uthd -a pam
root 13563 0.0 4.0 34564 20920 ? S Mar06 0:01 kwrite [kdeinit ] kwrite /etc/postfix/sasl_passwd
root 15294 0.0 0.1 1796 636 pts/1 R+ 00:38 0:00 grep sasl



When I maked the user and password I used the following syntax

The account is user1@57.ro

useradd -d /home/user1 -g users user1
passwd user1

In /home I made a folder user1
I think its that's correct because I can login to IMAP.
Thank you again for your quick response and patience.

Last edited by mavgh1; 7th March 2006 at 00:15.
Reply With Quote
  #10  
Old 7th March 2006, 13:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by mavgh1
root 13563 0.0 4.0 34564 20920 ? S Mar06 0:01 kwrite [kdeinit ] kwrite /etc/postfix/sasl_passwd
What's that? Is it possible that kwrite hangs when you try to edit /etc/postfix/sasl_passwd?
I recommend to use vi on the command line to edit files: http://www.howtoforge.com/faq/12_15_en.html

Can you post the exact error message from your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Problems with receiving mail Kieran General 8 26th February 2006 18:17
Postfix mail is held in queue indefinitely... squallbsr Server Operation 9 15th January 2006 19:13
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20


All times are GMT +2. The time now is 05:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.