Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th August 2005, 02:13
marketingmaven marketingmaven is offline
Junior Member
 
Join Date: Aug 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Suse 9.3 And ModReWrite

Hi everyone,

I am new the the Linux environment, but I have installed ISPConfig, and it has made my life a lot easier with operating my new Linux Box.

I am installing WordPress sites on the box, and one of the options I need is to enable Mod ReWrite.

I have Apache and everything else installed right as per the Suse 9.3 install faq on the ISPConfig site, but I am not sure how to enable it. Do I enable it on the server in httpd.conf or do I do it in ISPConfig for each site with the Apache Directives option (which I dont know how to use either)?

Anyway, everytime I try to invoke anything to do with Mod ReWrite with WordPress, the WordPress site no longer works until I delete .htaccess. Please help. I really am not sure what to do, or how to do it. Thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 17th August 2005, 14:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

From the howto:

Quote:
Edit /etc/sysconfig/apache2 and add rewrite to the APACHE_MODULES line:

APACHE_MODULES="access actions alias auth [...] setenvif ssl suexec userdir php4 php5 rewrite"

[...]

Then run

SuSEconfig
/etc/init.d/apache2 start
Then mod_rewrite is enabled.
You can then define rewrite conditions/rules in an .htaccess file, in the Apache Directives field in ISPConfig or by using the forward mechanism for Co-Domains (forwarding uses rewrite rules).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th August 2005, 17:09
thevinster thevinster is offline
Junior Member
 
Join Date: Aug 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Similar problem on Wikka

I'm trying to install Wikka, and the .htaccess file reads:

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.*/[^\./]*[^/])$ $1/
RewriteRule ^(.*)$ wikka.php?wakka=$1 [QSA,L]
</IfModule>


This keeps giving me a 403 error. It looks like a common problem, along with the people trying to set up Drupal.

Any suggestions?
Reply With Quote
  #4  
Old 17th August 2005, 17:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Quote:
Originally Posted by thevinster
I'm trying to install Wikka, and the .htaccess file reads:

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.*/[^\./]*[^/])$ $1/
RewriteRule ^(.*)$ wikka.php?wakka=$1 [QSA,L]
</IfModule>


This keeps giving me a 403 error. It looks like a common problem, along with the people trying to set up Drupal.

Any suggestions?
Have a look at this thread: http://www.howtoforge.com/forums/showthread.php?t=38
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 17th August 2005, 17:39
marketingmaven marketingmaven is offline
Junior Member
 
Join Date: Aug 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
From the howto:



Then mod_rewrite is enabled.
You can then define rewrite conditions/rules in an .htaccess file, in the Apache Directives field in ISPConfig or by using the forward mechanism for Co-Domains (forwarding uses rewrite rules).
Thanks Falko. I guess I did that when setting up ISPConfig, just didnt know how to activate it. So let me see if I understand this. I dont actually upload a .htaccess file to the directory I need it in, I just set the define the rewrite rules in a .htacces file and put that file in the Apache Directives Field? Thanks in advance.

Oh, I need the .htaccess in a subfolder of the main site it seems. Do I still put the .htaccess file in the Apache Directives Field? When I upload the .htaccess file directly to the subfolder, the site fails. When I delete it, everything is fine again. Thanks.

Last edited by marketingmaven; 17th August 2005 at 17:57.
Reply With Quote
  #6  
Old 17th August 2005, 19:05
thevinster thevinster is offline
Junior Member
 
Join Date: Aug 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko

Falko,

That is the thread I was referring to in my post. I still don't completely understand how to modify the .htaccess system for these scripts. I am currently having trouble with Helpcenterlive as well.

The .htaccess file reads:

php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728


Only if I delete the .htaccess file is it working.
Reply With Quote
  #7  
Old 17th August 2005, 19:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

Quote:
Originally Posted by thevinster
Falko,

That is the thread I was referring to in my post. I still don't completely understand how to modify the .htaccess system for these scripts. I am currently having trouble with Helpcenterlive as well.

The .htaccess file reads:

php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728


Only if I delete the .htaccess file is it working.
Have you tried to put exactly this

Code:
php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728
in the apache directives field of the ISPConfig site?
Reply With Quote
  #8  
Old 17th August 2005, 19:16
thevinster thevinster is offline
Junior Member
 
Join Date: Aug 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Have you tried to put exactly this

Code:
php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728
in the apache directives field of the ISPConfig site?
Hi Till,

Yes I have. It works of course. But if I wanted to isolate those instructions to one particular directory, say /home/www/web150/web/seperate_directory, how would I do that?
Reply With Quote
  #9  
Old 17th August 2005, 19:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Quote:
Originally Posted by thevinster
Hi Till,

Yes I have. It works of course. But if I wanted to isolate those instructions to one particular directory, say /home/www/web150/web/seperate_directory, how would I do that?
Like this:

Code:
<Location '/seperate_directory'>
  php_value upload_max_filesize 128M
  php_value post_max_size 128M
  LimitRequestBody 134217728
</Location>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 17th August 2005, 19:55
thevinster thevinster is offline
Junior Member
 
Join Date: Aug 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko
Like this:

Code:
<Location '/seperate_directory'>
  php_value upload_max_filesize 128M
  php_value post_max_size 128M
  LimitRequestBody 134217728
</Location>
Perfect!

Many thanks for this. ISPConfig is such an extremely useful piece of software, even if you're managing just one site on it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.