Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th November 2008, 17:33
algiss algiss is offline
Junior Member
 
Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig UPGRADE

tried to run installation dosen of times and it still fails at same point:

source:/root/install_ispconfig/
scripts:/root/ispconfig/
upgrading from 2.2.1 to 2.2.17

please advise on solution. thanks


Code:
Installing PHP SAPI module:       apache
[activating module `php5' in /root/ispconfig/httpd/conf/httpd.conf]
cp libs/libphp5.so /root/ispconfig/httpd/libexec/libphp5.so
chmod 755 /root/ispconfig/httpd/libexec/libphp5.so
cp /root/ispconfig/httpd/conf/httpd.conf 
/root/ispconfig/httpd/conf/httpd.conf.b 
ak
cp /root/ispconfig/httpd/conf/httpd.conf.new 
/root/ispconfig/httpd/conf/httpd.co 
nf
rm /root/ispconfig/httpd/conf/httpd.conf.new
Installing PHP CLI binary:        /root/ispconfig/php/bin/
Installing PHP CLI man page:      /root/ispconfig/php/man/man1/
Installing build environment:     /root/ispconfig/php/lib/php/build/
Installing header files:          /root/ispconfig/php/include/php/
Installing helper programs:       /root/ispconfig/php/bin/
  program: phpize
  program: php-config
Installing man pages:             /root/ispconfig/php/man/man1/
  page: phpize.1
  page: php-config.1
Installing PDO headers:          /root/ispconfig/php/include/php/ext/pdo/
/root/ispconfig/php/bin/php: error while loading shared libraries: 
libltdl.so.3:                                               cannot open 
shared object file: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your 
system! The installation routine stops here!
cd: error retrieving current directory: getcwd: cannot access parent 
directories: No such file or directory
Reply With Quote
Sponsored Links
  #2  
Old 6th November 2008, 13:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Please try 2.2.27 instead of 2.2.17.

Which distribution are you using?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th November 2008, 13:43
algiss algiss is offline
Junior Member
 
Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

as new panel is not accesible after upgrade failure, i cannot double check the version I was using before. How can I retrieve this information from source files?

And - yes - I was upgrading to most recent version 2.2.27
Reply With Quote
  #4  
Old 7th November 2008, 13:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Which distribution are you using?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th November 2008, 12:38
algiss algiss is offline
Junior Member
 
Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

using version: 2.2.19
so upgrading 2.2.19 to 2.2.27
Reply With Quote
  #6  
Old 10th November 2008, 12:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

No, I mean which Linux distribution are you using (e.g. Ubuntu 8.10, Debian Etch, Fedora 9, etc.)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 10th November 2008, 12:47
algiss algiss is offline
Junior Member
 
Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

CentOS Linux 5.2
Reply With Quote
  #8  
Old 11th November 2008, 14:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What are the outputs of
Code:
updatedb
locate libltdl
and
Code:
uname -a
?

Is SELinux disabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 11th November 2008, 15:10
algiss algiss is offline
Junior Member
 
Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
# updatedb
# locate libltdl
/root/Installs/OLD/courier-authlib-0.60.2/libltdl
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/.libs
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/COPYING.LIB
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/Makefile
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/Makefile.am
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/Makefile.in
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/README
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/acinclude.m4
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/aclocal.m4
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/config-h.in
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/config.guess
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/config.h
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/config.log
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/config.status
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/config.sub
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/configure
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/configure.ac
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/install-sh
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/libltdl.la
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/libtool
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/ltdl.c
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/ltdl.h
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/ltdl.lo
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/ltdl.o
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/ltmain.sh
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/missing
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/stamp-h1
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/.libs/libltdl.a
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/.libs/libltdl.la
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/.libs/libltdl.lai
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/.libs/libltdl.so
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/.libs/libltdl.so.3
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/.libs/libltdl.so.3.1.4
/root/Installs/OLD/courier-authlib-0.60.2/libltdl/.libs/ltdl.o
/usr/local/lib/libltdl.a
/usr/local/lib/libltdl.la
/usr/local/lib/libltdl.so
/usr/local/lib/libltdl.so.3
/usr/local/lib/libltdl.so.3.1.4
/usr/share/libtool/libltdl
/usr/share/libtool/libltdl/COPYING.LIB
/usr/share/libtool/libltdl/Makefile.am
/usr/share/libtool/libltdl/Makefile.in
/usr/share/libtool/libltdl/README
/usr/share/libtool/libltdl/acinclude.m4
/usr/share/libtool/libltdl/aclocal.m4
/usr/share/libtool/libltdl/config-h.in
/usr/share/libtool/libltdl/config.guess
/usr/share/libtool/libltdl/config.sub
/usr/share/libtool/libltdl/configure
/usr/share/libtool/libltdl/configure.ac
/usr/share/libtool/libltdl/install-sh
/usr/share/libtool/libltdl/ltdl.c
/usr/share/libtool/libltdl/ltdl.h
/usr/share/libtool/libltdl/ltmain.sh
/usr/share/libtool/libltdl/missing
Code:
uname -a
Linux *my*domain*.com 2.6.18-92.1.13.el5.centos.plus #1 SMP Wed Oct 1 13:42:29 EDT 2008 i686 i686 i386 GNU/Linux
Reply With Quote
  #10  
Old 11th November 2008, 16:01
algiss algiss is offline
Junior Member
 
Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

SElinux Disabled
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade has taken ISPConfig offline, help! indie1982 Installation/Configuration 2 9th September 2008 20:18
ISPconfig after installation cannot reach www.xyz.de:81 Figth4Linux Installation/Configuration 23 6th March 2008 22:38
Upgrade to PHP 5.2.4 in Debian Etch + ISPConfig 2.2.18? jtwyrrpirate Installation/Configuration 2 1st November 2007 03:58
fastcgi and php with ispconfig tosser Tips/Tricks/Mods 3 25th June 2006 21:01
Upgrading failed, ispconfig broken and ispconfig won't upgrade again dfriis Installation/Configuration 7 14th June 2006 17:54


All times are GMT +2. The time now is 06:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.