Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th November 2008, 17:25
fdsg72-lux fdsg72-lux is offline
Junior Member
 
Join Date: Oct 2006
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Unhappy RoundCube Webmail "AllowOverride Options" Location

Hi there,

Background:
I completed the following How To's to setup fresh install of Ubuntu 8.10 with ISPConfig and RoundCube WebMail:

=> Ubuntu 8.10: http://www.howtoforge.com/perfect-server-ubuntu-8.10
=> ISPConfig post-install setup: http://www.howtoforge.com/ispconfig-2.x-first-steps-p3
=> RoundCube Webmail: http://www.howtoforge.com/roundcube_webmail_ispconfig

Issue:
With RoundCube Webmail I am hitting the issue with the PHP options in the .htaccess file giving "500 Internal Server Error". After researching this issue I accordingly modified the file /etc/apache2/vhosts/Vhosts_ispconfig.conf for the appropriate <VirtualHost ...> section for my website by updating the following line inside the section:

<IfModule mod_python.c>
<Directory /var/www/web4/web>":
...
</Directory>
</IfModule>

from

=> AllowOverride Indexes AuthConfig Limit FileInfo

to

=> AllowOverride Options Indexes AuthConfig Limit FileInfo

and then restart apache2 which resolves the issue momentarily.

The problem is that if I make any change via ISPConfig e.g. update a setting of the website, then the file /etc/apache2/vhosts/Vhosts_ispconfig.conf is regenerated and I loose my edit which then again breaks the RoundCube Webmail functionality.

Question:
Where is the correct location to make the change for my website so it will not get overwritten when I make changes via ISPConfig? I also tried adding the following all by itself within the <VirtualHost ...> section, both as the first and last entry within this section:

<Directory /var/www/web4/web>
AllowOverride Options
</Directory>

but it does not make any difference, only when I update existing definitions of the like

<IfModule ...>
<Directory /var/www/web4/web>
...
</Directory>
</IfModule>

does the change work.

Help:
Please tell me what exact change I have to make exactly where to resolve this issue?

Thanks,
Faan
Reply With Quote
Sponsored Links
  #2  
Old 13th November 2008, 13:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,779
Thanks: 840
Thanked 5,610 Times in 4,421 Posts
 
Default

Quote:
Where is the correct location to make the change for my website so it will not get overwritten when I make changes via ISPConfig?
You must add your changed code to the apache directives field in the website settings. Never edit the file Vhosts_ispconfig.conf manually!
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
allowoverride, ispconfig, roundcube, ubuntu 8.10

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
RoundCube Webmail On Your ISPConfig Server Within 10 Easy Steps SoMBS HOWTO-Related Questions 17 25th November 2010 14:19
configure quota webmail roundcube shynma Installation/Configuration 13 22nd October 2010 19:44
Fail to run roundcube webmail satimis Server Operation 1 28th September 2008 14:42
how to find webmail location on a private DNS lcdsolutions HOWTO-Related Questions 3 17th January 2008 17:45
RoundCube webmail contact list disapears. kanour Installation/Configuration 1 7th April 2007 14:53


All times are GMT +2. The time now is 15:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.