Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 18th August 2005, 16:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
Originally Posted by hkaiser
Hi,
this also do not work. I think the reason why it do not work is that the libaries are searched in /usr/lib but on an 64 bit system they are in /usr/lib64. Is it possible to change the directory setting in ispconfig from /usr/lib to usr/lib64? when I have tried to set the directive --with-zlib-dir=/usr/lib64/ i get the error that mysql can not be configured!? Please help me to find a solution! Thanks

hkaiser
Try to set --with-mysql=/usr to --with-mysql=/usr/lib64 in the PHP configure string and make shure you have mysql-devel packages installed. This is not a directory setting from ISPConfig, we use the source tarballs from the PHP project without modifications.

If you get ISPConfig installed successfully, please write down your modifications and post them to the forum, so we can extend the installer to work on 64bit systems correctly
Reply With Quote
Sponsored Links
  #12  
Old 19th August 2005, 11:26
hkaiser hkaiser is offline
Member
 
Join Date: Aug 2005
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

I want to post the conlusion out of the installation which i made now.

First of all I added this repositories to the /etc/yum.conf file

[DAG]
name=Dag APT Repository
baseurl=http://apt.sw.be/fedora/4/en/x86_64/dag/

[dries]
name=Extra Fedora rpms dries - $releasever - $basearch
baseurl=http://ftp.belnet.be/packages/dries.ulyssis.org/fedora/linux/4/x86_64/dries/RPMS/

Then I changed the word imap to cyrus-imap because imap do not exist in these repositories.

Before starting the installtion process do this, because mysql has a bug in the x86_64 which can only be fixed so.

mkdir /usr/local/lib/mysql

and create symlinks "include" and "lib" pointing to the original directories (here /usr/include/mysql and /usr/lib64/mysql)

cd /usr/local/lib/mysql
ln -s /usr/include/mysql include
ln -s /usr/lib64/mysql lib

During the installation i got a zlib error and a mysql errror and after a openssl error. Edit the file "compile" in the installation directory /install_ispconfig/compile_aps/ to look like this.

cd ../${PHP}
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
make || error "Could not make PHP"
make install || error "Could not install PHP"
ln -s ${INSTALL_ROOT}/php/bin/php ${INSTALL_ROOT}/php/php

Now I have a proftp error so I think i will switch to vsftp. Do someone think this i a good idea? Because of this error i do not know to which directory the files go. the files go to the installation of ispconfig /home/www or the go to the installation which is explained in the "Perfect installation setup" what means /var/www?

I am also not happy with cyrus. Dovecot seem to be preinstalled at fedora core 4 and is more secure. I will try to use this one because Dovecot has also IMAP and Pop3 included!

hkaiser
Reply With Quote
  #13  
Old 19th August 2005, 11:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
Originally Posted by hkaiser
Now I have a proftp error so I think i will switch to vsftp. Do someone think this i a good idea? Because of this error i do not know to which directory the files go. the files go to the installation of ispconfig /home/www or the go to the installation which is explained in the "Perfect installation setup" what means /var/www?
Thank you for posting your 64bit installation guide.

We recommend proftpd beacause it can handle multiple anonymous accounts per server which vsftpd doesent.

The files go to /home/www or any other directory, that depends on which directory you chose in the ISPConfig installer. The ISPConfig instaler asks for the directory only if you chose expert mode.
Reply With Quote
  #14  
Old 19th August 2005, 16:15
hkaiser hkaiser is offline
Member
 
Join Date: Aug 2005
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

everything works. Only that it is impossbile to log into the proftp server. The users exist in /etc/shadow. I turned off PamAuth and have even put the AuthUserFile directive into the proftp.conf file. But even when i telnet the server and give in the username(USER web5_herg) and the password(PASS password) the server do not want me to login.

I installed the server with "yum install proftpd". I change nothing on that the PamAuth is turned off.

I have no idea what i can do else? Does someone else have an idea what can be done?

hkaiser
Reply With Quote
  #15  
Old 19th August 2005, 16:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Please have a look here:
http://www.howtoforge.com/forums/showthread.php?t=196
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 19th August 2005, 16:50
hkaiser hkaiser is offline
Member
 
Join Date: Aug 2005
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

What I did , after I have recognized that i can not login form the GUI of ISPConfig

First of all in disabled the firewall and Selinux inlcude in Fedora Core 4. And after i tested the port with the portscanner of ISPConfig.
I opened a terminal on the server where i installed ISPConfig.
I looked up if the user is in /etc/shadow/. Yes the user is in the file shadow with encrypted password.

After this i open a connection with telnet to the ftp server.

telnet localhost 21

FTP Server output:
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 FTP Server ready.

I gave into the username and the password which I gave in into the ISPConfig control panel.

USER web5_herg
331 Password required for web5_herg.
PASS test
530 Login incorrect.

But i can even not log in. Even with a normal system user which i created i can not log in.
So I have no idea what i can do to make this work. if someone has an idea how to fix this problem please write an answer. Thanks.

hkaiser

Last edited by hkaiser; 19th August 2005 at 17:04.
Reply With Quote
  #17  
Old 19th August 2005, 17:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
Originally Posted by hkaiser
Hi,

What I did , after I have recognized that i can not login form the GUI of ISPConfig

First of all in disabled the firewall and Selinux inlcude in Fedora Core 4. And after i tested the port with the portscanner of ISPConfig.
I opened a terminal on the server where i installed ISPConfig.
I looked up if the user is in /etc/shadow/. Yes the user is in the file shadow with encrypted password.

After this i open a connection with telnet to the ftp server.

telnet localhost 21

FTP Server output:
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 FTP Server ready.

I gave into the username and the password which I gave in into the ISPConfig control panel.

USER web5_herg
331 Password required for web5_herg.
PASS test
530 Login incorrect.

But i can even not log in. Even with a normal system user which i created i can log in.
So I have no idea what i can do not make this work. if someone has an idea how to fix this problem please write an answer. Thanks.

hkaiser

Can you try to change the password for the user web5_herg with the passwd command on the shell and try to login.
Reply With Quote
  #18  
Old 19th August 2005, 17:28
hkaiser hkaiser is offline
Member
 
Join Date: Aug 2005
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

That's the output of it. The passwd command work, only the login to the ftp has problems.

[root@host1 ~]# passwd web5_herg
Changing password for user web5_herg.
New UNIX password:
Retype new UNIX password:
passwd: all authentication tokens updated successfully.
[root@host1 ~]# telnet localhost 21
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 FTP Server ready.
USER web5_herg
331 Password required for web5_herg.
PASS qwertzuiop
530 Login incorrect.

This is the content of the /etc/shadow file:
before:
web5_herg:he2GhqNDqOjiQ:13014:0:99999:7:::
now:
web5_herg:$1$tJ/VDGao$kq8kSJc7CYZ/t5/ZGssAe/:13014:0:99999:7:::
Reply With Quote
  #19  
Old 19th August 2005, 17:29
hkaiser hkaiser is offline
Member
 
Join Date: Aug 2005
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default

that's the information to the package form yum search proftp

proftpd.x86_64 1.2.10-8.2.fc4.rf dries
Matched from:
proftpd
ProFTPD is an enhanced FTP server with a focus toward simplicity, security,
and ease of configuration. It features a very Apache-like configuration
syntax, and a highly customizable server infrastructure, including support for
multiple 'virtual' FTP servers, anonymous FTP, and permission-based directory
visibility.

This package defaults to the standalone behaviour of ProFTPD, but all the
needed scripts to have it run by xinetd instead are included.

Available rpmbuild rebuild options :
--without : tls
--with : ldap mysql postgresql
http://www.proftpd.org/
Reply With Quote
  #20  
Old 20th August 2005, 09:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
 
Default

Quote:
Originally Posted by hkaiser
that's the information to the package form yum search proftp

proftpd.x86_64 1.2.10-8.2.fc4.rf dries
Matched from:
proftpd
ProFTPD is an enhanced FTP server with a focus toward simplicity, security,
and ease of configuration. It features a very Apache-like configuration
syntax, and a highly customizable server infrastructure, including support for
multiple 'virtual' FTP servers, anonymous FTP, and permission-based directory
visibility.

This package defaults to the standalone behaviour of ProFTPD, but all the
needed scripts to have it run by xinetd instead are included.

Available rpmbuild rebuild options :
--without : tls
--with : ldap mysql postgresql
http://www.proftpd.org/

This looks fine so far.

Do you have read the other threads concerning FTP login problems and tested the solutions? In short terms: you have to authenticate over PAM and make a correct pam auth file for FTP.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Support System Tribal-Dolphin Feature Requests 3 20th August 2005 08:59
Installing software using wine floppywhopper Suggest HOWTO 0 17th May 2005 12:38
Installing Perl modules fernando Installation/Configuration 1 10th May 2005 20:16


All times are GMT +2. The time now is 19:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.