Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd November 2008, 22:53
casest casest is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Mailbox directories not being created

I followed the instructions (http://www.howtoforge.com/virtual-us...ix-ubuntu-7.10) to create a Virtual Mail server using Postfix on Ubuntu 8.04. Installation went without any error other than the ones already noted in the howto for dcc, which I skipped over. The issue I seem to be having has to do with directory creation.

root@ubuntu-mail1:/etc/postfix# telnet localhost pop3
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK Hello there.
user sales@buduru.net
+OK Password required.
pass 123456
-ERR chdir buduru.net/sales/ failed
Connection closed by foreign host.
root@ubuntu-mail1:/etc/postfix#

I have tried creating these directories by hand; however, I eventually gave up and figured something must have been missed some where during the installation. Any assistance would be greatly appreciated.

Stephen
Reply With Quote
Sponsored Links
  #2  
Old 3rd November 2008, 16:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

http://www.howtoforge.com/virtual-us...ail-ubuntu8.04

You must send an email first to a new account before you fetch emails. Maildir is created automatically when the first email arrives.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th November 2008, 03:03
casest casest is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That makes sense, from what I can tell all the messages are backing up in the queue, any thoughts? the status message I see for each message in the queue is: delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused.

Thanks, Stephen
Reply With Quote
  #4  
Old 6th November 2008, 14:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

What's the output of
Code:
netstat -tap
? Make sure that amavisd is running.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 6th November 2008, 17:04
casest casest is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is the output.

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost:10025 *:* LISTEN -
tcp 0 0 localhost:mysql *:* LISTEN -
tcp 0 0 *:webmin *:* LISTEN -
tcp 0 0 *:www *:* LISTEN -
tcp 0 0 *:smtp *:* LISTEN -
tcp6 0 0 [::]:imaps [::]:* LISTEN -
tcp6 0 0 [::]op3s [::]:* LISTEN -
tcp6 0 0 [::]op3 [::]:* LISTEN -
tcp6 0 0 [::]:2222 [::]:* LISTEN -
tcp6 0 0 [::]:imap2 [::]:* LISTEN -
tcp6 0 52 192.168.1.3%134645:2222 192.168.1.8%8191:1272 ESTABLISHED -

As you were hinting to amavis was not running. When I try and start it manually I get the following error. Any ideas, currently I have the server at home while I get it ready to take down to the hosting facility where it will be given a fixed ip, fqdn and a listing in dns.

Starting amavisd: The value of variable $myhostname is "ubuntu-mail1", but should have been
a fully qualified domain name; perhaps uname(3) did not provide such.
You must explicitly assign a FQDN of this host to variable $myhostname
in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
network name!
(failed).

Thanks, Stephen
Reply With Quote
  #6  
Old 6th November 2008, 19:47
casest casest is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've edited 05-note_id as follows.

...
#chomp($myhostname = `hostname --fqdn`);
...
$myhostname = "buduru.net";
...

So far this has resolved the issue with amavisd not starting; however it brings up a new issue. I'm able to send email successfully but now they are just bouncing and being remove and as far as I can tell are no longer in the system. Here are the entries from /var/log/mail.info

Nov 6 09:30:23 ubuntu-mail1 postfix/qmgr[8115]: 6BC4C15A2222: from=<sales@buduru.net>, size=230273, nrcpt=1 (queue active)
Nov 6 09:30:23 ubuntu-mail1 postfix/smtpd[8505]: connect from localhost[127.0.0.1]
Nov 6 09:30:23 ubuntu-mail1 postfix/smtpd[8505]: E7F0015A2232: client=localhost[127.0.0.1]
Nov 6 09:30:23 ubuntu-mail1 postfix/cleanup[8501]: E7F0015A2232: message-id=<C2084DFE02E0446FBAAC1FECA4EDF6E8@EDIALT1>
Nov 6 09:30:23 ubuntu-mail1 postfix/qmgr[8115]: E7F0015A2232: from=<sales@buduru.net>, size=230695, nrcpt=1 (queue active)
Nov 6 09:30:23 ubuntu-mail1 postfix/smtpd[8505]: disconnect from localhost[127.0.0.1]
Nov 6 09:30:23 ubuntu-mail1 amavis[8422]: (08422-01) Passed CLEAN, LOCAL [192.168.1.8] [192.168.1.8] <sales@buduru.net> -> <sales@buduru.net>, Message-ID: <C2084DFE02E0446FBAAC1FECA4EDF6E8@EDIALT1>, mail_id: GZV7Sb1lZa9d, Hits: -, size: 230273, queued_as: E7F0015A2232, 293 ms
Nov 6 09:30:24 ubuntu-mail1 postfix/smtp[8502]: 6BC4C15A2222: to=<sales@buduru.net>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.58, delays=0.27/0.01/0.01/0.29, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as E7F0015A2232)
Nov 6 09:30:24 ubuntu-mail1 postfix/qmgr[8115]: 6BC4C15A2222: removed
Nov 6 09:30:24 ubuntu-mail1 postfix/smtp[8506]: E7F0015A2232: to=<sales@buduru.net>, relay=none, delay=0.19, delays=0.04/0.02/0.13/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=mail.buduru.net type=A: Host not found)
Nov 6 09:30:24 ubuntu-mail1 postfix/cleanup[8501]: 251A215A2237: message-id=<20081106173024.251A215A2237@ubuntu-mail1>
Nov 6 09:30:24 ubuntu-mail1 postfix/qmgr[8115]: 251A215A2237: from=<>, size=2969, nrcpt=1 (queue active)
Nov 6 09:30:24 ubuntu-mail1 postfix/bounce[8507]: E7F0015A2232: sender non-delivery notification: 251A215A2237
Nov 6 09:30:24 ubuntu-mail1 postfix/qmgr[8115]: E7F0015A2232: removed
Nov 6 09:30:24 ubuntu-mail1 postfix/smtp[8506]: 251A215A2237: to=<sales@buduru.net>, relay=none, delay=0.07, delays=0.03/0/0.03/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=mail.buduru.net type=A: Host not found)
Nov 6 09:30:24 ubuntu-mail1 postfix/qmgr[8115]: 251A215A2237: removed
Nov 6 09:30:26 ubuntu-mail1 postfix/smtpd[8497]: disconnect from unknown[192.168.1.8]
Nov 6 09:33:46 ubuntu-mail1 postfix/anvil[8499]: statistics: max connection rate 1/60s for (smtp:192.168.1.8) at Nov 6 09:30:23
Nov 6 09:33:46 ubuntu-mail1 postfix/anvil[8499]: statistics: max connection count 1 for (smtp:192.168.1.8) at Nov 6 09:30:23
Nov 6 09:33:46 ubuntu-mail1 postfix/anvil[8499]: statistics: max cache size 1 at Nov 6 09:30:23

Stephen
Reply With Quote
  #7  
Old 7th November 2008, 14:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Nov 6 09:30:24 ubuntu-mail1 postfix/smtp[8506]: 251A215A2237: to=<sales@buduru.net>, relay=none, delay=0.07, delays=0.03/0/0.03/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=mail.buduru.net type=A: Host not found)
Please create an A record for mail.buduru.net.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 7th November 2008, 15:46
casest casest is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Will do. I take it the system is automatically assuming the server will be called mail.buduru.net considering I only entered it as buduru.net during the setup.
Reply With Quote
  #9  
Old 11th November 2008, 07:35
hostchecker hostchecker is offline
Junior Member
 
Join Date: Oct 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

thats an odd one probably something simple though
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[postfix]550 ..: Recipient address rejected: User unknown in virtual mailbox table RdeWilde Installation/Configuration 28 31st July 2008 20:14
default directories created bigger_travis Installation/Configuration 2 6th March 2008 20:53
Failure on Test Virtual Mailbox Setup satimis Server Operation 2 10th November 2007 04:44
Virtual Mailbox Domain psychomonkey General 1 22nd March 2006 09:14
postfix config jmroth Installation/Configuration 6 18th September 2005 16:58


All times are GMT +2. The time now is 21:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.