#1  
Old 6th March 2006, 01:05
Piccent Piccent is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Question Default Host "www" ???

Hi,

I set all my domains, that are hosted on my server with no hostname, because my Webmailclient needs the Mailadress with no "www". Can I stop the ISPConfig gives as default host the "www"? And the bigger problem, can I stop that ISPConfig automatically puts "www" into the host space every time I chance the settings of the page???

Greetz Marc
Reply With Quote
Sponsored Links
  #2  
Old 6th March 2006, 08:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

Cant you put a co-domain without www as co-domain on the website or do you read the isp_isp_web table directly from your webmail client?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th March 2006, 17:00
Piccent Piccent is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The webmail client reads the virtusertable and takes the first alias... :-( it was always info@www.1234.de and now (with main host blank) its info@1234.de.
Reply With Quote
  #4  
Old 6th March 2006, 19:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

What exactly is the problem now?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th March 2006, 01:49
Piccent Piccent is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The problem is, every time I chance s.th. at the site-settings, for host "www" is filled in, and the domain is set from 1234.com to www.1234.com.
Reply With Quote
  #6  
Old 7th March 2006, 08:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

You can change this only by editing the form with the form designer.

1) Make a backup of your ISPConfig database with phpmyadmin.

2) In ISPConfig, go to management > form designer > edit form, now click on edit for the "ISP - isp web" form, then click on edit on the "web_host" field, remove the value "www" in the Default field and hit safe.

When you create new websites without host www, you will have to edit the automatically created co-domain and set the host there to www.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 7th March 2006, 13:36
Piccent Piccent is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Great, thx...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to go next? DNS questions? Default Website? NetDreamz Installation/Configuration 1 29th October 2005 12:53
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 18:54
default virtual host jmroth Installation/Configuration 3 17th September 2005 21:29
webpages only display default site bosei Installation/Configuration 9 9th September 2005 22:25
my default webserver failed Venkatesh.S General 1 25th July 2005 11:11


All times are GMT +2. The time now is 20:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.