Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th November 2008, 19:10
loonies loonies is offline
Junior Member
 
Join Date: Sep 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Named hangs to start when I add new site

Hi!

Fedora 8
ISPconfig 2.2.21

I know this is not updated version of ISPconfig.
Googling with no luck.

---
Today, upon adding new site, ISPconfig fails to start named daemon.

I started to tracing down the problem.

It seems that path for named zone file, for some stranege reason, changed its value in table isp_server (db_ispconfig database).

I first took a look in /home/admispconfig/ispconfig/ispconfig.log, tried to manually start named.
As it hangs, I looked under /var/named/chroot/var/named/ directory and noticed there is zone file missing.
If I create zone file manually, everything is normal and named starts.
I tried to change permissinons under /var/named, but with same problem.
After that I started some debugging until I solved problem.

Entry in table isp_server looked like this:
atrribute: server_bind_zonefile_dir
value: /home/admispconfig/ispconfig/web/multidoc/edit

and output

Code:
# ls -l /home/admispconfig/ispconfig/web/multidoc/edit
-rwxr-xr-x 1 admispconfig admispconfig  2769 2008-03-20 14:52 delete.php
-rwxr-xr-x 1 admispconfig admispconfig 31702 2008-03-20 14:52 edit.php
-rwxr-xr-x 1 admispconfig admispconfig  2021 2008-03-20 14:52 empty_trash.php
-rw-r--r-- 1 root         root          2516 2008-10-30 13:20 named.ca
-rw-r--r-- 1 root         root           256 2008-10-30 13:20 named.local
-rwxr-xr-x 1 admispconfig admispconfig  3649 2008-03-20 14:52 new_switch.php
-rwxr-xr-x 1 admispconfig admispconfig  2190 2008-03-20 14:52 node_insert.php
-rwxr-xr-x 1 admispconfig admispconfig  7167 2008-03-20 14:52 node.php
-rwxr-xr-x 1 admispconfig admispconfig  6048 2008-03-20 14:52 papierkorb.php
-rw-r--r-- 1 named        named         1038 2008-11-04 10:24 pri.domain1.com
-rw-r--r-- 1 named        named          861 2008-10-30 13:20 pri.domain2.com
-rw-r--r-- 1 named        named          861 2008-10-30 13:20 pri.domain3.com
-rw-r--r-- 1 named        named        10397 2008-11-04 16:03 pri.reverseIP.in-addr.arpa
-rw-r--r-- 1 named        named        10481 2008-11-04 16:03 pri.reverseIP.in-addr.arpa~
...

Best regards,
loony

P.S. to developers:
Please make code comment in english.
Reply With Quote
Sponsored Links
  #2  
Old 5th November 2008, 11:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

The permissions of the bind directory are wrong. Please redo the bind configuration steps from the perfect setup guide and then correct the bind path in ISPConfig under administration > server > settings
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th November 2008, 11:22
loonies loonies is offline
Junior Member
 
Join Date: Sep 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till!

Thanks for your answer!

I already solved problem before my first posting.

For me, it was strange that path in DB changed for no reason. I rearly login as admin user into ISPconfig admin panel.


Quote:
Please redo the bind configuration steps from the perfect setup guide
It was first thing I thought about
But then problem persisted, so I folowed code in writeconfig.php, looked into DB and saw wrong path.

Sugesstion for isp_server table in ISPconfig DB,
Instead of:
-----------------------------------------
| setting 1 | set 2 | set 3 | ..... | set n |
-----------------------------------------
| value 1 | val 2 | val 3 | ..... | val n |
-----------------------------------------

Make it:
---------------------
| setting 1 | value 1 |
---------------------
| setting 2 | value 2 |
---------------------
| setting 3 | value 3 |
---------------------
...
...
---------------------
| setting n | value n |
---------------------

It would be easier to maintain table. (Don't know how ISP3 table looks like.)


Best regards,
loony
Reply With Quote
  #4  
Old 7th November 2008, 10:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

Quote:
For me, it was strange that path in DB changed for no reason.
Thats normal in ISPConfig. It happens when the ISPConfig interface is not able anymore to access the bind directories.

The problem is the fedora bind package. When you install a updated bind rpm in fedora or centos, the rpm messes up the permissions. Other distributions, even rpm based like suse are able to handle bind updates without changing the permissions.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
About reverse DNS lrider General 29 9th March 2009 10:08
"Too many open files in system" problems Berry Installation/Configuration 3 10th November 2007 22:58
dns server error Hellbound General 7 2nd August 2007 10:18
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error Hellbound General 4 7th January 2007 12:50
DNS: Multiple IPs, want to setup a "private" nameserver on each IP for resellers bpmee Server Operation 8 17th September 2006 10:35


All times are GMT +2. The time now is 02:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.