Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd March 2006, 13:53
Qrup Qrup is offline
Member
 
Join Date: Feb 2006
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mailheader problem after upgrade to 2.2.0

Hi,

A user on my system gets the below problem when sending a mail with an attachment. I (successfully) upgraded the webmail again today because another recent post suggested this solution. Still the user gets this error:

Warning: Header may not contain more than a single header, new line detected. in /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau.php on line 467

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau.php:467) in /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau.php on line 469


I hope you can help me..
Reply With Quote
Sponsored Links
  #2  
Old 2nd March 2006, 17:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Open /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau.php and change
PHP Code:
header("Content-Type: $content_type; name=\"$filename\"\r\n"
                        
."Content-Length: $filesize\r\n"); 
to

PHP Code:
header("Content-Type: $content_type; name=\"$filename\"");
header("Content-Length: $filesize"); 
I will update the webmail.pkg on ispconfig.org soon.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd March 2006, 00:17
Qrup Qrup is offline
Member
 
Join Date: Feb 2006
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Problem solved!

Changes applied and tested. Everthing seems to work as expected.

I really appreciate your help. Thanks alot
Reply With Quote
  #4  
Old 3rd March 2006, 17:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

I've uploaded a new webmail.pkg to www.ispconfig.org.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd March 2006, 17:38
teleriddler teleriddler is offline
Junior Member
 
Join Date: Dec 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Question Getting Header Errors after Upgrade to 2.2.0 as well

When my users login to Webmail they get the following error at the top of their page.

Code:
Warning: Header may not contain more than a single header, new line detected. in /home/admispconfig/ispconfig/web/webmail/inc/inc.php on line 136
Upon logging out of Webmail they get these errors

Code:
Warning: Header may not contain more than a single header, new line detected. in /home/admispconfig/ispconfig/web/webmail/inc/inc.php on line 136

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/webmail/inc/inc.php:136) in /home/admispconfig/ispconfig/web/webmail/logout.php on line 73

Just wondering if anyone has encountered this yet. Everything appears to be working fine, this just seems like a cosmetic issue but I thought I would bring it to attention.

TeleRiddler

*******Just read post in the other forum, reinstalling webmail package fixes this error. Sorry for not checking sooner*************

Last edited by teleriddler; 3rd March 2006 at 17:41.
Reply With Quote
  #6  
Old 3rd March 2006, 18:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Uninstall the old webmail package:
Code:
rm -fr /home/admispconfig/ispconfig/temp/webmail
rm -fr /home/admispconfig/ispconfig/web/webmail
rm -fr /home/admispconfig/ispconfig/web/tools/tools/webmail
and install the new webmail package from ispconfig.org: http://www.ispconfig.org/downloads/webmail.pkg
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 18th March 2006, 02:18
Martin1982 Martin1982 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thank you for the solution, just changing the header lines wasn't enough, but an installation of the new package did the trick.
Reply With Quote
  #8  
Old 22nd March 2006, 19:42
tone tone is offline
Junior Member
 
Join Date: Mar 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default cannot download attachments!!!

Hello,
Can you help me with this please:
1. cannot download attachments from Uebimiau. I had have the same problem and changed the headers as you post it. The problem now is that i cannot use "save target as..." to save the attachment NOR open it to view it except for Images!!!

2. What changes should i have to do to enable outlook express or microsoft Outlook to access the server remotely and send messages? I think there is something wrong with SASL auth cause when i enable "My Server Requires Authentication" the request for username and password keeps showing and rejects the account username and password??? Please Help

thanks alot ...
Tone
Reply With Quote
  #9  
Old 22nd March 2006, 23:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,736
Thanks: 840
Thanked 5,597 Times in 4,408 Posts
Default

Quote:
Originally Posted by tone
1. cannot download attachments from Uebimiau. I had have the same problem and changed the headers as you post it. The problem now is that i cannot use "save target as..." to save the attachment NOR open it to view it except for Images!!!
Which browser do you use? Please try firefox or netscape.

Quote:
2. What changes should i have to do to enable outlook express or microsoft Outlook to access the server remotely and send messages? I think there is something wrong with SASL auth cause when i enable "My Server Requires Authentication" the request for username and password keeps showing and rejects the account username and password??? Please Help
Which errors do you get in your mail log?

By the way, please make a new thread if you want to ask questions for a new topic.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 23rd April 2006, 18:05
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
 
Default

When I try to log in whith a wrong password I also get this messege:

Code:
Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau_mail.php:61) in /home/admispconfig/ispconfig/web/webmail/msglist.php on line 65
This change I've already done:
Quote:
header("Content-Type: $content_type; name=\"$filename\"");
header("Content-Length: $filesize");
I'm using the latest release of uebimiau_mail, ISPConfig 2.2.1 and the latests release of firefox.

tom

Last edited by tom; 23rd April 2006 at 18:16.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
problem after upgrade to ispconfig 2.2.0 adrenalinic Installation/Configuration 6 1st March 2006 21:19
problem after upgrade to ispconfig 2.2.0 adrenalinic General 1 1st March 2006 21:11
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 02:56
Big unespected problem in upgrade!!! donaldblake Installation/Configuration 6 6th December 2005 23:31


All times are GMT +2. The time now is 03:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.