Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th November 2008, 09:37
kalua kalua is offline
Member
 
Join Date: Oct 2008
Posts: 30
Thanks: 3
Thanked 0 Times in 0 Posts
Default apache directive for https vhost

How would I define an apache directive for the https host with ISPConfig?

Currently I add an directive by hand but if ISPConfig rewrites the vhost file any manual changes are reverted.
Reply With Quote
Sponsored Links
  #2  
Old 5th November 2008, 10:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,268 Times in 4,130 Posts
Default

The vhost for SSL is added automatically by ISPConfig when SSL is enabled for the website. The last time I tested it it worked for me. If this does not work on your server, please post a request in the bugtracker.

The vhost file shall not be edited manually and ISPConfig will remove any manual changes.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 5th November 2008, 10:29
kalua kalua is offline
Member
 
Join Date: Oct 2008
Posts: 30
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
The vhost for SSL is added automatically by ISPConfig when SSL is enabled for the website.
Then it works as intended.

For the "non-ssl-host" I can add apache directives using ISPConfig. Why souldn't I be able to do it for the ssl-host?

I have set up a site with ISPConfig and I want to redirect some urls from http to https. The redirect is working but the apps I want to acces need some ScriptAlias to work properly. Thats the background for my question.
Reply With Quote
  #4  
Old 5th November 2008, 10:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,268 Times in 4,130 Posts
 
Default

The apache directive variable was missing in the sll vhost. I added it now.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
kalua (5th November 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd + MySQL virtual users, can't connect geekman HOWTO-Related Questions 28 27th September 2010 18:03
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Can't start apache Musty Server Operation 12 9th March 2008 13:58
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 02:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.