Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 10th November 2008, 04:25
VanDaMe VanDaMe is offline
Junior Member
 
Join Date: Oct 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Looks ok. Have you tried to restart Postfix and Saslauthd?
Yes already for many times.

Seems that the email program can't auth to the server.
I tried to auth by telnet localhost 25

it's auth-ing succesfully
Reply With Quote
Sponsored Links
  #12  
Old 10th November 2008, 12:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Not sure what it is, but I'd compare all configuration files with the ones from the tutorial again. Maybe there's a small typo somewhere.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 11th November 2008, 08:48
VanDaMe VanDaMe is offline
Junior Member
 
Join Date: Oct 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

also my postfix is being used for spam
Note : I removed 127.0.0.1 from my networks. Because I don't use webmail at all

here's what I found on logs

Code:
Nov 11 14:45:20 mp-fs-13 postfix/smtpd[17200]: lost connection after DATA from localhost[127.0.0.1]
Nov 11 14:45:20 mp-fs-13 postfix/smtpd[17200]: disconnect from localhost[127.0.0.1]
Nov 11 14:45:59 mp-fs-13 postfix/smtpd[17200]: connect from localhost[127.0.0.1]
Nov 11 14:46:42 mp-fs-13 postfix/smtpd[17200]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <mortiz@pace.edu.com>: Relay access denied; from=<WebsitePromotions400@deanfoods.com> to=<mortiz@pace.edu.com> proto=SMTP helo=<127.0.0.1>
Nov 11 14:46:48 mp-fs-13 postfix/smtpd[17200]: disconnect from localhost[127.0.0.1]
Nov 11 14:47:12 mp-fs-13 postfix/smtpd[17260]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <dreeve@air7seas.com>: Relay access denied; from=<jhailey_vn@shentel.net> to=<dreeve@air7seas.com> proto=ESMTP helo=<gdiqbjvu>
Nov 11 14:47:12 mp-fs-13 postfix/smtpd[17260]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <eshaw@air7seas.com>: Relay access denied; from=<jhailey_vn@shentel.net> to=<eshaw@air7seas.com> proto=ESMTP helo=<gdiqbjvu>
Nov 11 14:47:12 mp-fs-13 postfix/smtpd[17260]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <lipsett@air7seas.com>: Relay access denied; from=<jhailey_vn@shentel.net> to=<lipsett@air7seas.com> proto=ESMTP helo=<gdiqbjvu>
Nov 11 14:47:12 mp-fs-13 postfix/smtpd[17260]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <jackcoke70@air7seas.com>: Relay access denied; from=<jhailey_vn@shentel.net> to=<jackcoke70@air7seas.com> proto=ESMTP helo=<gdiqbjvu>
Nov 11 14:47:12 mp-fs-13 postfix/smtpd[17260]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <jmegphib@air7seas.com>: Relay access denied; from=<jhailey_vn@shentel.net> to=<jmegphib@air7seas.com> proto=ESMTP helo=<gdiqbjvu>
Nov 11 14:47:12 mp-fs-13 postfix/smtpd[17260]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <emiv@air7seas.com>: Relay access denied; from=<jhailey_vn@shentel.net> to=<emiv@air7seas.com> proto=ESMTP helo=<gdiqbjvu>
Nov 11 14:47:12 mp-fs-13 postfix/smtpd[17260]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <emvoras@air7seas.com>: Relay access denied; from=<jhailey_vn@shentel.net> to=<emvoras@air7seas.com> proto=ESMTP helo=<gdiqbjvu>
Nov 11 14:47:12 mp-fs-13 postfix/smtpd[17260]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <fjw@air7seas.com>: Relay access denied; from=<jhailey_vn@shentel.net> to=<fjw@air7seas.com> proto=ESMTP helo=<gdiqbjvu>
Nov 11 14:47:12 mp-fs-13 postfix/smtpd[17260]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1 <micros@air7seas.com>: Relay access denied; from=<jhailey_vn@shentel.net> to=<micros@air7seas.com> proto=ESMTP helo=<gdiqbjvu>
Nov 11 14:47:18 mp-fs-13 postfix/smtpd[17260]: lost connection after DATA from localhost[127.0.0.1]
Nov 11 14:47:18 mp-fs-13 postfix/smtpd[17260]: disconnect from localhost[127.0.0.1]
It seems there's a hole inside the server? So that the user can send email from localhost?
Reply With Quote
  #14  
Old 12th November 2008, 13:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

It says Relay access denied which means spammers tried to abuse your server, but they did not succeed. Nothing to worry about here.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 13th November 2008, 08:26
VanDaMe VanDaMe is offline
Junior Member
 
Join Date: Oct 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I don't care about that.. It's because I removed 127.0.0.1 from mynetwork.

So how about the authentication issue?

I do saslfinger -c

here's the output
Code:
saslfinger - postfix Cyrus sasl configuration Thu Nov 13 16:44:01 WIT 2008
version: 1.0.2
mode: client-side SMTP AUTH

-- basics --
Postfix: 2.3.8
System: Debian GNU/Linux 4.0 \n \l

-- smtp is linked to --
        libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xb7dbe000)

-- active SMTP AUTH and TLS parameters for smtp --
relayhost =
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache


-- listing of /usr/lib/sasl2 --
total 791
drwxr-xr-x  2 root root  1392 2008-09-29 09:12 .
drwxr-xr-x 54 root root 14504 2008-11-12 15:24 ..
-rw-r--r--  1 root root 13304 2006-12-14 04:26 libanonymous.a
-rw-r--r--  1 root root   855 2006-12-14 04:26 libanonymous.la
-rw-r--r--  1 root root 12844 2006-12-14 04:26 libanonymous.so
-rw-r--r--  1 root root 12844 2006-12-14 04:26 libanonymous.so.2
-rw-r--r--  1 root root 12844 2006-12-14 04:26 libanonymous.so.2.0.22
-rw-r--r--  1 root root 15502 2006-12-14 04:26 libcrammd5.a
-rw-r--r--  1 root root   841 2006-12-14 04:26 libcrammd5.la
-rw-r--r--  1 root root 15052 2006-12-14 04:26 libcrammd5.so
-rw-r--r--  1 root root 15052 2006-12-14 04:26 libcrammd5.so.2
-rw-r--r--  1 root root 15052 2006-12-14 04:26 libcrammd5.so.2.0.22
-rw-r--r--  1 root root 46320 2006-12-14 04:26 libdigestmd5.a
-rw-r--r--  1 root root   864 2006-12-14 04:26 libdigestmd5.la
-rw-r--r--  1 root root 43040 2006-12-14 04:26 libdigestmd5.so
-rw-r--r--  1 root root 43040 2006-12-14 04:26 libdigestmd5.so.2
-rw-r--r--  1 root root 43040 2006-12-14 04:26 libdigestmd5.so.2.0.22
-rw-r--r--  1 root root 13482 2006-12-14 04:26 liblogin.a
-rw-r--r--  1 root root   835 2006-12-14 04:26 liblogin.la
-rw-r--r--  1 root root 13384 2006-12-14 04:26 liblogin.so
-rw-r--r--  1 root root 13384 2006-12-14 04:26 liblogin.so.2
-rw-r--r--  1 root root 13384 2006-12-14 04:26 liblogin.so.2.0.22
-rw-r--r--  1 root root 29300 2006-12-14 04:26 libntlm.a
-rw-r--r--  1 root root   829 2006-12-14 04:26 libntlm.la
-rw-r--r--  1 root root 28776 2006-12-14 04:26 libntlm.so
-rw-r--r--  1 root root 28776 2006-12-14 04:26 libntlm.so.2
-rw-r--r--  1 root root 28776 2006-12-14 04:26 libntlm.so.2.0.22
-rw-r--r--  1 root root 13818 2006-12-14 04:26 libplain.a
-rw-r--r--  1 root root   835 2006-12-14 04:26 libplain.la
-rw-r--r--  1 root root 13992 2006-12-14 04:26 libplain.so
-rw-r--r--  1 root root 13992 2006-12-14 04:26 libplain.so.2
-rw-r--r--  1 root root 13992 2006-12-14 04:26 libplain.so.2.0.22
-rw-r--r--  1 root root 21726 2006-12-14 04:26 libsasldb.a
-rw-r--r--  1 root root   856 2006-12-14 04:25 libsasldb.la
-rw-r--r--  1 root root 17980 2006-12-14 04:26 libsasldb.so
-rw-r--r--  1 root root 17980 2006-12-14 04:26 libsasldb.so.2
-rw-r--r--  1 root root 17980 2006-12-14 04:26 libsasldb.so.2.0.22
-rw-r--r--  1 root root 23576 2006-12-14 04:26 libsql.a
-rw-r--r--  1 root root   964 2006-12-14 04:26 libsql.la
-rw-r--r--  1 root root 23072 2006-12-14 04:26 libsql.so
-rw-r--r--  1 root root 23072 2006-12-14 04:26 libsql.so.2
-rw-r--r--  1 root root 23072 2006-12-14 04:26 libsql.so.2.0.22


Cannot find the smtp_sasl_password_maps parameter in main.cf.
Client-side SMTP AUTH cannot work without this parameter!
How can I fix this?

Last edited by VanDaMe; 13th November 2008 at 10:44.
Reply With Quote
  #16  
Old 14th November 2008, 12:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Did you compare the configuration files?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 17th November 2008, 05:29
VanDaMe VanDaMe is offline
Junior Member
 
Join Date: Oct 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes already.. here's the full config of main.cf file
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = yes

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = xmail.seleb.tv
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = localhost, localhost.localdomain

relayhost =
mynetworks = 10.50.12.0/24
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname
smtpd_error_sleep_time = 5s
smtpd_soft_error_limit = 10
smtpd_hard_error_limit = 20
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
broken_sasl_auth_clients = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
mydomain = my.domain.com
Is there somethink I'm missing?
Reply With Quote
  #18  
Old 17th November 2008, 12:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's in /etc/pam.d/smtp?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 19th November 2008, 04:11
VanDaMe VanDaMe is offline
Junior Member
 
Join Date: Oct 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

on /etc/pam.d/smtp

Code:
auth    required   pam_mysql.so user=mail_admin passwd=mail_admin_password host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
account sufficient pam_mysql.so user=mail_admin passwd=mail_admin_password host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
Reply With Quote
  #20  
Old 20th November 2008, 20:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Looks ok. I have no idea what's wrong...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 05:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.