Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st November 2008, 11:11
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Hi falko,

there are both:

mywebsite.net
www.mywebsite.net


thanks
Reply With Quote
Sponsored Links
  #12  
Old 2nd November 2008, 14:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,715 Times in 2,557 Posts
Default

Please check if the MX record for mywebsite.net is pointing to the correct server:
Code:
dig mx mywebsite.net
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 3rd November 2008, 18:33
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

; <<>> DiG 9.3.4-P1 <<>> mx mywebsite.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11522
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

;; QUESTION SECTION:
;mywebsite.net. IN MX

;; ANSWER SECTION:
mywebsite.net. 43200 IN MX 5 mail.mywebsite.net.

;; AUTHORITY SECTION:
mywebsite.net. 26875 IN NS dns2.server.com.
mywebsite.net. 26875 IN NS dns1.server.com.

;; ADDITIONAL SECTION:
mail.mywebsite.net. 43200 IN A 100.22.66.33
dns1.server.com. 43178 IN A 194.242.61.26
dns2.server.com. 43178 IN A 194.242.61.27

;; Query time: 10 msec
;; SERVER: 212.97.32.2#53(212.97.32.2)
;; WHEN: Mon Nov 3 18:54:31 2008
;; MSG SIZE rcvd: 151


thanks

Last edited by vaio1; 3rd November 2008 at 18:57.
Reply With Quote
  #14  
Old 3rd November 2008, 18:53
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Inside the maillog there are these rows:

Code:
Nov  2 05:52:39 myserver postfix/qmgr[11709]: warning: mail for localhost.localdomain.mymaindomain.com is using up 8588 of 8954 active queue entries
Nov  2 05:52:39 myserver postfix/qmgr[11709]: warning: you may need a separate master.cf transport for localhost.localdomain.mymaindomain.com
Nov  2 05:52:39 myserver postfix/qmgr[11709]: warning: please avoid flushing the whole queue when you have
Nov  2 05:52:39 myserver postfix/qmgr[11709]: warning: lots of deferred mail, that is bad for performance
Nov  2 05:52:39 myserver postfix/qmgr[11709]: warning: to turn off these warnings specify: qmgr_clog_warn_time = 0
Nov  2 05:52:39 myserver postfix/smtpd[13384]: disconnect from myserver.mymaindomain.com[127.0.0.1]
Reply With Quote
  #15  
Old 4th November 2008, 14:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,715 Times in 2,557 Posts
Default

Quote:
Originally Posted by mturillo View Post
mail.mywebsite.net. 43200 IN A 100.22.66.33
Is this the correct IP?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 4th November 2008, 15:14
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

No it is only a sample ip but what is the problem?
what is the main troubleshoot in these cases?
Reply With Quote
  #17  
Old 4th November 2008, 19:18
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Found in these forum:

Code:
Code:

smtp_sasl_auth_enable = yes

Code:

smtpd_sasl_auth_enable = yes
The omission of the letter 'd' there has made my life very difficult, but that's the answer to the fatal error in the log file.
Reply With Quote
  #18  
Old 4th November 2008, 19:53
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Now the emails are sent by the server but now I have received this message by email:

Code:
<admispconfig@localhost.localdomain.mywebsite.net>: mail for localhost.localdomain.mywebsite.net loops back to myself
thanks
Reply With Quote
  #19  
Old 5th November 2008, 17:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,715 Times in 2,557 Posts
 
Default

Please add
localhost.localdomain.mywebsite.net
at the end of /etc/postfix/local-host-names and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
mturillo (9th February 2009)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I can send emails, but not receive adobe Installation/Configuration 7 25th June 2010 20:22
postfix/email problems...will not send emails out plathw Server Operation 13 28th November 2007 16:04
Centos 4.4 ISPconfig I cant recive emails from out. polikarp General 17 29th March 2007 04:34
isp doesnt allow to send emails munika Installation/Configuration 6 1st December 2006 15:59
send and receve mail on centos 4.3 tesquenure Installation/Configuration 11 25th April 2006 21:15


All times are GMT +2. The time now is 15:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.