Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th April 2006, 11:26
Martin1982 Martin1982 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default Directory Listing for certain directories

Is it possible to set the directory listing to "on" for certain websites on self-specified folders? And if yes, how?
__________________
http://www.dikketoeters.nl - Powered By ISPConfig
http://www.dreamworxmedia.com - Powered By ISPConfig
Reply With Quote
Sponsored Links
  #2  
Old 4th April 2006, 17:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

You can put something like this into the "Apache Directives" field of the respective web site in ISPConfig:

Code:
<Directory "/path/to/directory">
Options +Indexes
IndexOptions FancyIndexing IconsAreLinks
</Directory>
Also have a look here: http://www.apachefreaks.com/tutorials/24/1.php
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th April 2006, 09:08
Martin1982 Martin1982 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default

I filled the following out as Apache Directives within the site on ISPConfig, although it doesn't seem to have any impact at all.

Code:
<Directory '/home/www/www.dataresort.estebanmedia.selfip.biz/web/user_uploads'>
Options +Indexes
IndexOptions FancyIndexing IconsAreLinks
</Directory>
__________________
http://www.dikketoeters.nl - Powered By ISPConfig
http://www.dreamworxmedia.com - Powered By ISPConfig
Reply With Quote
  #4  
Old 6th April 2006, 11:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Do you find the same directive in your Vhosts_ispconfig.conf?
Anything in the Apache error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 6th April 2006, 14:18
Martin1982 Martin1982 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
Do you find the same directive in your Vhosts_ispconfig.conf?
Anything in the Apache error log?
Yes, I found the directive in the Vhosts_ispconfig.conf
No, no strange Apache error logs

I don't really understand where it's going wrong at this moment
__________________
http://www.dikketoeters.nl - Powered By ISPConfig
http://www.dreamworxmedia.com - Powered By ISPConfig
Reply With Quote
  #6  
Old 7th April 2006, 12:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

Do you have an .htaccess file in /home/www/www.dataresort.estebanmedia.selfip.biz/web/user_uploads?


What happens if you use only

Code:
<Directory '/home/www/www.dataresort.estebanmedia.selfip.biz/web/user_uploads'>
Options +Indexes
</Directory>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
error compiling php5 florianrieder Installation/Configuration 3 23rd March 2006 18:41
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 13:42
Update to 2.2.0 question brianetilley Installation/Configuration 10 4th March 2006 17:02
Debian install error jf1976 Installation/Configuration 25 19th January 2006 22:31
ISP install problems Debian sarge 3.1 lerra Installation/Configuration 1 5th January 2006 16:37


All times are GMT +2. The time now is 15:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.