Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th October 2008, 21:46
mikeljason mikeljason is offline
Junior Member
 
Join Date: Oct 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Question Active FTP not working with pure-ftpd

This is my first post. I have searched through all other threads looking for an answer, so I am hopeful that one of you may have a solution.

I am running Fedora 9 64bit, fresh install. I have vino/vnc running for ease of administration along with SSH. I have pure-ftpd configured and running (using the command line options: pure-ftpd -4AbBEGKHirZl puredb:/etc/pureftpd.pdb -p 50000:50100 &).

My issue is this: I can connect to this server with FTP from my windows PC with CORE FTP using PASV, but I can not connect to it using ACTIVE. When I connect from command line, I get the following: (I have replaced IP replaced with XX.XX.XX.XXX)
220---------- Welcome to Pure-FTPd ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 03:03. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 15 minutes of inactivity.
User (XX.XX.XX.XXXnone)): ftptestuser
331 User ftptestuser OK. Password required
Password:
230-User ftptestuser has group access to: 501
230 OK. Current directory is /
ftp>
ftp>
ftp> ls
500 I won't open a connection to 0.0.0.0 (only to XX.XX.XX.XXX)
425 No data connection
ftp>

I have ports 1-5000 tcp and udp open. I can FTP in to the service from the Fedora box console and connect in ACTIVE mode. What makes it even stranger is that if I shut down pure-ftpd and run vsftp I am able to connect from the Windows box using active, so it is not a firewall/network issue. I really need some of the features of pure-ftpd for the application I am using. Any suggestions would be very welcome.

One note too. It took me a good deal of time to figure out why I couldn't connect in the first place. It seems that when you disable the firewall in Fedora 9 64bit, it clamps down on FTP.
Reply With Quote
Sponsored Links
  #2  
Old 28th October 2008, 15:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Do you have this problem from within your LAN or from outside?
Are there any errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th October 2008, 16:47
mikeljason mikeljason is offline
Junior Member
 
Join Date: Oct 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Question Thanks for your reply - here is more info:

There are no errors in the log:
Oct 27 22:00:47 testftpfedora pure-ftpd: (?@10.XX.XX.XXX) [INFO] New connection from 10.3.7.232
Oct 27 22:01:19 testftpfedora pure-ftpd: (?@10.XX.XX.XXX) [INFO] ftptestuser is now logged in

I just remembered that when logging in from the local box (terminal window), it does go to passive mode when I request data such as a directory listing:

331 User ftptestuser OK. Password required
Password:
230-User ftptestuser has group access to: 501
230 OK. Current directory is /
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
227 Entering Passive Mode (127,0,0,1,195,82)
150 Accepted data connection

So... to answer your questions - no errors in /var/log/messages whether I am logging in from inside the network or outside. There may be other logs you can suggest that I look at that I am not aware of... The issue seems to be both inside and outside the network. However, VSFTP on the same box/same network seems to work fine in Active mode.
Reply With Quote
  #4  
Old 31st October 2008, 17:23
mikeljason mikeljason is offline
Junior Member
 
Join Date: Oct 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Question Another question on the same topic

Does anyone know if there are any conflicts between pure-ftpd and any other services/apps? Has anyone had experience running pure-ftpd on Fedora 9 64bit?
Reply With Quote
  #5  
Old 1st November 2008, 16:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by mikeljason View Post
Does anyone know if there are any conflicts between pure-ftpd and any other services/apps?
I don't think there are any conflicts (unless you're running multiple FTP servers).

Can you try and disable SELinux?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 1st November 2008, 21:42
mikeljason mikeljason is offline
Junior Member
 
Join Date: Oct 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default SELinux

Guess I should have mentioned that. SELinux was disabled early on as a part of my original setup. I recently also went to the trouble of disabling network Manager and reverting back to the old network service. That didn't work either.

I am very much open to other thoughts or suggestions.

Thank you
Reply With Quote
  #7  
Old 6th November 2008, 20:24
mikeljason mikeljason is offline
Junior Member
 
Join Date: Oct 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Wink Tne Answer

Well... hopefully my experiences can help someone else down the road. I have found out what the issue is. Pure-ftpd will run under Fedora 9 64bit, but the active feature will not work. I reinstalled Fedora 9 32bit and pure-ftpd is working flawlessly now. Unrelated, but possibly useful to others, Steelvine management software for Silicon Image raid controllers also seems to require 32bit libraries to run correctly. Good luck all!
Reply With Quote
The Following User Says Thank You to mikeljason For This Useful Post:
falko (7th November 2008)
  #8  
Old 29th April 2009, 14:38
ramp ramp is offline
Junior Member
 
Join Date: Apr 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem, both with fedora 9 and fedora 10 64 bit editions.
Switching to 32 bit is not an option for me, so I ended up dumpgin the os alltogether as I could not find a solution.

Actually I did do a bit of a search now, and it seems we're not the only ones running into it
https://bugzilla.redhat.com/show_bug.cgi?id=481114
It also lists a possible solution I will have to try later.

Last edited by ramp; 29th April 2009 at 14:41.
Reply With Quote
  #9  
Old 29th April 2009, 15:00
ramp ramp is offline
Junior Member
 
Join Date: Apr 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I decided to test this on FC10 x86_64 agian, and to compile pure-ftpd from the latest source released 2 days ago.

The newest version "1.0.22 (released on April 27, 2009) from pureftpd.org" has solved these problems for me!

Regards,

-Stefan
Reply With Quote
Reply

Bookmarks

Tags
64bit, active, ftp, pure-ftpd, vsftp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp is very slow and asks for user/passwd continuously chico58 Installation/Configuration 7 8th October 2008 12:43
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 21:12
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38
ISPConfig with postfix problem Chrisssssss General 30 20th January 2007 23:34
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 18:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.