#1  
Old 1st March 2006, 13:47
SamDenton SamDenton is offline
Junior Member
 
Join Date: Mar 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Not receiving mail

I have installed The perfect Fedora setup, then installed ISPConfig.

My problem is now, that I have set up some users but none can receive emails, they can all send, but none can receive.

The Maillog shows:

Mar 1 11:46:00 ds-r1060025-001 postfix/local[14167]: 6818B82010C: to=<web3_sam@ds-r1060025-001.redstation.co.uk>, orig_to=<sam@imagemachinery.com>, relay=local, delay=3, status=sent (delivered to command: /usr/bin/procmail -f-)
Mar 1 11:46:00 ds-r1060025-001 postfix/qmgr[12592]: 6818B82010C: removed

But theres nothing to download in any inbox.

Any ideas? If you need more information let me know!

Thanks

Sam
Reply With Quote
Sponsored Links
  #2  
Old 1st March 2006, 14:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Did you choose the correct value for Maildir under Management -> Server -> Settings -> Email?
Please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st March 2006, 15:30
SamDenton SamDenton is offline
Junior Member
 
Join Date: Mar 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 19020/xinetd
tcp 0 0 *:32769 *:* LISTEN 1575/rpc.statd
tcp 0 0 *op3s *:* LISTEN 19020/xinetd
tcp 0 0 *:mysql *:* LISTEN 3224/mysqld
tcp 0 0 *op3 *:* LISTEN 19020/xinetd
tcp 0 0 *:imap *:* LISTEN 19020/xinetd
tcp 0 0 *:sunrpc *:* LISTEN 1558/portmap
tcp 0 0 *:81 *:* LISTEN 23098/ispconfig_htt
tcp 0 0 mail.etruscarestaura:domain *:* LISTEN 23209/named
tcp 0 0 ds-r1060025-001:domain *:* LISTEN 23209/named
tcp 0 0 ds-r1060025-001:ipp *:* LISTEN 1880/cupsd
tcp 0 0 ds-r1060025-001:5335 *:* LISTEN 1864/mDNSResponder
tcp 0 0 ds-r1060025-001:rndc *:* LISTEN 23209/named
tcp 0 0 *:smtp *:* LISTEN 23181/master
tcp 0 0 mail.etruscarestaurantop3 host86-140-42-162.rang:4013 TIME_WAIT -
tcp 0 0 mail.etruscarestaurantop3 host86-140-42-162.rang:4009 TIME_WAIT -
tcp 0 0 *:ssh *:* LISTEN 1969/sshd
tcp 0 0 ::1:rndc *:* LISTEN 23209/named
tcp 0 2596 mail.imagemachinery.com:ssh redstation-116.adsl.n:32522 ESTABLISHED 5212/0
Reply With Quote
  #4  
Old 1st March 2006, 15:35
SamDenton SamDenton is offline
Junior Member
 
Join Date: Mar 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay I reinstalled postfix and then ISPConfig as recommended elsewhere and now I get the following

Mar 1 13:33:10 ds-r1060025-001 postfix/smtpd[23661]: connect from redstation-117.adsl.newnet.co.uk[81.3.109.117]
Mar 1 13:33:10 ds-r1060025-001 postfix/smtpd[23661]: NOQUEUE: reject: RCPT from redstation-117.adsl.newnet.co.uk[81.3.109.117]: 554 <test@imagemachinery.com>: Relay access denied; from=<samdenton@redstation.com> to=<test@imagemachinery.com> proto=ESMTP helo=<exchange.redstationfec.co.uk>
Mar 1 13:33:10 ds-r1060025-001 postfix/smtpd[23661]: disconnect from redstation-117.adsl.newnet.co.uk[81.3.109.117]

however test@imagemachinery.com is in the /etc/postfix/virtusertable and imagemachinery.com is in the /etc/postfix/local-host-names

Thanks again

Sam
Reply With Quote
  #5  
Old 1st March 2006, 17:35
SamDenton SamDenton is offline
Junior Member
 
Join Date: Mar 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay Sorted the Relay-Denied message now...

Back to the first issue... The server appears to accept mail but its just not being picked up by user accounts.

Any more info I can give you to get this sorted?

Thanks

Sam
Reply With Quote
  #6  
Old 1st March 2006, 17:41
SamDenton SamDenton is offline
Junior Member
 
Join Date: Mar 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Did you choose the correct value for Maildir under Management -> Server -> Settings -> Email?
Please post the output of
Code:
netstat -tap
Errr... I don't get an option to change the maildir from here? Only a tick box?

Thanks

Sam
Reply With Quote
  #7  
Old 1st March 2006, 23:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
 
Default

Your POP3 daemon uses the mbox format which means you must disable Maildir under Management -> Server -> Settings -> Email.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 09:27
Problems with receiving mail Kieran General 8 26th February 2006 19:17
Not Receiving MAil! nformosa Installation/Configuration 8 2nd January 2006 12:07
Problem receiving mail CorrosionX General 4 15th November 2005 22:49
Mailserver not receiving mail Unsaferanger Installation/Configuration 3 26th August 2005 09:59


All times are GMT +2. The time now is 20:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.