Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th August 2005, 14:55
maxx maxx is offline
Member
 
Join Date: Jul 2005
Location: Finland
Posts: 70
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to maxx Send a message via Skype™ to maxx
Default Empty mails after update to 2.0.7

After update I get totally empty emails from time to time to my email account. Sender, receiver, subject and body are all empty, what is this?

- Maxx
Reply With Quote
Sponsored Links
  #2  
Old 16th August 2005, 15:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
Originally Posted by maxx
After update I get totally empty emails from time to time to my email account. Sender, receiver, subject and body are all empty, what is this?

- Maxx
There is nothing updated in this part of the software. Try to disable mailscan.

http://www.howtoforge.com/forums/showthread.php?t=261
Reply With Quote
  #3  
Old 17th August 2005, 14:33
maxx maxx is offline
Member
 
Join Date: Jul 2005
Location: Finland
Posts: 70
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to maxx Send a message via Skype™ to maxx
Default Empty mails

Quote:
Originally Posted by till
There is nothing updated in this part of the software. Try to disable mailscan.

http://www.howtoforge.com/forums/showthread.php?t=261
Took spam, av, mailscan off.
Put it back on.. Still have this problem so I cant use them now. And this happened after update.

- Maxx
Reply With Quote
  #4  
Old 17th August 2005, 14:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
Originally Posted by maxx
Took spam, av, mailscan off.
Put it back on.. Still have this problem so I cant use them now. And this happened after update.

- Maxx
Deactivate only mailscan as described in the other posts not spamfilter and antivirus.
Reply With Quote
  #5  
Old 17th August 2005, 21:12
maxx maxx is offline
Member
 
Join Date: Jul 2005
Location: Finland
Posts: 70
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to maxx Send a message via Skype™ to maxx
Default Did that.

Quote:
Originally Posted by till
Deactivate only mailscan as described in the other posts not spamfilter and antivirus.
Did that. It comes from spamfilter or antivirus. Havent tested that yet.
Reply With Quote
  #6  
Old 18th August 2005, 10:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
Originally Posted by maxx
Did that. It comes from spamfilter or antivirus. Havent tested that yet.
Ok, please try this, if it is spamassassin that makes these errors:

SpamAssassin

The ISPConfig comes with SpamAssassin, but without the Perl modules needed by
SpamAssassin. Run the following command after the installation of the ISPConfig:

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

If errors appear you have to install some Perl modules.

perl -MCPAN -e shell
install HTML::Parser
install DB_File
install Net:NS (when prompted to enable tests, choose "no")
install Digest::SHA1

To leave the Perl shell type

q

If

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

does not return any error everything is fine. You can then leave SpamAssassin by typing
" CTRL + c".
Reply With Quote
  #7  
Old 19th August 2005, 10:28
maxx maxx is offline
Member
 
Join Date: Jul 2005
Location: Finland
Posts: 70
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to maxx Send a message via Skype™ to maxx
Default Tested

Quote:
Originally Posted by till
Ok, please try this, if it is spamassassin that makes these errors:

SpamAssassin

The ISPConfig comes with SpamAssassin, but without the Perl modules needed by
SpamAssassin. Run the following command after the installation of the ISPConfig:

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

If errors appear you have to install some Perl modules.

perl -MCPAN -e shell
install HTML::Parser
install DB_File
install Net:NS (when prompted to enable tests, choose "no")
install Digest::SHA1

To leave the Perl shell type

q

If

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

does not return any error everything is fine. You can then leave SpamAssassin by typing
" CTRL + c".

When I did /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin
it doesnt say or do anything.. or report any errors. So i guess its okay.

- Maxx

Now I found out. Its the antivirus that does this problem. Can I fix somehow?

- Maxx

Last edited by maxx; 19th August 2005 at 11:28.
Reply With Quote
  #8  
Old 17th March 2008, 14:53
brt brt is offline
Junior Member
 
Join Date: Feb 2007
Posts: 10
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by maxx
Now I found out. Its the antivirus that does this problem. Can I fix somehow?
same problem here, totally empty emails, no sender, no subject, no mailheaders (!?)

how did you know it has something to do with antivirus ?
Reply With Quote
  #9  
Old 18th March 2008, 15:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Any errors in your mail log? Have you tried to disable Mailscan and/or Antivirus in ISPConfig?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 18th March 2008, 17:07
brt brt is offline
Junior Member
 
Join Date: Feb 2007
Posts: 10
Thanks: 0
Thanked 1 Time in 1 Post
 
Default problem still exists

yes the problem still exists when Mailscan is disabled, and no there are no errors in the mail-log.

a quick comparison of date/time of an empty email with the logfile showed that at this moment no email was incoming at all. all i could see in the maillog at this time was popfetching of this client.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Empty messages jysse Installation/Configuration 5 15th August 2005 09:33


All times are GMT +2. The time now is 12:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.