Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th March 2006, 13:48
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,044
Thanks: 269
Thanked 154 Times in 133 Posts
Default Open DNS servers (update bug?) 2.1.2 > 2.2.2

After updating from 2.1.2 to 2.2.2, all my DNS server were 'Open DNS servers' again. When I was using 2.1.2 I added the 'fix' for this in both named.conf files!

Looking at the named.conf in /root/ispconfig/isp/conf/named.conf.master and in /etc the
Code:
allow-recursion {
localhost;
};
is missing again!

After adding it, and restarting named, the DNS server is closed and ok :-)
Reply With Quote
Sponsored Links
  #2  
Old 14th March 2006, 15:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

Thats not a bug. ISPConfig replaces the templates with the default templates. If you want to keep custom master templates, make a backup before you update ISPConfig and merge your changes back in the new ISPConfig master templates.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th March 2006, 16:09
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,044
Thanks: 269
Thanked 154 Times in 133 Posts
Default

Quote:
Originally Posted by till
Thats not a bug. ISPConfig replaces the templates with the default templates. If you want to keep custom master templates, make a backup before you update ISPConfig and merge your changes back in the new ISPConfig master templates.
Okay.. it's not a bug.. but is it maybe not better to make this a default setup in the install file, or make an option in ISPconfig to enable/disable this?

I'm sure that a lot of users who install ISPconfig, do not really want to have an 'Open DNS server'...
Reply With Quote
  #4  
Old 15th March 2006, 09:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
 
Default

Quote:
Originally Posted by edge
Okay.. it's not a bug.. but is it maybe not better to make this a default setup in the install file, or make an option in ISPconfig to enable/disable this?
We will consider that. The problem with changing defaults is that it will break lots of installations that rely on a specific setting.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get mail after applying the update 2.1.2 mphayesuk Installation/Configuration 2 31st December 2008 15:48
Mail System doesnt work! crichton Installation/Configuration 3 18th September 2007 00:49
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 14:29
open ports rayit General 6 18th January 2006 15:23
can't receive mail Jordy General 10 1st November 2005 20:15


All times are GMT +2. The time now is 01:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.