Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st October 2007, 10:40
CaptainBalou CaptainBalou is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Thanks: 8
Thanked 1 Time in 1 Post
Question mailuser login malformed

Hello folks,

I try to login to my https://www.domain.com/mailuser Interface but it won't work even the "login mailuser" is activated. My user data is as follows:

Mailalias: user@domain.com
real user name: domain.com_user

The best would be that the users can login with their email alias names. But I've read in other threads that this is not possible. Am I right?

So I try to login with username "domain.com_user" and the following message appears in mail.log:

Code:
Oct  1 10:37:17 server dovecot: pop3-login: Disconnected: user=<_domain.com_user>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
I think this isn't correct because of the leading "_" in the user name. Does somebody know if this is the reason for that? And what should I do to fix it?

Regards
Marco
Reply With Quote
Sponsored Links
  #2  
Old 1st October 2007, 10:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,594
Thanks: 792
Thanked 4,984 Times in 3,904 Posts
Default

In the mailuser login, users can login with their email alias.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st October 2007, 10:43
CaptainBalou CaptainBalou is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Thanks: 8
Thanked 1 Time in 1 Post
Default

Hey Till, you're really fast in answering threads. :-)

They can login with their alias? Wow. So I misunderstood that in the other thread. But they should also be able to login with their real user name don't they?
Reply With Quote
  #4  
Old 1st October 2007, 10:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,594
Thanks: 792
Thanked 4,984 Times in 3,904 Posts
Default

Quote:
Originally Posted by CaptainBalou
But they should also be able to login with their real user name don't they?
No, the current implementation does a lookup for the email address, so a login is only possible with the email address of a user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st October 2007, 11:03
CaptainBalou CaptainBalou is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Thanks: 8
Thanked 1 Time in 1 Post
Default

Oh, so I complete mixed it up. Ok, now I'm on the right way.

But nevertheless: No login is possible with the email alias. The login dialog shows a message "Fehler: Username unbekannt" (like "Error: username unknown" for all non-Germans :-) ) if I try to login with the email address. The mail.log says nothing. I'm confursed.
Reply With Quote
  #6  
Old 1st October 2007, 11:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,594
Thanks: 792
Thanked 4,984 Times in 3,904 Posts
Default

Hmm, thats starnge. The mailuser login is enabled for this site?

For this login, ISPConfig tries to authenticate with pop3 on localhost, so you should at least see a failed pop3 login in your mail log.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 1st October 2007, 11:15
CaptainBalou CaptainBalou is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Thanks: 8
Thanked 1 Time in 1 Post
Default

I feel tha same: strange things happens. ;-)

If I disable "mailuser login" the message "mailuser login disabled" appears instead the other message. So I'm sure to have it correctly enabled.

I've read in the manual that it is done via pop3, so I enabled it in dovecot. Before I got the message "cannot connect to host 'localhost'". So I'm also sure to enabled it. :-)

But there is no message in the mail.log file. Do I have to setup some special thins for pop3 in dovecot.conf?
Reply With Quote
  #8  
Old 1st October 2007, 14:19
CaptainBalou CaptainBalou is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Thanks: 8
Thanked 1 Time in 1 Post
Default

Hmm, Till, I'm still wondering if I understood you correct. I looked up /home/admispconfig/ispconfig/web/mailuser/login/index.php because I thinks it does the mailuser login page.

In this script just the given username out of the input filed is used to compare it against the isp_isp_user table. I cannot see that anyone does a virtual user table lookup.

Am I completely wrong?
Reply With Quote
  #9  
Old 1st October 2007, 23:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,594
Thanks: 792
Thanked 4,984 Times in 3,904 Posts
Default

Sorry, you are right. I thought we had implemented a email to username lookup there too.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 1st October 2007, 23:40
CaptainBalou CaptainBalou is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Thanks: 8
Thanked 1 Time in 1 Post
 
Default



But can you imagine why my username "domain.com_username" results in a mail.log entry of "_domain.com_username"? Who inserts the underscore? Is dovecot the troublemaker? Still confused...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to authenticate to SMTP server ashkev Installation/Configuration 15 6th February 2007 17:46
Mail Login: mailuser or mailuser@domain.com, not webX_mailuser... VMartins General 3 7th November 2006 11:47
kann keine mails empfangen odin1 Installation/Configuration 5 6th July 2006 12:13
MailUser Login suman General 1 9th May 2006 17:03
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 16:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.