Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th October 2008, 23:01
nakeman nakeman is offline
Junior Member
 
Join Date: Oct 2008
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Default WARNING: mysqlcheck has found corrupt tables

When I log in to my acc via SSH, getting message "You have new mail". Opened mail and this is what I get:

To: root@XXX root@XXX
Subject: Re: WARNING: mysqlcheck has found corrupt tables

What the *uck is wrong ? It started after couple of power failures. I think I get a new mail everytime when I boot my server.
I'am using only SSH to config my server, so give me some shell commands pls.
Reply With Quote
Sponsored Links
  #2  
Old 21st October 2008, 10:29
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

You need to repair the corrupt tables.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 21st October 2008, 10:34
nakeman nakeman is offline
Junior Member
 
Join Date: Oct 2008
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Well theres not a lot tables to repair. But is that shell command something like "repair <table>"?
Reply With Quote
  #4  
Old 21st October 2008, 10:43
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

you do that for myisam tables from the mysql prompt

Code:
mysql> repair table <table_name>
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
The Following User Says Thank You to topdog For This Useful Post:
nakeman (21st October 2008)
  #5  
Old 21st October 2008, 11:47
nakeman nakeman is offline
Junior Member
 
Join Date: Oct 2008
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Why it keeps jamming...

mysql> repair table ftpgroup
->

I've changed database.
Reply With Quote
  #6  
Old 21st October 2008, 11:49
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

It will run for some time u need to be patient depending on the size of the table.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
The Following User Says Thank You to topdog For This Useful Post:
nakeman (21st October 2008)
  #7  
Old 22nd October 2008, 02:47
nakeman nakeman is offline
Junior Member
 
Join Date: Oct 2008
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I waited like 20min and on that table was only 1 row (or how it is called..).
Reply With Quote
  #8  
Old 22nd October 2008, 12:54
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

You need to include a semicolon at the end of the command:
Code:
repair table <table_name>;
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 22nd October 2008, 13:14
nakeman nakeman is offline
Junior Member
 
Join Date: Oct 2008
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko View Post
You need to include a semicolon at the end of the command:
Code:
repair table <table_name>;
Thx! It works now (aka "Why didn't I sort that our by my own.. sigh)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 20:17
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
pure-ftp woes d3th_n1gG4 Server Operation 4 24th January 2007 13:11
help on /etc/rc0.d/K20dnsctl -> ../init.d/dnsctl zimele General 13 23rd August 2006 16:06
mysqlcheck has found corrupt tables m u r Installation/Configuration 1 18th August 2005 10:47


All times are GMT +2. The time now is 09:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.