#1  
Old 13th October 2008, 18:41
ruben23 ruben23 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Centos as Gateway server.

Hi to all....i would like to ask help about my centos gateway server...i setup a gateway server on my network to be able to share internet with my private network.....in my gateway server i already can browse to the internet but with the dhcp function i think its not working....my client PC can ping the local ip of my gateway server..please help how to proceed with this...thanks
Reply With Quote
Sponsored Links
  #2  
Old 13th October 2008, 18:43
ruben23 ruben23 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i follow the how to of Home Gateway Firewall With DHCP Server For Connection Sharing..i already review it for several times...still my client PC cant connect with the internet..
Reply With Quote
  #3  
Old 14th October 2008, 16:04
ruben23 ruben23 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi anyone help........
Reply With Quote
  #4  
Old 14th October 2008, 19:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Is your client PC a Linux system? If so, please post the outputs of
Code:
ifconfig
and
Code:
route -nee
on that system.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th October 2008, 20:44
ruben23 ruben23 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Wink

no...my client PC are Windows xp...my configuration is:

PC-1
IP add=192.168.2.5
Subnet mask-255.255.255.0
Gateway=192.168.2.1
Dns=( given by my ISP)

.....plus one to every IP to the next client PC.



Server Gateway

LOCAL ETHERNET
eth1= local ip ( 192.168.2.1)
submask= 255.255.255.0
Gateway=192.168.2.1

EXTERNAL ETHERNET
eth2= ISP static IP (x.x.x.x)
submask= 255.255.255.248
Gateway= x.x.x.x

thats my initial config...
Reply With Quote
  #6  
Old 14th October 2008, 20:49
ruben23 ruben23 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

And my server Kernel Ip routing is:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface MSS Window irtt
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1 0 0 0
0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 eth1 0 0 0
Reply With Quote
  #7  
Old 15th October 2008, 17:22
marpada marpada is offline
Senior Member
 
Join Date: Sep 2008
Posts: 139
Thanks: 2
Thanked 14 Times in 14 Posts
 
Default

Did you enable the port_forwarding in the Centos server?

Code:
$ cat /proc/sys/net/ipv4/ip_forward
if is set to 0 (disabled) you have to enable it

Quote:
# echo "1" > /proc/sys/net/ipv4/ip_forward
and edit to make the change permanent /etc/sysctl.conf

net.ipv4.ip_forward=1
________
Vapoizers
________
Black ass

Last edited by marpada; 13th May 2011 at 01:48.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
centos syslog is slow on Dell server Hellbound Server Operation 1 23rd September 2008 21:08
Web Server setup- CentOS 5.2 64-bit Helter Installation/Configuration 1 30th August 2008 18:39
Setting up a backup mail server setup with two installations of ISPConfig zitch Tips/Tricks/Mods 7 30th December 2006 10:07
server blocked/stopped by host Ovidiu Technical 11 14th February 2006 10:50


All times are GMT +2. The time now is 12:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.