Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 19th November 2008, 14:19
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

Sorry about my above post. I think the login fails because u are trying to login using administrator instead of Administrator which u configured in the post prior to this one.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
Sponsored Links
  #22  
Old 19th November 2008, 14:43
space007 space007 is offline
Junior Member
 
Join Date: Nov 2008
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by topdog View Post
Are u not using the full email address for logon ? As sasl is seeing only the user part.
I edited the sql table to rename the user (horde table "horde_users" ), still the same thing
messages:
Code:
Nov 19 13:18:54 server imap[14538]: sql_select option missing
Nov 19 13:18:54 server imap[14538]: auxpropfunc error no mechanism available 
saslauthd[14539]: do_auth : auth failure: [user=user@domain.com] [service=imap] [realm=domain.com] [mech=pam] [reason=PAM auth error]
repeated 6 times
Reply With Quote
  #23  
Old 19th November 2008, 14:56
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

can you add debug to you /etc/pam.d/imap file and they tell me what u see in /var/log/secure
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #24  
Old 19th November 2008, 17:00
gsp gsp is offline
Member
 
Join Date: Oct 2008
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Horde cannot login into cyrus because in config file the user is cyrus with blank password. System doesn't allow cyrus user with blank password. If i replace this with a real password login works and seems to work through IMAP.

My problems are mostly related with php and also i get some errors when i install packages of pearl/php about some files in tmp directory ( i never found any logs about it..)

So i get several errors between modules... One time i almost managed to make this work but virtual folders were already f***d up and couldn't create any users...

Also some errors occur in apache configuration especially in secure connections related to the hostname of the machine...


All this combination (how to) works but it needs a GOOD updated and some details that are not included.


And finally, topdog, we don't blame you.. We thank you for your work, BUT i call for help if anyone has made this to work, to post the updated info so other people can also make this how to to work

Cheers
Reply With Quote
  #25  
Old 19th November 2008, 17:37
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

Quote:
Originally Posted by gsp View Post
Horde cannot login into cyrus because in config file the user is cyrus with blank password. System doesn't allow cyrus user with blank password. If i replace this with a real password login works and seems to work through IMAP.
The should not be neccessary if you have set the admins to a user who is in the db and has a password, you need to use that user not the cyrus user.
Quote:
My problems are mostly related with php and also i get some errors when i install packages of pearl/php about some files in tmp directory ( i never found any logs about it..)
Just pinpoint what u are facing and i will help.
Quote:
All this combination (how to) works but it needs a GOOD updated and some details that are not included.


And finally, topdog, we don't blame you.. We thank you for your work, BUT i call for help if anyone has made this to work, to post the updated info so other people can also make this how to to work

Cheers
I will try to redo it on 5.2 and post an update, i just relaxing abit at the moment after doing a maration CCSP certification program which i finished last friday. I will try and work on this next weekend.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #26  
Old 19th November 2008, 19:20
gsp gsp is offline
Member
 
Join Date: Oct 2008
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi again, i mean the admin login to cyrus which horde uses from imap module (imp servers section) probably for reading virtual folders(?)... this operation works ONLY if i set a cyrus user password (from the system) and set the same in the config file..

Otherwise IMP never logins...

To make an update would be very kind of you... also i will come back with a list with specific problems because at this moment i have formatted this machine for another one time!!

Thank you
Reply With Quote
  #27  
Old 19th November 2008, 19:40
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

actually the login you use to login to horde is what is passed on to imp then on to the imap server. The virtual folders are just a software implementation in horde and not stored on the imap server

If the login fails it means there is an underlying problem with your authentication which u need to test using

Code:
testsaslauthd -u user@domain -p <password> -s imap
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #28  
Old 20th November 2008, 09:08
gsp gsp is offline
Member
 
Join Date: Oct 2008
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Default

OK, but then what is the use of servers config file of IMP? When i fixed this password issue then i was able to login with any existed user in the system...

I noticed some 'malfunction' in the way that the system registered new users...

Also i couldn't understand if there is a relation between horde admin user and cyrus because if i logged in as Administrator in horde i had no admin rights to delete folders in cyrus for instance...

Any way, these are various problem which i remember from the many many installs i had done.. so don't bother to solve them because maybe i don't remember well.. As soon as i get more time in my work because we changing some systems now, i will install CentOS 5.2 again and start over.. Then i'll start to post SPECIFIC problems and maybe i'll get to success!

Thanks for your valuable help!

P.S. I think that its not important the way that someone installs CentosOS? I mean with graphic desktop, or server environment or any other packages? Either way according to how to we install all necessary things afterward right?

P.S.2. One last thing which made me confused... the host name of the machine during installation should be mailserver.domain.com or just mailserver ? Because i think this is important for apache setup ?
Reply With Quote
  #29  
Old 20th November 2008, 09:24
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

Quote:
Originally Posted by gsp View Post
OK, but then what is the use of servers config file of IMP? When i fixed this password issue then i was able to login with any existed user in the system...
It tells imp which server to connect to.
Quote:
I noticed some 'malfunction' in the way that the system registered new users...

Also i couldn't understand if there is a relation between horde admin user and cyrus because if i logged in as Administrator in horde i had no admin rights to delete folders in cyrus for instance...
The horde admin user should be a cyrus admin user, As per deleting of folders that is the default cyrus behavior, the acl's applied to the folders do not allow for deleting by default you need to set the acl to allow deleting before you can do it.
http://cyrusimap.web.cmu.edu/twiki/b...boxPermissions

Quote:

P.S.2. One last thing which made me confused... the host name of the machine during installation should be mailserver.domain.com or just mailserver ? Because i think this is important for apache setup ?
That should not really affect apache as with virtual hosting the page that is served is dependent on what the client sends in the HOST field of the HTTP/1.1 headers.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #30  
Old 20th November 2008, 10:11
space007 space007 is offline
Junior Member
 
Join Date: Nov 2008
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
 
Thumbs up

First, Topdog many thanks, you are very helpful

Quote:
Originally Posted by topdog View Post
can you add debug to you /etc/pam.d/imap file and they tell me what u see in /var/log/secure
That give an idea, to double check /etc/pam modifications related to imap, there was a typo in the DB pwd..

1. Horde Login
a) First login success
got the horde menu on the left, auth failed in the center

b) re-login got access
FYI:
# testsaslauthd -u user@domain.com -p pwd123
0: OK "Success."
2. Kmail (on the local box), added IMAP & pop3
a) Imap connected
var log maillog
imap[9707]: accepted connection
master[9726]: about to exec /usr/lib/cyrus-imapd/imapd
imap[9726]: executed
imap[9707]: login: server [10.0.0.1] user@domain.com plaintext User
IMAP does not have default folders in Kmail, when I try to subscribe it crashes it

b) Pop3 AUTH failed
messages:
pop3[9733]: sql_select option missing
pop3[9733]: auxpropfunc error no mechanism available
var log maillog
pop3[9708]: accepted connection
master[9733]: about to exec /usr/lib/cyrus-imapd/pop3d
pop3[9708]: badlogin: server [10.0.0.1] plaintext user@domain.com invalid user
pop3[9733]: executed
master[9688]: process 9708 exited, status 0
3. Deliver mail to a smarthost with and without auth

4. Somebody mentioned that horde can fetch external pop3, but as Horde is not a daemon, its just triggered when the user logs in (wild guess). So it does ot work for me, I will have some users accessing using IMAP and/or pop3, so I would need something like fetchmail. Will check this after first 3 issues are solved and post back.

P.S. Just to know, got some errors in messages every 5 min. probably when horde and/or Kmail is accessing imap.
imap[9760]: auxpropfunc error no mechanism available
imap[9773]: sql_select option missing
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail Server Setup With Exim, MySQL, Cyrus-Imapd, Horde Webmail On Centos 5.1 Dutchy63 HOWTO-Related Questions 9 9th October 2008 13:50
Mail Server Setup With Exim, MySQL, Cyrus-Imapd, Horde Webmail On Centos 5.1 gueland HOWTO-Related Questions 3 28th August 2008 12:21
User constantly loggin into mail? bswinnerton Installation/Configuration 2 24th March 2008 01:12
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 09:27
Install ISPConfig on CentOS Server, in brief gfts Tips/Tricks/Mods 11 4th April 2006 09:29


All times are GMT +2. The time now is 08:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.