Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th October 2008, 00:05
houstonpcguy houstonpcguy is offline
Junior Member
 
Join Date: Aug 2006
Location: Waverly, Ohio
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to houstonpcguy Send a message via Yahoo to houstonpcguy
Default RE: After Installation of CentOS 5.1 upgraded to 5.2

Hello,

I am relatively still new to all this and I am following the CentOS 5.1 Desktop guide and I am having a problem after installing everything I get to the Audacity install and I get the following error:

Missing Dependency: libwx_gtk2u_adv-2.6.so.0 is needed by package audacity
Missing Dependency: libwx_gtk2u_xrc-2.6.so.0 is needed by package audacity
Missing Dependency: libwx_gtk2u_html-2.6.so.0(WXU_2.6) is needed by package audacity
Missing Dependency: libwx_gtk2u_html-2.6.so.0 is needed by package audacity
Missing Dependency: libwx_baseu_net-2.6.so.0(WXU_2.6) is needed by package audacity
Missing Dependency: libwx_baseu-2.6.so.0 is needed by package audacity
Missing Dependency: libwx_gtk2u_qa-2.6.so.0 is needed by package audacity
Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6) is needed by package audacity
Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.2) is needed by package audacity
Missing Dependency: libwx_baseu-2.6.so.0(WXU_2.6) is needed by package audacity
Missing Dependency: libwx_baseu_net-2.6.so.0 is needed by package audacity
Missing Dependency: libwx_gtk2u_core-2.6.so.0 is needed by package audacity
Missing Dependency: libwx_baseu_xml-2.6.so.0 is needed by package audacity

I have made sure the wxGTK and wxGTK-Developement packages were installed yet I still get this error.

Does anyone have a clue to this problem and how I can fix it please?

Thanks,
Reply With Quote
Sponsored Links
  #2  
Old 9th October 2008, 18:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
updatedb
locate libwx_gtk2u_adv-2.6.so
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 10th October 2008, 11:25
houstonpcguy houstonpcguy is offline
Junior Member
 
Join Date: Aug 2006
Location: Waverly, Ohio
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to houstonpcguy Send a message via Yahoo to houstonpcguy
Default Re: CentOS 5.1 to 5.2 Install Problem

Quote:
Originally Posted by falko View Post
What's the output of
Code:
updatedb
locate libwx_gtk2u_adv-2.6.so
?
Hey Falko,

How are ya?

Nothing the updatedb does update but the locate libwx_gtk2u_adv-2.6.so produces nothing blank line comes back after issuing that command.



Thanks,
Reply With Quote
  #4  
Old 10th October 2008, 11:27
houstonpcguy houstonpcguy is offline
Junior Member
 
Join Date: Aug 2006
Location: Waverly, Ohio
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to houstonpcguy Send a message via Yahoo to houstonpcguy
Default Re: CentOS 51. to 5.2 Upgrade, Install Problem

Quote:
Originally Posted by falko View Post
What's the output of
Code:
updatedb
locate libwx_gtk2u_adv-2.6.so
?
Hey Falko,

I got this by running "rpm -qa | grep wxGTK"

wxGTK-2.8.8-1.el5.rf
wxGTK-devel-2.8.8-1.el5.rf

Just to show it is installed,

Thanks Again,
Reply With Quote
  #5  
Old 11th October 2008, 18:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

And what's the output of
Code:
locate libwx_gtk2u
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 12th October 2008, 13:26
houstonpcguy houstonpcguy is offline
Junior Member
 
Join Date: Aug 2006
Location: Waverly, Ohio
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to houstonpcguy Send a message via Yahoo to houstonpcguy
Default Re: After Installation of CentOS 5.1 upgraded to 5.2

Quote:
Originally Posted by falko View Post
And what's the output of
Code:
locate libwx_gtk2u
?
locate libwx_gtk2u
/usr/lib/libwx_gtk2u_adv-2.8.so
/usr/lib/libwx_gtk2u_adv-2.8.so.0
/usr/lib/libwx_gtk2u_adv-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_aui-2.8.so
/usr/lib/libwx_gtk2u_aui-2.8.so.0
/usr/lib/libwx_gtk2u_aui-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_core-2.8.so
/usr/lib/libwx_gtk2u_core-2.8.so.0
/usr/lib/libwx_gtk2u_core-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_gizmos-2.8.so
/usr/lib/libwx_gtk2u_gizmos-2.8.so.0
/usr/lib/libwx_gtk2u_gizmos-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_gizmos_xrc-2.8.so
/usr/lib/libwx_gtk2u_gizmos_xrc-2.8.so.0
/usr/lib/libwx_gtk2u_gizmos_xrc-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_gl-2.8.so
/usr/lib/libwx_gtk2u_gl-2.8.so.0
/usr/lib/libwx_gtk2u_gl-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_html-2.8.so
/usr/lib/libwx_gtk2u_html-2.8.so.0
/usr/lib/libwx_gtk2u_html-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_media-2.8.so
/usr/lib/libwx_gtk2u_media-2.8.so.0
/usr/lib/libwx_gtk2u_media-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_ogl-2.8.so
/usr/lib/libwx_gtk2u_ogl-2.8.so.0
/usr/lib/libwx_gtk2u_ogl-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_qa-2.8.so
/usr/lib/libwx_gtk2u_qa-2.8.so.0
/usr/lib/libwx_gtk2u_qa-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_richtext-2.8.so
/usr/lib/libwx_gtk2u_richtext-2.8.so.0
/usr/lib/libwx_gtk2u_richtext-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_stc-2.8.so
/usr/lib/libwx_gtk2u_stc-2.8.so.0
/usr/lib/libwx_gtk2u_stc-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_svg-2.8.so
/usr/lib/libwx_gtk2u_svg-2.8.so.0
/usr/lib/libwx_gtk2u_svg-2.8.so.0.5.0
/usr/lib/libwx_gtk2u_xrc-2.8.so
/usr/lib/libwx_gtk2u_xrc-2.8.so.0
/usr/lib/libwx_gtk2u_xrc-2.8.so.0.5.0

That's what I got with that command.

Thanks,
Reply With Quote
  #7  
Old 13th October 2008, 12:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Ok, you've got the 2.8 version installed, while audacity is looking for the 2.6 version.
Are you trying to install the latest version of audacity, or is your CentOS 5.2 trying to install the version for CentOS 5.1?

What you can try is symlinking each needed file, like this:
Code:
ln -s /usr/lib/libwx_gtk2u_adv-2.8.so /usr/lib/libwx_gtk2u_adv-2.6.so.0
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 21st November 2008, 19:49
DaveAtFraud DaveAtFraud is offline
Junior Member
 
Join Date: Nov 2008
Location: Parker, CO USA
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Thumbs down

Quote:
Originally Posted by falko View Post
Ok, you've got the 2.8 version installed, while audacity is looking for the 2.6 version.
Are you trying to install the latest version of audacity, or is your CentOS 5.2 trying to install the version for CentOS 5.1?

What you can try is symlinking each needed file, like this:
Code:
ln -s /usr/lib/libwx_gtk2u_adv-2.8.so /usr/lib/libwx_gtk2u_adv-2.6.so.0
This does NOT work. audacity does a run time check to see if the libraries are the correct version. Setting up all of the sym links just gets you:
Code:
[dave@bend ~]# audacity
audacity: /usr/lib64/libwx_gtk2u_html-2.6.so.0: version `WXU_2.6' not found (required by audacity)
audacity: /usr/lib64/libwx_baseu_net-2.6.so.0: version `WXU_2.6' not found (required by audacity)
audacity: /usr/lib64/libwx_gtk2u_core-2.6.so.0: version `WXU_2.6.2' not found (required by audacity)
audacity: /usr/lib64/libwx_gtk2u_core-2.6.so.0: version `WXU_2.6' not found (required by audacity)
audacity: /usr/lib64/libwx_baseu-2.6.so.0: version `WXU_2.6' not found (required by audacity)
Anyone have a solution that works?

Thanks,
Dave
Reply With Quote
  #9  
Old 22nd November 2008, 04:21
DaveAtFraud DaveAtFraud is offline
Junior Member
 
Join Date: Nov 2008
Location: Parker, CO USA
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default

OK. I've got audacity running on CentOS 5.2. This is what I ended up doing. I pulled down an older copy of wxGTK from http://rpmfind.net. The copy of 2.6 they had for RHEL/CentOS 5 was 2.6.3-1. I then installed the older version wxGTK and audacity-1.30b-1 using rpm.

This got audacity running but now yum barfs because it wants to update wxGTK to 2.8 but can't since then audacity fails dependencies. I like to run yum updates from the command line anyway so I use:

yum --exclude wxGTK update

which then works just fine. If a version of audacity comes out that works with wxGTK 2.8, I won't need to exclude wxGTK. I'll write up what I did in more detail on my blog at http://davenjudy.org/davesBlog within the next few days.

Cheers,
Dave
Reply With Quote
The Following User Says Thank You to DaveAtFraud For This Useful Post:
falko (22nd November 2008)
  #10  
Old 27th January 2009, 10:41
jason.theitguy jason.theitguy is offline
Junior Member
 
Join Date: Jan 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Thank you Dave

Quote:
Originally Posted by DaveAtFraud View Post
.

yum --exclude wxGTK update
You can also add this to your yum.conf file so you don't have to remember to do this each time.

http://www.cyberciti.biz/faq/redhat-...lude-packages/
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 5.2 Domu on Ubuntu Hardy Dom0 Camran Installation/Configuration 5 3rd November 2009 10:57
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
The Perfect Server - CentOS 5.2 VMware Guest pg001 HOWTO-Related Questions 3 26th July 2008 11:32
CentOS 5.1 - ISPConfig Installation completed but init.d/ispconfig_server not found?? tozden Installation/Configuration 1 15th May 2008 10:21
Problem with new CENTOS 5.1 / POSTFIX installation can Server Operation 1 7th March 2008 23:10


All times are GMT +2. The time now is 04:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.