Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th September 2009, 19:49
StevenD StevenD is offline
Member
 
Join Date: Oct 2008
Posts: 43
Thanks: 8
Thanked 0 Times in 0 Posts
Default Mail routing problem

Hi All,

I have 3 domains setup on my server, since I setup the 3rd I no longer receive email. The new domain is listed in local_host_names and virtusertable.

This is the reply I get if i sent from yahoo to my acoounts.

Quote:
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

web15_enquiry@server.home2
Unrouteable address

------ This is a copy of the message, including all the headers. ------

Return-path: <yahoo@yahoo.co.uk>
Received: from [172.23.170.140] (helo=anti-virus02-07)
by smtp-out2.blueyonder.co.uk with smtp (Exim 4.52)
id 1MmWY9-0005CW-E3
for web15_enquiry@server.home2; Sat, 12 Sep 2009 18:38:13 +0100
Received: from [77.96.21.154] (helo=server.home2)
by asmtp-out5.blueyonder.co.uk with esmtpa (Exim 4.52)
id 1MmWY9-0005Nf-1R
for web15_enquiry@server.home2; Sat, 12 Sep 2009 18:38:13 +0100
Received: from n29.bullet.mail.ukl.yahoo.com (n29.bullet.mail.ukl.yahoo.com [87.248.110.146])
by server.home2 (Postfix) with SMTP id B379F2DC21C
for <enquiry@mydomain.co.uk>; Sat, 12 Sep 2009 18:38:12 +0100 (BST)
Received: from [217.146.182.180] by n29.bullet.mail.ukl.yahoo.com with NNFMP; 12 Sep 2009 17:38:12 -0000
Received: from [87.248.110.118] by t6.bullet.ukl.yahoo.com with NNFMP; 12 Sep 2009 17:38:12 -0000
Received: from [127.0.0.1] by omp223.mail.ukl.yahoo.com with NNFMP; 12 Sep 2009 17:38:12 -0000
X-Yahoo-Newman-Property: ymail-3
X-Yahoo-Newman-Id: 409449.4650.bm@omp223.mail.ukl.yahoo.com
Received: (qmail 25869 invoked by uid 60001); 12 Sep 2009 17:38:12 -0000
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.co.uk; s=s1024; t=1252777092; bh=HAZCiSc1Uto9LNWNrgIJr2qD7CVuhtT0j3J8+JiV078=; h=Message-ID:X-YMail-OSG:Received:X-Mailerate:From:Subject:To:In-Reply-To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=2xHICb+uKoYOb90ZfAD8OaskWJhLBZXU+JJxkXP4ClGzTYsi UCH+FUhQC9FT9aa4hTqUDpVWqfF7k3dze3T4v/xmWaWYIGuSk3rd138o/qxeHqnGUNijGKTIswR6hMZLGzU4TiuXjjlNa0lgAd6777O+DR1 NT7re8io9vzsTvEU=
DomainKey-Signature:a=rsa-sha1; q=dns; c=nofws;
s=s1024; d=yahoo.co.uk;
h=Message-ID:X-YMail-OSG:Received:X-Mailerate:From:Subject:To:In-Reply-To:MIME-Version:Content-Type:Content-Transfer-Encoding;
b=LXAaKsH+kjDUIwZQpJqcRsrN/965KBTjioV9NQ4oPnRh0VzZqzm3BtUMJqunWg2+aEJAdgDk/7uRKGzG3x2TR5I5EupL06ArIwvrlpEbkktS/h6xXUJ9elqZDC677sP+J6AdpRRxzFEpK+oyK6qid7nVW0jH/GiY2EvPGVVuhE0=;
Message-ID: <200189.25051.qm@web25802.mail.ukl.yahoo.com>
X-YMail-OSG: wpPxgAYVM1kg8Ccsl4Tf_G3Njp_V2RkXQjIlSqp0HQLt9KgbUX 8NvUQWoBzCIz9YxWbx3UnAmQ5.XZ90YZJXAmRIgTr5a.B9DtqM DaC9QEcN3sF8JMCbtnVmn_G2ebSSlYcbRsHdsCWeL.Ww_cbxm2 u3jwRpAQlzNzoZ38HbOZ_4mWJyu8VUPrca.T2SDofIQm1lpOhb Kr_nMgYRByQbefq_FUY25jSvKLM5jsuyFAZusnl4a.ozarcb5j VWnoxV.vVZmSgN0xNuZ_ryiF.ApxtdeS.a7l0ssEavn0dre0k-
Received: from [my ip address] by web25802.mail.ukl.yahoo.com via HTTP; Sat, 12 Sep 2009 17:38:12 GMT
X-Mailer: YahooMailClassic/7.0.14 YahooMailWebService/0.7.347.2
Date: Sat, 12 Sep 2009 17:38:12 +0000 (GMT)
From:Yahoo <yahoo@yahoo.co.uk>
Subject: Re: Test2
To: enquiry@mydomain.co.uk
In-Reply-To: <44707.192.168.2.3.1252777046.squirrel@www.writabl es.co.uk>
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable
This is the contents of the mail.log
Quote:
Sep 12 18:38:13 localhost postfix/smtpd[4718]: connect from n29.bullet.mail.ukl.yahoo.com[87.248.110.146]
Sep 12 18:38:13 localhost postfix/smtpd[4718]: B379F2DC21C: client=n29.bullet.mail.ukl.yahoo.com[87.248.110.146]
Sep 12 18:38:13 localhost postfix/cleanup[4721]: B379F2DC21C: message-id=<200189.25051.qm@web25802.mail.ukl.yahoo.com>
Sep 12 18:38:13 localhost postfix/qmgr[2133]: B379F2DC21C: from=<yahoo@yahoo.co.uk>, size=2655, nrcpt=1 (queue active)
Sep 12 18:38:13 localhost postfix/smtp[4730]: B379F2DC21C: to=<web15_enquiry@server.home2>, orig_to=<enquiry@mydomain.co.uk>, relay=smtp.blueyonder.co.uk[195.188.53.60]:25, delay=0.41, delays=0.15/0/0.17/0.09, dsn=2.0.0, status=sent (250 OK id=1MmWY9-0005Nf-1R)
Sep 12 18:38:13 localhost postfix/qmgr[2133]: B379F2DC21C: removed
Sep 12 18:38:13 localhost postfix/smtpd[4718]: disconnect from n29.bullet.mail.ukl.yahoo.com[87.248.110.146]
The dig MX returns my IP address for all the domains.

I have also tried sending email between the domains, this does not work either. Not sure what I ave done wrong..

Any help gratefully received.

Steve
Reply With Quote
Sponsored Links
  #2  
Old 13th September 2009, 10:04
StevenD StevenD is offline
Member
 
Join Date: Oct 2008
Posts: 43
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Ok, I have found something that maybe wrong.

Here is a record from my mail.log.ispconfigsave from when my mail was correctly routed.

Quote:
Mar 3 22:27:06 server postfix/qmgr[4360]: F11272DC2FF: from=<somebody@lycos.com>, size=1928, nrcpt=1 (queue active)
Mar 3 22:27:06 server postfix/smtpd[10290]: disconnect from mail-outfilter2.bo3.lycos.com[209.202.249.132]
Mar 3 22:27:06 server postfix/pickup[7406]: 270762DC311: uid=10002 from=<web8_ste>
Mar 3 22:27:06 server postfix/cleanup[10299]: 270762DC311: message-id=<20090303222706.270762DC311@server.home2>
Mar 3 22:27:06 server postfix/local[10300]: F11272DC2FF: to=<web8_ste@server.home2>, orig_to=<ste@mydomain.co.uk>, relay=local, delay=0.19, delays=0.13/0.02/0/0.05, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Mar 3 22:27:06 server postfix/qmgr[4360]: F11272DC2FF: removed
Now here is the same part from mail.log today.

Quote:
Sep 13 08:53:38 localhost postfix/smtpd[18735]: connect from n29.bullet.mail.ukl.yahoo.com[87.248.110.146]
Sep 13 08:53:38 localhost postfix/smtpd[18735]: E399B2DC169: client=n29.bullet.mail.ukl.yahoo.com[87.248.110.146]
Sep 13 08:53:38 localhost postfix/cleanup[18740]: E399B2DC169: message-id=<199982.43890.qm@web25807.mail.ukl.yahoo.com>
Sep 13 08:53:38 localhost postfix/qmgr[22541]: E399B2DC169: from=<somebody@yahoo.co.uk>, size=2662, nrcpt=1 (queue active)
Sep 13 08:53:38 localhost postfix/smtpd[18735]: disconnect from n29.bullet.mail.ukl.yahoo.com[87.248.110.146]
Sep 13 08:53:38 localhost postfix/smtp[18741]: E399B2DC169: to=<web15_enquiry@server.home2>, orig_to=<enquiry@mydomain.co.uk>, relay=smtp.blueyonder.co.uk[195.188.53.60]:25, delay=0.44, delays=0.1/0.05/0.21/0.08, dsn=2.0.0, status=sent (250 OK id=1Mmjty-0007mH-8w)
Sep 13 08:53:38 localhost postfix/qmgr[22541]: E399B2DC169: removed
As you can see it seems to be routing my mail back to the external email relay I use instead of local.

Not sure how to correct this.

Thanks

Steve
Reply With Quote
  #3  
Old 13th September 2009, 17:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Is server.home2 the domain of the email address? That's no official domain and therefore it's not routeable.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 13th September 2009, 19:49
StevenD StevenD is offline
Member
 
Join Date: Oct 2008
Posts: 43
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Hi Falko,

Thanks for your reply.

Looking at the server.home2, it was the same when I was receiving email before.

All that seems to have changed is that relay=local to relay=smtp.blueyonder.co.uk

Thanks

Steve
Reply With Quote
  #5  
Old 23rd September 2009, 20:13
StevenD StevenD is offline
Member
 
Join Date: Oct 2008
Posts: 43
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Hi,

I'm still struggling with this one. What makes it server.home2? where can this be changed, everything seemed fine till I added another domain on to ISPConfig.

Thanks

Steve
Reply With Quote
  #6  
Old 24th September 2009, 13:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 24th September 2009, 23:18
StevenD StevenD is offline
Member
 
Join Date: Oct 2008
Posts: 43
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Hi Falko,

Thank you for your reply.

main.cf contains
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = server.home2
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = server.home2, localhost.home2, , localhost
relayhost = smtp.blueyonder.co.uk
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options =
local-host-names contains
Code:
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
server
localhost.server
localhost.localdomain
www.my1stdomain.co.uk
www.my2nddomain.co.uk
www.my3rddomain.co.uk
my1stdomain.co.uk
my2nddomain.co.uk
my3rddomain.co.uk
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Thanks

Steve
Reply With Quote
  #8  
Old 25th September 2009, 12:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's in /etc/mailname?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 25th September 2009, 21:45
StevenD StevenD is offline
Member
 
Join Date: Oct 2008
Posts: 43
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Hi Falko,

Thanks again for your reply.

mailname contains.
Code:
server.home2
Thanks

Steve
Reply With Quote
  #10  
Old 26th September 2009, 14:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Ok, change the myhostname setting in /etc/postfix/main.cf and the hostname in /etc/mailname and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Problem with dcc-client installation (Postfix) swap-as Installation/Configuration 9 18th September 2008 20:47
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Can not recieve mail with de virtual mail adress Mounir Installation/Configuration 9 24th July 2006 23:16


All times are GMT +2. The time now is 04:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.