#1  
Old 14th October 2008, 22:33
aAdmavRic987 aAdmavRic987 is offline
Junior Member
 
Join Date: Oct 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Centos 5 Mail Server

This might be easy I hope. I have centos 5.2 installed and updated running my postfix - dovcote - ssl mail server. I can send and receive email, but I cannot connect to the mail server to check/download mail. I am trying to connect within my network (Linksys router). I have tried setting the incoming and outgoing address to my fqdn and my internal Ip with no luck. All I get out of "Windows Mail" is "Connecting" for about 30 seconds, then the error "The connection to the server has failed.

If you need anymore info from me let me know. The fqdn is aad4gamers.com and the MX is set to mail.aad4gamers.com 10 74.218.20.6.

http://mxtoolbox.com tells me that the connect time is "good" .062 seconds and the "transaction time is .0594, "relay" check says OK.

Did I forget to do something to beable to connect to this server? Remember I am trying to do this inside my network.
Reply With Quote
Sponsored Links
  #2  
Old 15th October 2008, 14:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

What's the output of
Code:
netstat -tap
?
Are there any errors in the mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th October 2008, 17:52
aAdmavRic987 aAdmavRic987 is offline
Junior Member
 
Join Date: Oct 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address Stat e PID/Program name
tcp 0 0 *:imaps *:* LIST EN 26179/dovecot
tcp 0 0 *op3s *:* LIST EN 26179/dovecot
tcp 0 0 *:839 *:* LIST EN 1929/rpc.statd
tcp 0 0 *:mysql *:* LIST EN 2984/mysqld
tcp 0 0 *op3 *:* LIST EN 26179/dovecot
tcp 0 0 *:imap *:* LIST EN 26179/dovecot
tcp 0 0 *:sunrpc *:* LIST EN 1899/portmap
tcp 0 0 *:ndmp *:* LIST EN 26020/perl
tcp 0 0 *:ftp *:* LIST EN 23256/pure-ftpd (SE
tcp 0 0 192.168.1.106:domain *:* LIST EN 2811/named
tcp 0 0 mav.aad4gamers.com:domain *:* LIST EN 2811/named
tcp 0 0 mav.aad4gamers.com:ipp *:* LIST EN 2129/cupsd
tcp 0 0 *:smtp *:* LIST EN 32004/master
tcp 0 0 mav.aad4gamers.com:rndc *:* LIST EN 2811/named
tcp 0 0 *:http *:* LIST EN 3831/httpd
tcp 0 0 *:ftp *:* LIST EN 23256/pure-ftpd (SE
tcp 0 0 *:ssh *:* LIST EN 2143/sshd
tcp 0 0 localhost6.localdomain:rndc *:* LIST EN 2811/named
tcp 0 0 *:https *:* LIST EN 3831/httpd
tcp 0 0 ::ffff:192.168.1.106:ssh ::ffff:192.168.1.104:62317 ESTA BLISHED 10786/4


Maillog is as follows:

Oct 15 04:02:02 mav postfix/smtpd[8694]: connect from mav.aad4gamers.com[127.0.0.1]
Oct 15 04:02:02 mav postfix/smtpd[8694]: setting up TLS connection from mav.aad4gamers.com[127.0.0.1]
Oct 15 04:02:02 mav postfix/smtpd[8694]: TLS connection established from mav.aad4gamers.com[127.0.0.1]: TLSv1 with cipher DHE-RSA-*****-SHA (256/256 bits)
Oct 15 04:02:02 mav sendmail[8925]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-*****-SHA, bits=256/256
Oct 15 04:02:02 mav postfix/smtpd[8694]: C4A6016843C: client=mav.aad4gamers.com[127.0.0.1], sasl_sender=root@mav.aad4gamers.com
Oct 15 04:02:02 mav postfix/cleanup[8697]: C4A6016843C: message-id=<200810150802.m9F8228G008925@mav.aad4gamers.com >
Oct 15 04:02:02 mav postfix/qmgr[32006]: C4A6016843C: from=<root@mav.aad4gamers.com>, size=4095, nrcpt=1 (queue active)
Oct 15 04:02:02 mav sendmail[8925]: m9F8228G008925: to=root, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=33451, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as C4A6016843C)
Oct 15 04:02:02 mav postfix/smtpd[8694]: disconnect from mav.aad4gamers.com[127.0.0.1]
Oct 15 04:02:02 mav postfix/smtp[8698]: C4A6016843C: to=<root@mav.aad4gamers.com>, relay=none, delay=0.1, delays=0.04/0/0.06/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=mav.aad4gamers.com type=A: Host not found)
Oct 15 04:02:02 mav postfix/cleanup[8697]: EA041168440: message-id=<20081015080202.EA041168440@mail.aad4gamers.com >
Oct 15 04:02:02 mav postfix/qmgr[32006]: EA041168440: from=<>, size=6051, nrcpt=1 (queue active)
Oct 15 04:02:02 mav postfix/bounce[8699]: C4A6016843C: sender non-delivery notification: EA041168440
Oct 15 04:02:02 mav postfix/qmgr[32006]: C4A6016843C: removed
Oct 15 04:02:03 mav postfix/smtp[8698]: EA041168440: to=<root@mav.aad4gamers.com>, relay=none, delay=0.05, delays=0.03/0/0.02/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=mav.aad4gamers.com type=A: Host not found)
Oct 15 04:02:03 mav postfix/qmgr[32006]: EA041168440: removed
Oct 15 04:02:21 mav postfix/smtpd[8694]: connect from unknown[192.168.1.1]
Oct 15 04:02:21 mav postfix/smtpd[8694]: E343816843C: client=unknown[192.168.1.1]
Oct 15 04:02:21 mav postfix/cleanup[8697]: E343816843C: message-id=<20081015080253.3E36622F8721@aad.aad4gamers.com >
Oct 15 04:02:21 mav postfix/qmgr[32006]: E343816843C: from=<root@aad4gamers.com>, size=881, nrcpt=1 (queue active)
Oct 15 04:02:21 mav postfix/smtpd[8694]: disconnect from unknown[192.168.1.1]
Oct 15 04:02:21 mav postfix/smtpd[8694]: connect from unknown[192.168.1.1]
Oct 15 04:02:21 mav postfix/smtp[8698]: warning: host aad4gamers.com[74.218.20.6]:25 greeted me with my own hostname mail.aad4gamers.com
Oct 15 04:02:21 mav postfix/smtp[8698]: warning: host aad4gamers.com[74.218.20.6]:25 replied to HELO/EHLO with my own hostname mail.aad4gamers.com
Oct 15 04:02:21 mav postfix/smtp[8698]: E343816843C: to=<root@aad4gamers.com>, relay=aad4gamers.com[74.218.20.6]:25, delay=0.05, delays=0.01/0/0.04/0, dsn=5.4.6, status=bounced (mail for aad4gamers.com loops back to myself)
Oct 15 04:02:21 mav postfix/smtpd[8694]: disconnect from unknown[192.168.1.1]
Oct 15 04:02:21 mav postfix/cleanup[8697]: F0972168440: message-id=<20081015080221.F0972168440@mail.aad4gamers.com >
Oct 15 04:02:21 mav postfix/qmgr[32006]: F0972168440: from=<>, size=2680, nrcpt=1 (queue active)
Oct 15 04:02:21 mav postfix/bounce[8699]: E343816843C: sender non-delivery notification: F0972168440
Oct 15 04:02:21 mav postfix/qmgr[32006]: E343816843C: removed
Oct 15 04:02:22 mav postfix/smtpd[8694]: connect from unknown[192.168.1.1]
Oct 15 04:02:22 mav postfix/smtp[8698]: warning: host aad4gamers.com[74.218.20.6]:25 greeted me with my own hostname mail.aad4gamers.com
Oct 15 04:02:22 mav postfix/smtp[8698]: warning: host aad4gamers.com[74.218.20.6]:25 replied to HELO/EHLO with my own hostname mail.aad4gamers.com
Oct 15 04:02:22 mav postfix/smtp[8698]: F0972168440: to=<root@aad4gamers.com>, relay=aad4gamers.com[74.218.20.6]:25, delay=0.05, delays=0.01/0/0.04/0, dsn=5.4.6, status=bounced (mail for aad4gamers.com loops back to myself)
Oct 15 04:02:22 mav postfix/smtpd[8694]: disconnect from unknown[192.168.1.1]
Oct 15 04:02:22 mav postfix/qmgr[32006]: F0972168440: removed


I have been able to send and receive messages using the servers "Webmin" postfix module. As stated before, I cannot connect to this server from another computer to read/download messages. I have not tried to have someone else from outside my network try to connect.

Last edited by aAdmavRic987; 15th October 2008 at 18:09.
Reply With Quote
  #4  
Old 16th October 2008, 14:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Are you using a firewall? What's the output of
Code:
iptables -L
?
Did you disable SELinux?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th October 2008, 20:56
aAdmavRic987 aAdmavRic987 is offline
Junior Member
 
Join Date: Oct 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

No firewall, no SELinux upon install. I have been following these instructions http://howtoforge.org/perfect-server...-5.2-x86_64-p5, and last night I decided to copy and paste the postfix main.cf from those instructions to my file and got it working.

Thank you, for your help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What can be wrong martin_rudowicz Installation/Configuration 9 11th May 2008 19:42
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 22:53
Rejecting outbound mail tristanlee85 General 11 20th May 2007 17:04
External mail server with gmail MX service adrenalinic Installation/Configuration 20 24th April 2007 14:49
Webmail Relay Error palkat General 17 23rd April 2006 18:12


All times are GMT +2. The time now is 08:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.