#1  
Old 21st September 2008, 04:35
happz happz is offline
Senior Member
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 261
Thanks: 35
Thanked 6 Times in 5 Posts
Default MailLog message

My maillog has this entry- Sep 20 22:14:51 websrv1 postfix/smtp[8791]: warning: database /etc/postfix/sasl_passwd.db is older than source file /etc/postfix/sasl_passwd
__________________________________________________ ________

How do i resolve this message or problem?

Also, if i may ask question #2.

I can send and receive emails to all i.e. yahoo, msn, aol..you name it...i have config. outlook to do this. So all is good there but my actual websites that run php script sites such as, well, v Bulletin...that ability to send users a message from within the website administration or another example is when a user signs up...they should be receiving an email that they can click a link for to authenticate them but it never shows up. Can anyone explain how i fix this?

Last edited by happz; 22nd September 2008 at 18:13. Reason: crap...i meant "can" sorry falko :)
Reply With Quote
Sponsored Links
  #2  
Old 21st September 2008, 10:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,768
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Quote:
How do i resolve this message or problem?
This file is not used by ISPConfig.

Quote:
Also, if i may ask question #2.
Do you run your server behind a dsl line with dynamic IP?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st September 2008, 14:03
happz happz is offline
Senior Member
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 261
Thanks: 35
Thanked 6 Times in 5 Posts
Default Yes...DSL

Till,

to send and receive emails it took me a long time to figure out how to use my ISP for smtp but now i can send/rec emails using outlook. i use pop3 of my centos server via perfect server config and i use my isp setting for smtp. all will work but internal websites like my forum sites and youtube clones will not send any email at all.

thanks
happz
Reply With Quote
  #4  
Old 21st September 2008, 14:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,768
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Please answer my question from above:

Quote:
Do you run your server behind a dsl line with dynamic IP?
We can not help you if you dont answer the questions
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 21st September 2008, 14:52
happz happz is offline
Senior Member
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 261
Thanks: 35
Thanked 6 Times in 5 Posts
Default please read on..

Sorry Till but my title was the answer in the previous response but you are right...i forgot some info. the answer is yes, i am running server behind dsl and i have a static IP.

thank you.

happz

Last edited by happz; 21st September 2008 at 15:29. Reason: for info
Reply With Quote
  #6  
Old 22nd September 2008, 13:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Most dynamic IP addresses are blacklisted nowadays (see http://mxtoolbox.com/blacklists.aspx ) so that's most likely the reason why you can't send emails. To overcome this, you can relay your emails through another mailserver: http://www.howtoforge.com/postfix_re...her_mailserver
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 22nd September 2008, 13:15
happz happz is offline
Senior Member
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 261
Thanks: 35
Thanked 6 Times in 5 Posts
Default does anyone else run php sites like vbulletin and can't send mail..

if anyone can help, this is the last major problem i need to get through in order to close down my godaddy VPS. None of my php sites will send mail such as when a user signs up on my site...they should receive a welcome email....but nope...not getting it.

thanks

happz
Reply With Quote
  #8  
Old 22nd September 2008, 17:44
happz happz is offline
Senior Member
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 261
Thanks: 35
Thanked 6 Times in 5 Posts
Default Thanks Falko..i do not have a dynamic IP and I can send/receive emails

Quote:
Originally Posted by falko View Post
Most dynamic IP addresses are blacklisted nowadays (see http://mxtoolbox.com/blacklists.aspx ) so that's most likely the reason why you can't send emails. To overcome this, you can relay your emails through another mailserver: http://www.howtoforge.com/postfix_re...her_mailserver

I can send/receive emails because i am relaying them. My problem is with my websites (all are php just like this one, howtoforge) but no messages will work...say you forget your password, click forgot password and nothing will go. that is my problem now.

happz
Reply With Quote
  #9  
Old 23rd September 2008, 20:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's in your mail log when a PHP app tries to send a mail?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 24th September 2008, 04:52
happz happz is offline
Senior Member
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 261
Thanks: 35
Thanked 6 Times in 5 Posts
 
Default here is one resulted log...

i did an invite and here is the log, i did remove some personal info from the log----
__________________________________________________ _____________
Sep 23 22:39:21 websrv1 sendmail[1713]: m8O2dLB8001713: from=apache, size=711, class=0, nrcpts=2, msgid=<200809240239.m8O2dLB8001713@websrv1.myhidde ndomain.com>, relay=apache@localhost
Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: connect from localhost.localdomain[127.0.0.1]
Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: setting up TLS connection from localhost.localdomain[127.0.0.1]
Sep 23 22:39:21 websrv1 sendmail[1713]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: B7BCB34D07EB: client=localhost.localdomain[127.0.0.1], sasl_sender=apache@websrv1.myhiddendomain.com
Sep 23 22:39:21 websrv1 postfix/cleanup[1717]: B7BCB34D07EB: message-id=<200809240239.m8O2dLB8001713@websrv1.myhiddendo main.com>
Sep 23 22:39:21 websrv1 sendmail[1713]: m8O2dLB8001713: to=joe.joe@lpnq.com,noreply@somenameimadeup.com, ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60711, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as B7BCB34D07EB)
Sep 23 22:39:21 websrv1 postfix/qmgr[986]: B7BCB34D07EB: from=<apache@websrv1.myhiddendomain.com>, size=1192, nrcpt=2 (queue active)
Sep 23 22:39:21 websrv1 postfix/smtpd[1714]: disconnect from localhost.localdomain[127.0.0.1]
Sep 23 22:39:21 websrv1 postfix/qmgr[986]: B7BCB34D07EB: to=<hiddenname@hd.net>, relay=none, delay=0.09, delays=0.05/0.04/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to fmailhost.isp.att.net[204.127.217.18]: Connection timed out)
Sep 23 22:39:21 websrv1 postfix/cleanup[1717]: CE90A34D07EC: message-id=<200809240239.m8O2dLB8001713@websrv1.myhiddendo main.com>
Sep 23 22:39:21 websrv1 postfix/local[1719]: B7BCB34D07EB: to=<web11_noreply@websrv1.myhiddendomain.com>, orig_to=<noreply@somenameimadeup.com>, relay=local, delay=0.11, delays=0.05/0.05/0/0, dsn=2.0.0, status=sent (forwarded as CE90A34D07EC)
Sep 23 22:39:21 websrv1 postfix/qmgr[986]: CE90A34D07EC: from=<apache@websrv1.myhiddendomain.com>, size=1362, nrcpt=1 (queue active)
Sep 23 22:39:21 websrv1 postfix/qmgr[986]: CE90A34D07EC: to=<aname@something.com>, orig_to=<noreply@somenameimadeup.com>, relay=none, delay=0.01, delays=0/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to fmailhost.isp.att.net[204.127.221.14]: Connection timed out)
[root@websrv1 log]#
__________________________________________________ ______________
here is another log----Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: 3C72834D07E6: client=localhost.localdomain[127.0.0.1], sasl_sender=apache@websrv1.myhiddendomain.com
Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: 3C72834D07E6: reject: RCPT from localhost.localdomain[127.0.0.1]: 550 5.1.1 <noreply@somenameimadeup.com>: Recipient address rejected: User unknown in local recipient table; from=<apache@websrv1.myhiddendomain.com> to=<noreply@somenameimadeup.com> proto=ESMTP helo=<websrv1.myhiddendomain.com>
Sep 23 22:00:39 websrv1 sendmail[32362]: m8O20cGm032362: to=noreply@somenameimadeup.com, ctladdr=apache (48/48), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=60706, relay=[127.0.0.1] [127.0.0.1], dsn=5.1.1, stat=User unknown
Sep 23 22:00:39 websrv1 postfix/cleanup[32366]: 3C72834D07E6: message-id=<200809240200.m8O20cGm032362@websrv1.myhiddendo main.com>
Sep 23 22:00:39 websrv1 postfix/qmgr[3861]: 3C72834D07E6: from=<apache@websrv1.myhiddendomain.com>, size=1218, nrcpt=1 (queue active)
Sep 23 22:00:39 websrv1 sendmail[32362]: m8O20cGm032362: to=nonono@msn.com, ctladdr=apache (48/48), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=60706, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 3C72834D07E6)
Sep 23 22:00:39 websrv1 sendmail[32362]: m8O20cGm032362: m8O20cGn032362: DSN: User unknown
Sep 23 22:00:39 websrv1 postfix/qmgr[3861]: 3C72834D07E6: to=<nonono@msn.com>, relay=none, delay=0.07, delays=0.06/0.01/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to fmailhost.isp.att.net[204.127.217.18]: Connection timed out)
Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: 4C08F34D07E7: client=localhost.localdomain[127.0.0.1]
Sep 23 22:00:39 websrv1 postfix/cleanup[32366]: 4C08F34D07E7: message-id=<200809240200.m8O20cGn032362@websrv1.myhiddendo main.com>
Sep 23 22:00:39 websrv1 postfix/qmgr[3861]: 4C08F34D07E7: from=<>, size=3226, nrcpt=1 (queue active)
Sep 23 22:00:39 websrv1 sendmail[32362]: m8O20cGn032362: to=apache, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31730, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 4C08F34D07E7)
Sep 23 22:00:39 websrv1 postfix/smtpd[32363]: disconnect from localhost.localdomain[127.0.0.1]
Sep 23 22:00:39 websrv1 postfix/local[32368]: 4C08F34D07E7: to=<root@websrv1.myhiddendomain.com>, orig_to=<apache@websrv1.myhiddendomain.com>, relay=local, delay=0.09, delays=0.05/0.04/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
Sep 23 22:00:39 websrv1 postfix/qmgr[3861]: 4C08F34D07E7: removed
You have new mail in /var/spool/mail/root
__________________________________________________ _____________-

So any ideas?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error message: cant access nm_dbus geoffree Installation/Configuration 2 11th June 2008 16:14
got this message today.... i am stumped MisterVlad Installation/Configuration 5 22nd June 2007 13:52
Rejecting outbound mail tristanlee85 General 11 20th May 2007 17:04
How to increase Message size problem AngelDrago Installation/Configuration 2 19th May 2007 16:24
Change Postfix Quota exceeded error message steowimmy Installation/Configuration 3 16th November 2006 15:20


All times are GMT +2. The time now is 09:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.