#1  
Old 24th February 2006, 13:53
d3m0nic d3m0nic is offline
Member
 
Join Date: Feb 2006
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default Net::DNS error

TOPIC CLOSED! see last message!

Hello,

I'm trying to install Net::DNS like it is done in the guide The Perfect Setup - Fedora Core 4 on a CentOS 4.2 distro. I keep getting this error message:

Code:
[root@www ~]# perl -MCPAN -e shell
cpan>  install Net::DNS
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
  Database was generated on Thu, 23 Feb 2006 18:40:22 GMT
Running install for module Net::DNS
Running make for O/OL/OLAF/Net-DNS-0.56.tar.gz
CPAN: Digest::MD5 loaded ok
Checksum for /root/.cpan/sources/authors/id/O/OL/OLAF/Net-DNS-0.56.tar.gz ok
Scanning cache /root/.cpan/build for sizes
Net-DNS-0.56/
... cut ...
Net-DNS-0.56/TODO
Removing previously used /root/.cpan/build/Net-DNS-0.56

  CPAN.pm: Going to build O/OL/OLAF/Net-DNS-0.56.tar.gz

The libraries needed to support IPv6 transport have not been found.
You will need recent versions of the IO::Socket::INET6 and Socket6
libraries (from CPAN).

Testing if you have a C compiler and the needed header files....
cc    -c -o compile.o compile.c
You have a working compiler.

You appear to be directly connected to the Internet.  I have some tests
that try to query live nameservers.

Do you want to enable these tests? [y] n
Checking if your kit is complete...
Looks good
Writing Makefile for Net::DNS
cp lib/Net/DNS/RR/A.pm blib/lib/Net/DNS/RR/A.pm
... cut ...
cp lib/Net/DNS/Resolver/Base.pm blib/lib/Net/DNS/Resolver/Base.pm
gcc -c   -D_REENTRANT -D_GNU_SOURCE -DDEBUGGING -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 

-I/usr/include/gdbm -O2 -g -pipe -m32 -march=i386 -mtune=pentium4   -DVERSION=\"0.56\" -DXS_VERSION=\"0.56\" -fPIC 

"-I/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE"   netdns.c
ar cr netdns.a netdns.o
: netdns.a
/usr/bin/perl /usr/lib/perl5/5.8.5/ExtUtils/xsubpp  -typemap /usr/lib/perl5/5.8.5/ExtUtils/typemap  DNS.xs > DNS.xsc && mv DNS.xsc DNS.c
gcc -c   -D_REENTRANT -D_GNU_SOURCE -DDEBUGGING -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 

-I/usr/include/gdbm -O2 -g -pipe -m32 -march=i386 -mtune=pentium4   -DVERSION=\"0.56\" -DXS_VERSION=\"0.56\" -fPIC 

"-I/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE"   DNS.c
Running Mkbootstrap for Net::DNS ()
chmod 644 DNS.bs
rm -f blib/arch/auto/Net/DNS/DNS.so
gcc  -shared -L/usr/local/lib DNS.o  -o blib/arch/auto/Net/DNS/DNS.so netdns.a
chmod 755 blib/arch/auto/Net/DNS/DNS.so
cp DNS.bs blib/arch/auto/Net/DNS/DNS.bs
chmod 644 blib/arch/auto/Net/DNS/DNS.bs
Manifying blib/man3/Net::DNS::RR::A.3pm
Manifying blib/man3/Net::DNS::Resolver::Win32.3pm
... cut ...
Manifying blib/man3/Net::DNS::Resolver::Base.3pm
  /usr/bin/make  -- OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-load..................ok
t/00-pod...................skipped
        all skipped: Test::Pod v0.95 required for testing POD
t/00-version...............ok
t/01-resolver-env..........ok
t/01-resolver-file.........ok
        7/8 skipped: Could not read configuration file
t/01-resolver-opt..........ok
t/01-resolver..............ok
        2/44 skipped: Online tests disabled.
t/02-header................ok
t/03-question..............ok
t/04-packet-unique-push....ok
t/04-packet................ok
t/05-rr-opt................ok
t/05-rr-rrsort.............ok
t/05-rr-sshfp..............ok
t/05-rr-txt................ok
t/05-rr-unknown............ok
t/05-rr....................ok
t/06-update................ok
t/07-misc..................ok
t/08-online................skipped
        all skipped: Online tests disabled.
t/09-tkey..................ok
t/10-recurse...............skipped
        all skipped: Online tests disabled.
t/11-escapedchars..........# Using the  XS compiled dn_expand function
t/11-escapedchars..........ok 95/141#
# disabling XS based dns_expand for a moment.
t/11-escapedchars..........ok 98/141#
# Continuing to use the XS based dn_expand()
t/11-escapedchars..........ok
t/11-inet6.................ok 8/11# Looks like you planned 11 tests but only ran 10.
t/11-inet6.................dubious
        Test returned status 1 (wstat 256, 0x100)
DIED. FAILED test 11
        Failed 1/11 tests, 90.91% okay (less 9 skipped tests: 1 okay, 9.09%)
Failed Test  Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/11-inet6.t    1   256    11    2  18.18%  11
3 tests and 18 subtests skipped.
Failed 1/24 test scripts, 95.83% okay. 1/961 subtests failed, 99.90% okay.
make: *** [test_dynamic] Error 2
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force
Next i tried to install IO::Socket::INET6...
Code:
cpan> install IO::Socket::INET6
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
  Database was generated on Thu, 23 Feb 2006 18:40:22 GMT
Running install for module IO::Socket::INET6
Running make for M/MO/MONDEJAR/IO-Socket-INET6-2.51.tar.gz
CPAN: Digest::MD5 loaded ok
Checksum for /root/.cpan/sources/authors/id/M/MO/MONDEJAR/IO-Socket-INET6-2.51.tar.gz ok
Scanning cache /root/.cpan/build for sizes
IO-Socket-INET6-2.51/
... cut ...
IO-Socket-INET6-2.51/MANIFEST
Removing previously used /root/.cpan/build/IO-Socket-INET6-2.51

  CPAN.pm: Going to build M/MO/MONDEJAR/IO-Socket-INET6-2.51.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for IO::Socket::INET6
cp INET6.pm blib/lib/IO/Socket/INET6.pm
Manifying blib/man3/IO::Socket::INET6.3pm
  /usr/bin/make  -- OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/io_multihomed6....ok
t/io_sock6..........ok 11/20Died at t/io_sock6.t line 39, <GEN5> line 2.
t/io_sock6..........dubious
        Test returned status 4 (wstat 1024, 0x400)
DIED. FAILED tests 12-20
        Failed 9/20 tests, 55.00% okay
t/io_udp6...........ok
Failed Test  Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/io_sock6.t    4  1024    20   18  90.00%  12-20
Failed 1/3 test scripts, 66.67% okay. 9/32 subtests failed, 71.88% okay.
make: *** [test_dynamic] Error 255
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force
What do i have to do with this... skip it and just install ISPConfig and Spamassasin or does anyone on this forum have a solution. As i said earlier, i'm using CentOS and with yum i already installed Spamassassin (3.0.4-1.el4), so i don't know if i need this at all... hopefully you guys could help me out.

Thanks

Last edited by d3m0nic; 24th February 2006 at 15:35.
Reply With Quote
Sponsored Links
  #2  
Old 24th February 2006, 14:58
ovis ovis is offline
Junior Member
 
Join Date: Oct 2005
Posts: 28
Thanks: 0
Thanked 2 Times in 2 Posts
Post

Quote:
Originally Posted by d3m0nic
Hello,

I'm trying to install Net :: DNS like it is done in the guide The Perfect Setup - Fedora Core 4 on a CentOS 4.2 distro. I keep getting this error message:
Yesterday i had problems with Net :: DNS on Debian Sarge and i did't even got to the test part. My fix was downgrade Net :: DNS 1 point to:

Net-DNS-0.55.tar.gz

untar and did a:

perl Makefile.PL
make
make install


Net-DNS-0.55 is from 14-Dec-2005 11:18 124K
and
Net-DNS-0.56 is from 20-Feb-2006 13:04 128K

That barly 4 days old

Well if this fix your trouble than you know the problem is in the new software
(.56) and if the problem persist that maybe in your setup is something wrong.

Hope this helps

PS I dont know mutch form perl maybe that the tests fail isnt a problem at all
but i leave that to the experts

Gr ovis
Reply With Quote
  #3  
Old 24th February 2006, 15:25
d3m0nic d3m0nic is offline
Member
 
Join Date: Feb 2006
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I think i have the solution already... it's READING the output after installing Spamassassin. My apologies for asking this question when all i had to do is:

Code:
[root@www ~]# yum -y install spamassassin
Installed: spamassassin.i386 0:3.0.4-1.el4
Dependency Installed: perl-Digest-HMAC.noarch 0:1.01-13 
perl-Digest-SHA1.i386 0:2.07-5 
perl-Net-DNS.i386 0:0.48-1 
perl-Time-HiRes.i386 0:1.55-3
Complete!
It looks like this Net::DNS module is being installed with Spamassassin!

So i guess i can start installing ISPConfig now... thanks d3m0nic... for helping d3m0nic out! HAHAHA :p

...and thanks Ovis, for the lighting quick reply! thumbs up!

Last edited by d3m0nic; 24th February 2006 at 15:28.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 17:14
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 19:07
error while installing..... securitywonks Installation/Configuration 1 23rd December 2005 13:07
Could not make OpenSSL yontengyatso Installation/Configuration 3 3rd November 2005 11:50
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 5th October 2005 00:53


All times are GMT +2. The time now is 00:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.