Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd March 2014, 00:04
adrian2k7 adrian2k7 is offline
Junior Member
 
Join Date: Mar 2014
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Default Mail-Catchall and forwarding stopped working

Hello,

since today my server isn't forwarding emails anymore (worked for month now). Also catchall isn't working as well.

All message get bounced fromdovecot, but from what I've read so far postfix should forward the mails itself and dovecote shouldn't even be involved?

From the log:
Code:
 relay=dovecot, delay=0.27, delays=0.25/0.01/0/0.02, dsn=5.1.1, status=bounced (user unknown)
  • It doesn't matter who the sender is (internal or external)
  • The (forward) recipient doesn't matter as well (internal or external)

What I did today with the server:
  • Installed Roundcube (had nothing similar before)
  • Did an ugrade of installed software (clamav received an update)

I also compared the configuration files with a backup from last week and didn't find any noticeable.

Now I already spend hours to figure down the problem. I hope you have some tipps, I really want to avoid reinstalling the whole server.

Is there a way to figure out what postfix is doing and why it is not correctly forwarding mails or is it really a dovecot problem?

My installation is http://www.howtoforge.com/using-roun...wheezy-apache2
Reply With Quote
Sponsored Links
  #2  
Old 22nd March 2014, 00:52
adrian2k7 adrian2k7 is offline
Junior Member
 
Join Date: Mar 2014
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Okay, just solved it (at least for now), with the solution from here: http://www.howtoforge.com/forums/showthread.php?t=36419
  • Remove amavis
  • And set "no_unknown_recipient_checks"

I still don't know why this caused the problem. Maybe someone knows more.
Reply With Quote
Reply

Bookmarks

Tags
catchall, dovecot, forward, postfix

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Catchall and Forwarding not working simmo General 6 22nd March 2014 00:54
Send Copy To / Maildrop filter forwarding not working jluros Installation/Configuration 7 8th February 2011 20:10
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00


All times are GMT +2. The time now is 00:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.