Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th September 2008, 23:38
daFritz84 daFritz84 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix / Procmail does not deliver to right local location

Hi all,

I've setup ispconfig on a CentOS 4.7 System and I'm using postfix as my email server. All seems fine so far since I can send and receive emails.

I believe that the emails are stored in a wrong maildir since I cannot see them in UebiMiau Webmail or in a local mail client, but I see them on my harddrive.

Any clue how comes that?
If you need to have some further insights in my configuration, let me know ...

some part of my maillog:
Sep 26 23:13:31 root86 postfix/smtpd[27042]: connect from mail.gmx.net[213.165.64.20]
Sep 26 23:13:31 root86 postfix/smtpd[27042]: 32E70808A: client=mail.gmx.net[213.165.64.20]
Sep 26 23:13:31 root86 postfix/cleanup[27047]: 32E70808A: message-id=<48DD507A.9020605@gmx.at>
Sep 26 23:13:31 root86 postfix/qmgr[27039]: 32E70808A: from=<_obfuscatedaddress_>, size=1248, nrcpt=1 (queue active)
Sep 26 23:13:31 root86 postfix/smtpd[27042]: disconnect from mail.gmx.net[213.165.64.20]
Sep 26 23:13:31 root86 sendmail[27053]: m8QLDVAt027053: from=stefan.seifried, size=127, class=0, nrcpts=1, msgid=<200809262113.m8QLDVAt027053@root86.localdom ain>, relay=stefan.seifried@localhost
Sep 26 23:13:31 root86 postfix/smtpd[27042]: connect from localhost[127.0.0.1]
Sep 26 23:13:31 root86 postfix/smtpd[27042]: setting up TLS connection from localhost[127.0.0.1]
Sep 26 23:13:31 root86 postfix/smtpd[27042]: TLS connection established from localhost[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Sep 26 23:13:31 root86 sendmail[27053]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Sep 26 23:13:31 root86 postfix/smtpd[27042]: 8AB668244: client=localhost[127.0.0.1]
Sep 26 23:13:31 root86 postfix/cleanup[27047]: 8AB668244: message-id=<200809262113.m8QLDVAt027053@root86.localdomain >
Sep 26 23:13:31 root86 postfix/qmgr[27039]: 8AB668244: from=<stefan.seifried@root86.localdomain>, size=761, nrcpt=1 (queue active)
Sep 26 23:13:31 root86 sendmail[27053]: m8QLDVAt027053: to=admispconfig@localhost.localdomain, ctladdr=stefan.seifried (10006/10005), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30127, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 8AB668244)
Sep 26 23:13:31 root86 postfix/smtpd[27042]: disconnect from localhost[127.0.0.1]
Sep 26 23:13:31 root86 postfix/local[27048]: 32E70808A: to=<stefn.seifried_at_fakedomain.at>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Sep 26 23:13:31 root86 postfix/qmgr[27039]: 32E70808A: removed
Sep 26 23:13:31 root86 postfix/local[27056]: 8AB668244: to=<admispconfig@root86.localdomain>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Sep 26 23:13:31 root86 postfix/qmgr[27039]: 8AB668244: removed
Sep 26 23:14:28 root86 dovecot: pop3-login: Login: user=<stefan.seifried>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Sep 26 23:14:28 root86 dovecot: POP3(stefan.seifried): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
Sep 26 23:14:34 root86 dovecot: pop3-login: Login: user=<stefan.seifried>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Sep 26 23:14:34 root86 dovecot: POP3(stefan.seifried): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
Sep 26 23:16:51 root86 postfix/anvil[27045]: statistics: max connection rate 1/60s for (smtp:213.165.64.20) at Sep 26 23:13:31
Sep 26 23:16:51 root86 postfix/anvil[27045]: statistics: max connection count 1 for (smtp:213.165.64.20) at Sep 26 23:13:31
Sep 26 23:16:51 root86 postfix/anvil[27045]: statistics: max cache size 1 at Sep 26 23:13:31
Sep 26 23:20:12 root86 dovecot: pop3-login: Login: user=<stefan.seifried>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Sep 26 23:20:12 root86 dovecot: POP3(stefan.seifried): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
Sep 26 23:22:12 root86 dovecot: imap-login: Login: user=<stefan.seifried>, method=PLAIN, rip=xx.xx.xx.xx, lip=xx.xx.xx.xx
Reply With Quote
Sponsored Links
  #2  
Old 27th September 2008, 09:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,032
Thanks: 826
Thanked 5,382 Times in 4,229 Posts
Default

Please enable the maildir checkbox under management > server > settings in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th September 2008, 11:21
daFritz84 daFritz84 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till,

I already enabled the checkbox. And the mail is delivered to the location stated in /etc/passwd. But I think the user directory path's are rather strange.

e.g.:
Code:
stefan.seifried:x:10006:10005:Stefan Seifried:/home/tmp/install_ispconfig/web5:/bin/false
For your information /home/tmp/install_ispconfig was my directory for installation. But if I follow the path I can find my email in there.

Any ideas why ispconfig uses that path when entering the mail users in my /etc/passwd?

Thanks,
Stefan
Reply With Quote
  #4  
Old 27th September 2008, 11:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,032
Thanks: 826
Thanked 5,382 Times in 4,229 Posts
Default

This path is indeed starnge. Did you install ISPConfig with its installer or did you installed the sql dump manually?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 27th September 2008, 11:40
daFritz84 daFritz84 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I used the installer. I prepared my system according to the tutorial for centos 4.6 since 4.7 was not available.

The root server itself I'm preparing was originally delivered with CentOS 4.7 and BlueQuartz. But I wiped off BlueQuartz since it is discontinued for some time now .
Reply With Quote
  #6  
Old 27th September 2008, 18:10
daFritz84 daFritz84 is offline
Junior Member
 
Join Date: Sep 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi, I resolved the problem by editing the dovecot mail_location property to point to the right place. However since I find the used directories very strange I did a clean reinstallatio and now I have also more convenient pathes.

Thanks, for your help attempts Till
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 20:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.