#101  
Old 2nd March 2008, 08:00
azidtripz azidtripz is offline
Junior Member
 
Join Date: May 2007
Posts: 19
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Thank you very much Till that worked great, now to 2 minor problems (i hope) on bootup it says this mysql user cant log in "debian-sys-maint". and also when i run this command "postmap /etc/postfix/virtusertable" i get the following error

postmap /etc/postfix/virtusertable
postmap: fatal: open /etc/postfix/virtusertable.db: Permission denied
Reply With Quote
Sponsored Links
  #102  
Old 3rd March 2008, 18:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by azidtripz
Thank you very much Till that worked great, now to 2 minor problems (i hope) on bootup it says this mysql user cant log in "debian-sys-maint".
Please make sure you use the correct password in /etc/mysql/debian.cnf for the debian-sys-maint user.

Quote:
Originally Posted by azidtripz
and also when i run this command "postmap /etc/postfix/virtusertable" i get the following error

postmap /etc/postfix/virtusertable
postmap: fatal: open /etc/postfix/virtusertable.db: Permission denied
What's the output of
Code:
ls -la /etc/postfix
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
azidtripz (3rd March 2008)
  #103  
Old 3rd March 2008, 21:45
azidtripz azidtripz is offline
Junior Member
 
Join Date: May 2007
Posts: 19
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Code:
total 104
drwxr-xr-x  4 root      root       4096 2008-03-02 16:43 .
drwxr-xr-x 76 root      root       4096 2008-03-03 12:45 ..
-rw-r--r--  1 root      root        318 2008-03-02 14:15 dynamicmaps.cf
-rw-r--r--  1 azidtripz azidtripz   485 2008-03-02 17:01 local-host-names
-rw-r--r--  1 root      root        380 2008-03-02 17:01 local-host-names~
-rw-r--r--  1 root      root       1852 2008-03-02 16:17 main.cf
-rw-r--r--  1 root      root       1756 2008-03-02 16:17 main.cf.orig
-rw-r--r--  1 root      root       4035 2008-03-02 14:15 master.cf
-rw-r--r--  1 root      root      18116 2007-10-06 11:19 postfix-files
-rwxr-xr-x  1 root      root       7121 2007-10-06 11:19 postfix-script
-rwxr-xr-x  1 root      root      22197 2007-10-06 11:19 post-install
drwxr-xr-x  2 root      root       4096 2008-03-02 14:17 sasl
drwxr-xr-x  2 root      root       4096 2008-03-02 14:21 ssl
-rw-r--r--  1 azidtripz azidtripz   939 2008-03-02 17:01 virtusertable
-rw-r--r--  1 root      root          0 2008-03-02 17:01 virtusertable~
-rw-r--r--  1 root      root      12288 2008-03-02 16:17 virtusertable.db
so i assume i have the wrong permissions, what do i need to change them too ?

also fixed mysql problem, didn't know where to look for the password so thankyou
Reply With Quote
  #104  
Old 4th March 2008, 19:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Did you run the postmap command as root?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #105  
Old 5th March 2008, 02:08
azidtripz azidtripz is offline
Junior Member
 
Join Date: May 2007
Posts: 19
Thanks: 8
Thanked 0 Times in 0 Posts
Default

yes i most certainly did :/

Last edited by azidtripz; 5th March 2008 at 02:12.
Reply With Quote
  #106  
Old 5th March 2008, 16:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Please try
Code:
chown root:root /etc/postfix/virtusertable
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
azidtripz (5th March 2008)
  #107  
Old 5th March 2008, 23:51
azidtripz azidtripz is offline
Junior Member
 
Join Date: May 2007
Posts: 19
Thanks: 8
Thanked 0 Times in 0 Posts
Default

thankyou falko, i just thought since i was running as root, that it would work, but its all sorted now, thank you guys for all your help

i have just moved my server from a dell poweredge 1650 to a 701 eeePc, because i couldn't afford my power bill and the eee consumes 14watts of power and seems to handle it all quiet well....
Reply With Quote
  #108  
Old 4th April 2008, 17:10
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 419
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default

Hello Falko,
quick question to first page of this thread:


Do i have to transfer /etc/passwd, /etc/shadow, /etc/group, /etc/postfix/local-host-names, /etc/postfix/virtusertable before i restore the old database?
those files seems to be correctly created after IPSC is restarted after restoring database..
Reply With Quote
  #109  
Old 5th April 2008, 21:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by radim_h
Hello Falko,
quick question to first page of this thread:


Do i have to transfer /etc/passwd, /etc/shadow, /etc/group, /etc/postfix/local-host-names, /etc/postfix/virtusertable before i restore the old database?
Yes, but if your files seem to be ok, then it's fine, too.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #110  
Old 9th April 2008, 18:21
titanium titanium is offline
Junior Member
 
Join Date: Oct 2006
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default Missing config line

Hi there

Thanks for the excellent tips for moving ISPConfig between servers. However, with regards to the following step:

Quote:
Originally Posted by falko
Code:
echo "*  smtp:[<IP address of new server>]" >> /etc/postfix/transport
postmap /etc/postfix/transport
/etc/init.d/postfix restart
This won't work until you add the following line to /etc/postfix/main.cf :

Code:
transport_maps = hash:/etc/postfix/transport
and restart Postfix.

Mails on my old server weren't being relayed to the new server until I inserted this line!

Regards
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot access ispconfig site Nu2Linux Installation/Configuration 13 3rd January 2009 15:29
Users and websites aren't created Glorfindel Installation/Configuration 9 23rd February 2006 04:20
42goISP vs. ISPConfig nveid General 1 16th January 2006 09:07
Mirroring ISPConfig with DRBD rodriglm General 5 2nd January 2006 12:48
Moving mail in ISPConfig rodriglm General 3 7th December 2005 09:44


All times are GMT +2. The time now is 03:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.