Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 27th February 2006, 23:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by dfriis
Seems that no redirection works at all. When I browse the ip-adress I get that same docroot, but I should get the sharedip page, right?
Yes, right.

Did you follow this tutorial? http://www.howtoforge.com/perfect_setup_debian_sarge

Did you do things differently than described in the tutorial?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #32  
Old 28th February 2006, 07:40
dfriis dfriis is offline
Junior Member
 
Join Date: Feb 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, I followed that tutorial but no, I did nothing differently what I can tell. Since I haven't gotten this to work a few times I was careful not to make any mistakes and copy-pasted most of it.

As I've mentioned before my server is behind a router and the only thing I'm not sure about is when I should use my public ip and when to use my internal ip when configuring the server and dns settings. Could an error in the ip settings create the problem I'm having?
Reply With Quote
  #33  
Old 28th February 2006, 09:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
Default

Quote:
Originally Posted by dfriis
Yes, I followed that tutorial but no, I did nothing differently what I can tell. Since I haven't gotten this to work a few times I was careful not to make any mistakes and copy-pasted most of it.

As I've mentioned before my server is behind a router and the only thing I'm not sure about is when I should use my public ip and when to use my internal ip when configuring the server and dns settings. Could an error in the ip settings create the problem I'm having?
Yes, if your IP settings are incorrect you might get this error.

If you are in a NAT eviroment, always use your internal IP address. Only in the ISPConfig DNS-Manager you will have to use your external IP.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #34  
Old 28th February 2006, 09:53
dfriis dfriis is offline
Junior Member
 
Join Date: Feb 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oh my...
The problem was huge, but the solution was simple. I had my external ip put up instead of my internal. I'm sorry that I've caused you such troubles.
The only problem I have now is that the web-ftp doesn't let me in but I'll fix that I guess.
Thanks for all your help though, I'll go stand in the corner now.
Reply With Quote
  #35  
Old 18th April 2006, 05:30
mebusybody mebusybody is offline
Junior Member
 
Join Date: Apr 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
That's weird. There must be something really mixed up on your system. Please check the ISPConfig database if it uses /home/www everywhere.
What's at the end of your Apache configuration file? It should look like this:

Code:
###############ispconfig_log###############
LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

<Directory /home/www/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /home/www/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /home/www/*/cgi-bin>
    Options ExecCGI -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

Include /etc/apache/vhosts/Vhosts_ispconfig.conf

Hi falko
I had the same error, the <Directory /home/www/*/web>... was NOT in my httpd.conf, I added in restart the server but still have the same error.

I started a new thread http://www.howtoforge.com/forums/showthread.php?t=3756 regarding this. Should we continue with this thread or the other.

Thanks
Reply With Quote
  #36  
Old 18th April 2006, 10:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Quote:
Originally Posted by mebusybody
I started a new thread http://www.howtoforge.com/forums/showthread.php?t=3756 regarding this. Should we continue with this thread or the other.

Thanks
Let's take this to the new thread.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Default Mail scan settings for new users timehost Installation/Configuration 3 26th October 2007 12:05
Sites that are added using ISPConfig Tool direct to Apache page gimhan90 Installation/Configuration 11 13th February 2006 10:27
Easy One - ISPConfig Default Holding Page mphayesuk General 1 27th November 2005 18:30
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54
WHere is the default domain's web page? Bedevere Installation/Configuration 4 28th August 2005 20:14


All times are GMT +2. The time now is 22:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.