Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 24th February 2006, 14:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by mojosound
[root@cjt-design-server chris]# httpd -V
Server version: Apache/2.0.54
Server built: Jan 5 2006 11:10:01
Server's Module Magic Number: 20020903:9
Architecture: 32-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_FCNTL_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/etc/httpd"
-D SUEXEC_BIN="/usr/sbin/suexec"
-D DEFAULT_PIDLOG="/var/run/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="/var/run/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"
[root@cjt-design-server chris]#
From you I wanted to see the output of
Code:
httpd -t
, not
Code:
httpd -V
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 24th February 2006, 15:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by dfriis
I found one error in the logs. Seems apache is looking in /var/www/web1 for the added site, but standard is /home/www..., isn't it?
Please post the error message.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 24th February 2006, 15:14
mojosound mojosound is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry about that:

[root@cjt-design-server chris]# httpd -t
Syntax error on line 48 of /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps mis-spelled or defined by a module not included in the server configuration
[root@cjt-design-server chris]#

I am going to try and google for the module.
Reply With Quote
  #14  
Old 24th February 2006, 15:20
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,467
Thanks: 813
Thanked 5,253 Times in 4,119 Posts
Default

Quote:
Originally Posted by mojosound
Sorry about that:

[root@cjt-design-server chris]# httpd -t
Syntax error on line 48 of /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps mis-spelled or defined by a module not included in the server configuration
[root@cjt-design-server chris]#

I am going to try and google for the module.
The missing apache module is mod_php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #15  
Old 24th February 2006, 15:39
dfriis dfriis is offline
Junior Member
 
Join Date: Feb 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry, as a test I changed the site settings for the server in ispconfig. I changed the dokument root from /home/www to /var/www and then back again, so the former error message I had is now gone and has been replaced with another one. You can see the result at http://friisweb.se and now the error messages in error.log looks like:
Code:
[Fri Feb 24 14:48:45 2006] [error] [client 217.***.**.***] (13)Permission denied: access to /web1/Maildir/index.html
denied, referer: http://friisweb.se/
I guess that's because of the file structure that now shows when you browse the site so everytime you browse friisweb.se the browser tries to check the mail folder.
I noticed that both sites-available/default and sites-enabled/000-default has /var/www as document root, but Vhosts_ispconfig.conf has /home/www/web1/web as document root. Still, friisweb.se still points to the same root as friisonline.com, my server domain.
Code:
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
###################################
#
NameVirtualHost 195.38.5.139:80
<VirtualHost 195.38.5.139:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.friisweb.se:80
######################################
#
#
<VirtualHost 195.38.5.139:80>
ServerName www.friisweb.se:80
ServerAdmin webmaster@friisweb.se
DocumentRoot /home/www/web1/web
ServerAlias friisweb.se
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.$
ScriptAlias  /cgi-bin/ /home/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /home/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/home/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /home/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web1/user/$1/web/$3
</VirtualHost>
#
#
#
This config file seems to be alright, and so does all the others. What other files would you like me to post? I'll post them all if you want
Reply With Quote
  #16  
Old 24th February 2006, 15:43
mojosound mojosound is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can run php scripts. http://www.cjt-design-server.com/php_info.php runs fine.
Reply With Quote
  #17  
Old 24th February 2006, 15:57
mojosound mojosound is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, I missed the LoadModule mod_php5 from the perfect setup. Now I get:
[root@cjt-design-server chris]# httpd -t
httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[Fri Feb 24 09:54:15 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Fri Feb 24 09:54:15 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Fri Feb 24 09:54:15 2006] [warn] NameVirtualHost 192.168.4.2:80 has no VirtualHosts
[Fri Feb 24 09:54:15 2006] [warn] NameVirtualHost 192.168.4.2:80 has no VirtualHosts
Syntax OK
[root@cjt-design-server chris]#

Everything should be ok now?
Reply With Quote
  #18  
Old 24th February 2006, 16:01
dfriis dfriis is offline
Junior Member
 
Join Date: Feb 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Btw, the guy posting http://www.howtoforge.com/forums/sho...=sites-enabled
has a similar problem as I have.
Reply With Quote
  #19  
Old 24th February 2006, 16:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by mojosound
Ok, I missed the LoadModule mod_php5 from the perfect setup. Now I get:
[root@cjt-design-server chris]# httpd -t
httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[Fri Feb 24 09:54:15 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Fri Feb 24 09:54:15 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Fri Feb 24 09:54:15 2006] [warn] NameVirtualHost 192.168.4.2:80 has no VirtualHosts
[Fri Feb 24 09:54:15 2006] [warn] NameVirtualHost 192.168.4.2:80 has no VirtualHosts
Syntax OK
[root@cjt-design-server chris]#

Everything should be ok now?
That's not serious. Please check at the end of /etc/httpd/conf/httpd.conf if Vhosts_ispconfig.conf is included twice or more. You should have it only once there. If you have to change anything, restart Apache afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 24th February 2006, 16:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by dfriis
http://friisweb.se and now the error messages in error.log looks like:
Code:
[Fri Feb 24 14:48:45 2006] [error] [client 217.***.**.***] (13)Permission denied: access to /web1/Maildir/index.html
denied, referer: http://friisweb.se/
That's weird. There must be something really mixed up on your system. Please check the ISPConfig database if it uses /home/www everywhere.
What's at the end of your Apache configuration file? It should look like this:

Code:
###############ispconfig_log###############
LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

<Directory /home/www/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /home/www/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /home/www/*/cgi-bin>
    Options ExecCGI -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

Include /etc/apache/vhosts/Vhosts_ispconfig.conf
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Default Mail scan settings for new users timehost Installation/Configuration 3 26th October 2007 12:05
Sites that are added using ISPConfig Tool direct to Apache page gimhan90 Installation/Configuration 11 13th February 2006 10:27
Easy One - ISPConfig Default Holding Page mphayesuk General 1 27th November 2005 18:30
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54
WHere is the default domain's web page? Bedevere Installation/Configuration 4 28th August 2005 20:14


All times are GMT +2. The time now is 11:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.