#1  
Old 28th September 2008, 14:38
FractalizeR FractalizeR is offline
Member
 
Join Date: Aug 2008
Posts: 44
Thanks: 0
Thanked 2 Times in 2 Posts
Default Incorrect site folder owners

Hello.

I am using SUPHP. When I create a user, ISPConfig incorrectly assignes permissions to created folders. They are created as
Code:
ls -l /var/www
.................
drwxr-xr-x 8 apache    web8 4096 Sep 28 14:20 web8
...............
while the correct configurationis
Code:
drwxr-xr-x 8 web8_user1    web8 4096 Sep 28 14:20 web8
The same relates to suphp_UserGroup directive in nano /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf.
ISPConfig creates that entry as
Code:
suphp_UserGroup nobody apache
while the correct implementation should be
Code:
suPHP_UserGroup web8_limobus web8
What should I fix and where to correct this problem?
Reply With Quote
Sponsored Links
  #2  
Old 28th September 2008, 15:45
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,994
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

Please create a administrator user for the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th September 2008, 20:12
FractalizeR FractalizeR is offline
Member
 
Join Date: Aug 2008
Posts: 44
Thanks: 0
Thanked 2 Times in 2 Posts
 
Default

Will this change permissions on created files and folders if website already exist?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP - symlinks (site url) to folder (eg web20) dont work robit Installation/Configuration 2 20th July 2008 18:21
Force folder site to "web1" adrenalinic General 3 16th January 2008 11:05
Site Files In The Wrong Folder mudder-board Installation/Configuration 2 3rd September 2007 00:35
Incorrect Site Deletion! tsj5j Installation/Configuration 1 15th February 2007 17:15
Delete & recreate site folder name kyriakos General 1 24th November 2006 17:41


All times are GMT +2. The time now is 11:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.