#1  
Old 22nd September 2008, 21:24
bjarne-j bjarne-j is offline
Junior Member
 
Join Date: Apr 2008
Posts: 17
Thanks: 5
Thanked 0 Times in 0 Posts
Default Email problems after upgrade

hello,

I have just upgraded ispconfig 2.2.25 from 2.2.23. Everything works fine except email. It's possible to login to webmail(roundcubemail), but from an email-client the connection is trying to load until time-out.

Hope someone can help with this issue

Bjarne.
Reply With Quote
Sponsored Links
  #2  
Old 22nd September 2008, 22:27
bjarne-j bjarne-j is offline
Junior Member
 
Join Date: Apr 2008
Posts: 17
Thanks: 5
Thanked 0 Times in 0 Posts
Default

The issue is isolated to IMAP accounts. POP3 works just fine.
Reply With Quote
  #3  
Old 22nd September 2008, 22:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

ISPConfig does not configure imap or pop3 directly, so this issue is most likely not caused to the ISPConfig update.

Which errors do you get in the mail log file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 23rd September 2008, 17:46
bjarne-j bjarne-j is offline
Junior Member
 
Join Date: Apr 2008
Posts: 17
Thanks: 5
Thanked 0 Times in 0 Posts
Default

I found more errors in my setup. So I reinstalled. It works now. I just have to fix my certificates for postfix and courier.

I found this for courier:

Edit /etc/courier/imapd.cnf
rm /usr/lib/courier/imapd.pem
run /usr/lib/couier/mkimapdcert

I restarted courier-imap, courier-imap-ssl, courier-authdaemon after making the new cert.

I want to change the CN to mail.domain.tld in order to awoid the warning from Thunderbird. When I run mkimapdcert it generates the new cert. But when thunderbird downloads the cert the CN is still localhost(as by default).

The issue is mentioned in this thread also: http://www.howtoforge.com/forums/showthread.php?t=1168

Last edited by bjarne-j; 23rd September 2008 at 17:50.
Reply With Quote
  #5  
Old 23rd September 2008, 21:52
bjarne-j bjarne-j is offline
Junior Member
 
Join Date: Apr 2008
Posts: 17
Thanks: 5
Thanked 0 Times in 0 Posts
 
Default

Solved.

I had to edit /etc/courier/imapd-ssl. TLS_CERTFILE has to be changed to /usr/lib/courier/imapd.pem instead of /etc/courier/imapd.pem

Thanks anyway.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 03:39
ISPConfig - Problems with Unique Email Addresses daadams2000 Installation/Configuration 1 7th March 2007 20:59
Problems with updating email account paddyman Installation/Configuration 1 1st February 2007 18:12
Email problems - POP3/SMTP/Password jwan Installation/Configuration 1 16th October 2006 11:04
Email problems lead to apache problems natewlew Installation/Configuration 7 10th July 2006 08:53


All times are GMT +2. The time now is 00:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.