Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th January 2008, 06:03
cybere cybere is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPconfig update - no new users or details permitted

Hi,

Have recently upgraded an Fedora Core 5 ISPconfig installation. All other server operations are functional. ISPConfig has all previous details of all sites, all users etc. However, no existing users details may be altered. It keeps saying that the system is busy and goes no further. After waiting far too long, and checking/repairing databases, the same error occurs. Recycle bin is empty.
Reboot does not clear it up.

ISPconfig has operated flawlessly for over 12 months on version 2.2.6. Old I know, but it works. FC5 was updated, and then ISPconfig started playing up.

I am hesitant to upgrade ispconfig any further due to these problems. Is anyone able to shed some light on how I may repair this please?
Reply With Quote
Sponsored Links
  #2  
Old 15th January 2008, 08:12
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Please make a screenshot of the error and post it here.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 15th January 2008, 23:41
cybere cybere is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default ErrorMessage

Hi Till,

Here is the only error message that is displayed within ISPConfig.

This error is displayed now after any attempt to alter user details. There is no specified time to wait, and having waited several hours, with no response/change/alteration to status, there is obviously something wrong. As stated earlier, checking and repairing DB has no effect.

TIA.
Attached Images
 
Reply With Quote
  #4  
Old 16th January 2008, 08:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Please run:

/etc/init.d/ispconfig_server restart

then wait a few minutes and try again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th January 2008, 00:38
cybere cybere is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPconfig still failing to permit alterations

Hi Till,

>/etc/init.d/ispconfig_server restart

This command restarted the ispconfig server successfully. However, the problem still exists.

When i select a users details to view, the first page loads no problems. Here I am able to reset passwords, shell access checkboxes etc, but Advanced settings, Spam and Antivirus settings while displaying fine, are not permitting any changes to be made.

All other operations appear at this point to be fine.

Thanks again Till
Reply With Quote
  #6  
Old 17th January 2008, 07:18
cybere cybere is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default update to alterations

Hi Till,

As per our previous 2 posts, if I open the users details, to the page where I wish to edit, THEN execute your above command, I am able to make changes and save. Then the problem continues again for any other users that I may need to edit. If i repeat this process, I may continue, again, though for only one page....

still testing...
Reply With Quote
  #7  
Old 17th January 2008, 09:20
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Do you get any errors in the log file /home/admispconfig/ispconfig/ispconfig.log
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 18th January 2008, 01:00
cybere cybere is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till,

No error entries in the log you specified. Only perhaps 40lines of the following:
>
YYYY:x:10004:10001:YYYY:/var/www/web1/user/YYYY:/bin/false
15.01.2008 - 16:08:30 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 883: setquota -u YYYY 0 0 0 0 -a &> /dev/null
15.01.2008 - 16:08:30 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 57: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web1/user/YYYY/.forward
15.01.2008 - 16:08:30 => INFO - USER:
>

Aside: Has anyone been able to install Acronis True Image on FC8 yet? I would like to build FC8 so long as I can get backups working on it. FC5 backup howtos fail on this system.

Thanks for your assistance to date Till.
Reply With Quote
  #9  
Old 18th January 2008, 18:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
ls -la /home/admispconfig/ispconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 21st January 2008, 22:35
cybere cybere is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Output:

Hi Till,

Here are the results:

[root@www ~]# ls -la /home/admispconfig/ispconfig/
total 2560
drwxr-xr-x 8 admispconfig admispconfig 4096 Jan 21 08:56 .
drwxr-xr-x 4 admispconfig admispconfig 4096 Sep 7 2006 ..
-rw-r--r-- 1 admispconfig admispconfig 14 Sep 7 2006 adminmail.txt
drwxrwx--- 2 admispconfig mysql 4096 Sep 7 2006 backup
drwxr-xr-x 4 admispconfig admispconfig 4096 Sep 7 2006 files
-rw-r--r-- 1 admispconfig admispconfig 1349416 Jan 21 08:56 ispconfig.log
-rw-r--r-- 1 root root 411571 Jan 15 15:07 ispconfig.log.15-01-08_16-07-27.tar.gz
-rw-r--r-- 1 root root 389062 Nov 29 2006 ispconfig.log.29-11-06_09-51-08.tar.gz
-rw-r--r-- 1 root root 404355 Aug 31 14:17 ispconfig.log.31-08-07_14-17-22.tar.gz
drwxr-xr-x 6 admispconfig admispconfig 4096 Sep 7 2006 lib
-rw-r--r-- 1 root root 969 Sep 7 2006 sysconf.txt
drwxr-xr-x 6 admispconfig admispconfig 4096 Dec 14 18:13 temp
drwxr-xr-x 8 admispconfig admispconfig 4096 Sep 7 2006 tools
-rw-r--r-- 1 root root 284 Sep 7 2006 users
drwxr-xr-x 16 admispconfig admispconfig 4096 Sep 7 2006 web


Ive begun building yet another server now, as this situation is deteriorating.

cybere
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NIC Issues latcarf Installation/Configuration 15 6th January 2008 16:45
Update ispconfig skiping versions? NETabuse Installation/Configuration 2 13th July 2007 00:10
Can't update ISPConfig Piccent Installation/Configuration 1 18th June 2006 13:31
Ubuntu update from 5.10 to 6.06 - its allok for ispconfig? adrenalinic General 2 10th June 2006 20:28
Ability to add components for users webstergd Feature Requests 1 20th December 2005 10:25


All times are GMT +2. The time now is 18:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.