#1  
Old 9th September 2006, 14:41
djkoelkast djkoelkast is offline
Member
 
Join Date: Sep 2006
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Default FTP issues

Installed using the perfect setup here.
Web FTP works fine, but normal FTP doesn't

With PASV mode on it hangs at the LIST command.
Without PASV mode it hangs at the PORT command:

COMMAND:> PORT 192,168,1,100,9,238
500 Illegal PORT command
STATUS:> Transfer Interrupted

the 192.168.1.100 is the address of the pc I'm trying to connect to the server, it's not the server itself.

Ports are forwarded and open. Did I forget something?

Please help me out.
Reply With Quote
Sponsored Links
  #2  
Old 9th September 2006, 17:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,769
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Please post the output from the following command, executed as root on your server:

iptables -L
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th September 2006, 17:51
djkoelkast djkoelkast is offline
Member
 
Join Date: Sep 2006
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Default

firewall is off

iptables -L gives:

Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
Reply With Quote
  #4  
Old 9th September 2006, 17:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,769
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Thats strange as WebFTP uses a normal FTP connection which means that your ftp daemon is generally working.

Have you tried to connect from inside your local network with another FTP daemon like smartftp or WS-FTP light?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 9th September 2006, 18:03
djkoelkast djkoelkast is offline
Member
 
Join Date: Sep 2006
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Default

yes I connected from another pc in the network with FTP Voyager. Do I need to open up more ports on the router for PASV (passive) mode?

Now ofcourse 21 is open.
Reply With Quote
  #6  
Old 10th September 2006, 19:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

This might help you: http://www.howtoforge.com/forums/sho...ighlight=60000
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 10th September 2006, 19:51
djkoelkast djkoelkast is offline
Member
 
Join Date: Sep 2006
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Default

thanks.
I run Debian, so SELinux is no option and could not cause an error.
Opening port 60000-60005 doesn't help unfortunately.
Reply With Quote
  #8  
Old 11th September 2006, 09:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,769
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Do you get any errors in your xferlog?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 11th September 2006, 12:27
djkoelkast djkoelkast is offline
Member
 
Join Date: Sep 2006
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
Do you get any errors in your xferlog?
/var/xferlog is empty, xferlog.ispconfigsave is also empty.
Reply With Quote
  #10  
Old 11th September 2006, 13:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by djkoelkast
Opening port 60000-60005 doesn't help unfortunately.
Did you do this on your router? You can also try to open port 20.
Do active transfers work?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 Setup DNS and ISPCONFIG issues The General Installation/Configuration 7 15th May 2006 09:45
ISPConfig + Turck MMCache + Hardened-PHP - Any Issues? BobbyQ General 8 3rd May 2006 22:52
DNS issues jaffaizal Installation/Configuration 6 24th February 2006 12:24
Install issues with PHP Part cksrealm Installation/Configuration 7 29th November 2005 18:55
Several minor issues dahljh Installation/Configuration 2 30th October 2005 22:22


All times are GMT +2. The time now is 15:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.