#1  
Old 18th March 2009, 08:28
Balbuzard Balbuzard is offline
Junior Member
 
Join Date: Mar 2009
Posts: 25
Thanks: 1
Thanked 0 Times in 0 Posts
Default edition of /etc/sysctl.conf

Hi!

I have installed OpenVZ on Debian 5.0 Lenny and I am afraid having some trouble with an error-message which comes out during the reboot of the debian-computer;

Code:
Setting kernel variables /etc/sysctl.conf line net.ipv4.conf.eth1.proxy_arp=1 is an unknown key failed
I have followed the steps to install OpenVZ on Debian, except for this line, I have had to change eth0 to eth1 because the eth0 interface is broken.

I have not configured openvz now, could you please explain to me if this error-message will have consequences during the creation of the containers? And is there any way to fix it?

Thanks a lot for your answers!!
Reply With Quote
Sponsored Links
  #2  
Old 19th March 2009, 17:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Do you see this error also when you run
Code:
sysctl -p
? What's the output of
Code:
ifconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th March 2009, 01:28
Balbuzard Balbuzard is offline
Junior Member
 
Join Date: Mar 2009
Posts: 25
Thanks: 1
Thanked 0 Times in 0 Posts
Default

No, there is no error in the output of sysctl -p
Here is the output of ifconfig:
Code:
eth1      Link encap:Ethernet  HWaddr 00:03:2d:09:8a:51  
          inet addr:203.143.170.20  Bcast:203.143.170.255  Mask:255.255.255.0
          inet6 addr: 2402:1800:0:a004:203:2dff:fe09:8a51/64 Scope:Global
          inet6 addr: fe80::203:2dff:fe09:8a51/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2011 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:206646 (201.8 KiB)  TX bytes:10018 (9.7 KiB)
          Interrupt:18 Base address:0xdc00 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Maybe is's just a warning, and there is no real problem with it...
Thanks for your answer!!

EDIT:

I have created my first container, and setted it its IP address:
Code:
:~# vzctl start 101
Starting container ...
Container is mounted
Adding IP address(es): 192.168.0.101
arpsend: 192.168.0.101 is detected on another computer : 00:00:0c:07:ac:00
vps-net_add WARNING: arpsend -c 1 -w 1 -D -e 192.168.0.101 eth1 FAILED
Setting CPU units: 1000
Configure meminfo: 65536
Set hostname: first
Container start in progress...
I don't understand the WARNING message, is there any link with the trouble I have had before?
Thanks for your help, falko!

Last edited by Balbuzard; 20th March 2009 at 02:35.
Reply With Quote
  #4  
Old 20th March 2009, 14:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Do you get the error also when you use net.ipv4.conf.eth0.proxy_arp=1 instead of net.ipv4.conf.eth1.proxy_arp=1?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd March 2009, 00:31
Balbuzard Balbuzard is offline
Junior Member
 
Join Date: Mar 2009
Posts: 25
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Yes, it's the same. I have not used the eth0 interface because there is a problem on it.
Thanks for your answer!
Reply With Quote
  #6  
Old 23rd March 2009, 19:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

What's in your /etc/sysctl.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 24th March 2009, 00:47
Balbuzard Balbuzard is offline
Junior Member
 
Join Date: Mar 2009
Posts: 25
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi!
Here is my sysctl.conf file (I have not pasted all the comments)
Thanks again for your help! But maybe this error doesn't mean anything?

Code:
# Uncomment the next line to enable packet forwarding for IPv4
net.ipv4.ip_forward=1

# Uncomment the next line to enable packet forwarding for IPv6
#net.ipv6.conf.all.forwarding=1
#-- OpenVZ begin --#

# On Hardware Node we generally need
# packet forwarding enabled and proxy arp disabled
net.ipv4.conf.default.forwarding=1
net.ipv4.conf.default.proxy_arp = 0

# Enables source route verification
net.ipv4.conf.all.rp_filter = 1

# Enables the magic-sysrq key
kernel.sysrq = 1

# TCP Explict Congestion Notification
#net.ipv4.tcp_ecn = 0

# we do not want all our interfaces to send redirects
net.ipv4.conf.default.send_redirects = 1
net.ipv4.conf.all.send_redirects = 0
net.ipv4.conf.eth1.proxy_arp=1

#-- OpenVZ end --#
Reply With Quote
  #8  
Old 24th March 2009, 18:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Looks ok. Not sure what the problem is...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Balbuzard (25th March 2009)
  #9  
Old 25th March 2009, 00:12
Balbuzard Balbuzard is offline
Junior Member
 
Join Date: Mar 2009
Posts: 25
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

OK
I consider this trouble as solved, I have not had issues when building the internet connection between the containers or between internet and the containers, so maybe it's just a warning, even if it does not look like it.

Thank you for your help!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Zarafa 6.20 Community Edition tommii Feature Requests 0 22nd January 2009 13:07
How to turn off Laptop Monitor running Hardy 8.04 Server edition? media_555 Installation/Configuration 1 27th August 2008 22:10
1 Subscription for Red Hat Linux Enterprise edition Balaram Smalltalk 1 8th July 2008 10:44
Red hat enterprise edition repository blocker Installation/Configuration 3 20th May 2008 19:05


All times are GMT +2. The time now is 02:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.