#1  
Old 4th September 2008, 15:44
aaronkm aaronkm is offline
Junior Member
 
Join Date: Sep 2008
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Default Apache root

Hello HowtoForge,

I hope this post finds you well.

I've added my first website to my ISPConfig install. (2.2.4)
The DNS resolves as it should but when I browse to the site, the default apache folder is served from /var/www/html instead of what is in the Vhost conf file. (/var/www/web7/web)

Below is my Vhost's conf file, not sure if it helps diagnose or not.

Thanks for any insight on what I've done wrong.



Code:
NameVirtualHost 96.225.168.6:80
<VirtualHost 96.225.168.6:80>
 ServerName localhost
 ServerAdmin root@localhost
 DocumentRoot /var/www/sharedip
 <IfModule mod_rewrite.c>
   RewriteEngine on
   RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
   RewriteRule .* - [F]
 </IfModule>
</VirtualHost>
#
#
######################################
# Vhost: www.advantagecamps.org:80
######################################
#
#
<VirtualHost 96.225.168.6:80>
ServerName www.advantagecamps.org:80
ServerAdmin webmaster@advantagecamps.org
DocumentRoot /var/www/web7/web
ServerAlias advantagecamps.org
DirectoryIndex index.html index.htm index.php aaron.test
ErrorLog /var/www/web7/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
   SetOutputFilter PHP
   SetInputFilter PHP
</Files>
<Files *.php3>
   SetOutputFilter PHP
   SetInputFilter PHP
</Files>
<Files *.php4>
   SetOutputFilter PHP
   SetInputFilter PHP
</Files>
<Files *.php5>
   SetOutputFilter PHP
   SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/var/www/web7/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web7/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web7/user/$1/web/$3
<IfModule mod_rewrite.c>
 RewriteEngine on
 RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
 RewriteRule .* - [F]
</IfModule>
</VirtualHost>
Reply With Quote
Sponsored Links
  #2  
Old 4th September 2008, 15:55
jon jon is offline
Member
 
Join Date: Jan 2007
Location: Canada
Posts: 87
Thanks: 11
Thanked 5 Times in 5 Posts
Send a message via Skype™ to jon
Default

Have you disabled the default site config that comes with your distro? Perhaps it's being hit first, and directing you there.

In your console try ...

cd /etc/apache2 (assuming this is your apache2 config directory)
grep -ir "var/www/html" *

And see if it returns the offending config file.

If you were running Debian, you could run a2dissite and disable default
Reply With Quote
The Following User Says Thank You to jon For This Useful Post:
aaronkm (4th September 2008)
  #3  
Old 4th September 2008, 16:00
aaronkm aaronkm is offline
Junior Member
 
Join Date: Sep 2008
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Default Bingo!

Quote:
Originally Posted by jon View Post
Have you disabled the default site config that comes with your distro? Perhaps it's being hit first, and directing you there.

In your console try ...

cd /etc/apache2 (assuming this is your apache2 config directory)
grep -ir "var/www/html" *

And see if it returns the offending config file.

If you were running Debian, you could run a2dissite and disable default
Thanks Jon.

I thought that was it.

I changed the httpd.conf file

from <Directory "/var/www/html">
to <Directory "/var/www">

And it now shows the contents of /var/www when I point my browser to www.advantagecamps.org

If I change it back to /var/www/html it takes me back to the apache root /var/www/html

Thought that was the answer but no.

Last edited by aaronkm; 4th September 2008 at 16:04.
Reply With Quote
  #4  
Old 4th September 2008, 17:54
aaronkm aaronkm is offline
Junior Member
 
Join Date: Sep 2008
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

I made the mistake of using a live IP instead of the local non-routable IP.

Making that change squared things away.

Thanks again for the assist.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Email dayjahone General 7 30th June 2008 15:29
Postfix email server problems Access denied 554 554 5.7.1 state 14 AceRimmer Server Operation 4 19th June 2008 14:36
i am having some problem ? cobro Installation/Configuration 20 30th April 2008 16:26
Add Webmin to the system sushestvo Installation/Configuration 44 21st August 2007 16:52
cannot connect to ispconfig guidovanh Installation/Configuration 22 3rd March 2006 19:52


All times are GMT +2. The time now is 13:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.