#1  
Old 21st February 2006, 18:14
Plascual Plascual is offline
Junior Member
 
Join Date: Feb 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Dynamic DNS & DNS

Hi!

I registered a domain name with EasyDNS with DNS-Plus service (I'm on cable, behind a router with forwarding) and would like to setup a development web-server.

I installed a "Debian perfect setup" + ISPConfig successfully with external IP and domain name.

I'm a little bit confused about DNS and Bind9 and ISPConfig, because EasyDNS provide control panel to manage A records, and I configured nameservers to those of EasyDNS.

- Should I turn off Bind9 and how?
- Should I point to their nameservers?

There is no problem seeing the ISPConfig server from outside, but I have difficulties to set subdomains as "user1.example.com" and "user2.example.com" so that they point to different web pages.

Should I add IPs to /etc/hosts for each subdomains?

Does anybody know examples on how to setup ISPConfig with dynamic DNS with nameserver of i.e. EasyDNS?
Reply With Quote
Sponsored Links
  #2  
Old 21st February 2006, 20:52
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by Plascual
- Should I turn off Bind9 and how?
If you use EasyDNS to manage all your DNS records, then yes. You can use the ISPConfig interface to turn off Bind: Management -> Server -> Services.

Quote:
Originally Posted by Plascual
- Should I point to their nameservers?
No, that's not necessary.

Quote:
Originally Posted by Plascual
There is no problem seeing the ISPConfig server from outside, but I have difficulties to set subdomains as "user1.example.com" and "user2.example.com" so that they point to different web pages.
Just create the appropriate DNS records for user1.example.com and user2.example.com with EasyDNS, and then create two new web sites in ISPConfig, one for user1.example.com, the other one for user2.example.com.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st February 2006, 23:15
Plascual Plascual is offline
Junior Member
 
Join Date: Feb 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks falko!

In Management > Server > Settings > DNS > Default Ns1 : Ip adresses or ns1.easydns.com or my ISP nameserver or any of theses?

Something strange, in Services, the Web-Server is Offline...

If I "netstat -tap" some entries end with "TIME_WAIT"...

Plascual
Reply With Quote
  #4  
Old 21st February 2006, 23:29
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Originally Posted by Plascual
Thanks falko!

In Management > Server > Settings > DNS > Default Ns1 : Ip adresses or ns1.easydns.com or my ISP nameserver or any of theses?
If you use easydns to manage your dns records, you can leave these fields empty. They are just the defaults that are inserted when you use the DNS-Manager in ISPConfig.

Quote:
Something strange, in Services, the Web-Server is Offline...

If I "netstat -tap" some entries end with "TIME_WAIT"...
Can you please post the output of "netstat -tap". I guess your apache webserver is not listening on localhost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 23rd February 2006, 17:54
Plascual Plascual is offline
Junior Member
 
Join Date: Feb 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks you!

You were right Till, I changed listening port to 8080. I put it back to 80, with my router forwarding external port 8080 to internal 80 of my server IP.

So, being with EasyDNS, I switched off DNS-Server. With EasyDNS panel, I created A record "server1.example.com" that has an URL to "https://IP-adress:81/" and A records "user1.example.com" and "user2.example.com" with IP.

The ISPConfig on "https://server1.example.com:81/" respond from the outside without any problem.

I created the two clients and their respective websites.

When I type address "http://user1.example.com:8080" or "http://user2.example.com:8080", I'm redirected to "http://user#.example.com:8080/apache2-default/" ...

Is it a DNS problem?

I expected to see the user1.example.com page with the blue stripe.
Reply With Quote
  #6  
Old 23rd February 2006, 23:02
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Did you create a web site for user1.example.com in ISPConfig (or added user1.example.com to another web site as Co-Domain)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
DDClient won't start deezone Installation/Configuration 1 1st February 2006 20:22
isp and dynamic ip mcl Installation/Configuration 1 7th November 2005 10:02
PHP cleanup Spum Developers' Forum 8 19th October 2005 17:25
Dynamic Connection/Ez-IPupdate and/Linksysmon and easydns.com linutzy Suggest HOWTO 1 25th August 2005 14:17


All times are GMT +2. The time now is 14:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.