#1  
Old 21st February 2006, 16:07
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default Connecting email client

HI..
My postfix email server is running correctly now.There is a smalle problem.I can check email with my outlook express but unable to send emails.Log file shows following error

Feb 20 23:06:54 linux pop3d: LOGIN: DEBUG: ip=[::ffff:222.165.169.248], username=web7_lasitha
Feb 20 23:06:54 linux pop3d: LOGIN: DEBUG: ip=[::ffff:222.165.169.248], password=*****
Feb 20 23:06:54 linux pop3d: authdaemon: starting client module
Feb 20 23:06:55 linux pop3d: authdaemon: ACCEPT, username web7_lasitha
Feb 20 23:06:55 linux pop3d: LOGIN, user=web7_lasitha, ip=[::ffff:222.165.169.248]
Feb 20 23:06:55 linux pop3d: LOGOUT, user=web7_lasitha, ip=[::ffff:222.165.169.248], top=0, retr=0, time=0
Feb 20 23:07:05 linux postfix/smtpd[19148]: connect from unknown[222.165.169.248]
Feb 20 23:07:06 linux postfix/smtpd[19148]: warning: support for restriction "check_relay_domains" will be removed from Postfix; use "reject_unauth_destination" instead

Feb 20 23:07:06 linux postfix/smtpd[19148]: NOQUEUE: reject: RCPT from unknown[222.165.169.248]: 554 <lasitha@codegen.net>: Recipient address rejected: Relay access denied; from=<lasitha@cosmoforge.com> to=<lasitha@codegen.net> proto=SMTP helo=<Lasitha>

Feb 20 23:07:06 linux postfix/smtpd[19148]: disconnect from unknown[222.165.169.248]



I think this will be usefult for you


su93254144:~ # telnet localhost smtp
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 su93254144.cosmoforge.com ESMTP Postfix
ehlo localhost
250-su93254144.cosmoforge.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.


And here is main.cf configurations


inet_protocols = all
inet_interfaces = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
program_directory = /usr/lib/postfix
mynetworks = 192.168.0.0/24,66.240.0.0/24, 127.0.0.0/8
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
relay_domains = cosmoforge.com
mailbox_command =
mailbox_transport =
home_mailbox = Maildir/
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtp_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
mydomain = cosmoforge.com
myhostname = su93254144.$mydomain

smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
Reply With Quote
Sponsored Links
  #2  
Old 21st February 2006, 17:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Please enable "Sever needs authentication" in your outlook express smtp settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st February 2006, 18:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Please do what Till suggests, and then replace

Code:
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
with

Code:
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
in /etc/postfix/main.cf and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 22nd February 2006, 13:27
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default Connecting an email client

I'v done changes both of you posted.still it's not working.Here is my log file


Feb 21 20:17:02 linux postfix/anvil[21750]: statistics: max connection count 1 for (smtp:222.165.180.127) at Feb 21 20:08:46
Feb 21 20:17:02 linux postfix/anvil[21750]: statistics: max cache size 1 at Feb 21 20:08:46
Feb 21 20:18:51 linux postfix/smtpd[22069]: connect from unknown[222.165.180.127]
Feb 21 20:18:52 linux postfix/smtpd[22069]: lost connection after AUTH from unknown[222.165.180.127]
Feb 21 20:18:52 linux postfix/smtpd[22069]: disconnect from unknown[222.165.180.127]
Feb 21 20:19:09 linux postfix/smtpd[22069]: connect from unknown[222.165.180.127]
Feb 21 20:19:10 linux postfix/smtpd[22069]: warning: unknown[222.165.180.127]: SASL LOGIN authentication failed
Feb 21 20:19:11 linux postfix/smtpd[22069]: disconnect from unknown[222.165.180.127]
Feb 21 20:19:14 linux postfix/smtpd[22069]: connect from unknown[222.165.180.127]
Feb 21 20:20:00 linux postfix/smtpd[22069]: warning: unknown[222.165.180.127]: SASL LOGIN authentication failed
Feb 21 20:20:01 linux postfix/smtpd[22069]: disconnect from unknown[222.165.180.127]
Feb 21 20:20:10 linux pop3d: Connection, ip=[::ffff:222.165.180.127]
Feb 21 20:20:10 linux pop3d: LOGIN: DEBUG: ip=[::ffff:222.165.180.127], command=AUTH
Feb 21 20:20:17 linux postfix/smtpd[22069]: connect from unknown[222.165.180.127]
Feb 21 20:20:18 linux postfix/smtpd[22069]: disconnect from unknown[222.165.180.127]
Feb 21 20:20:51 linux postfix/smtpd[22069]: connect from unknown[222.165.180.127]
Feb 21 20:20:51 linux postfix/smtpd[22069]: disconnect from unknown[222.165.180.127]
Feb 21 20:21:22 linux postfix/smtpd[22069]: connect from unknown[222.165.180.127]
Feb 21 20:21:31 linux postfix/smtpd[22069]: disconnect from unknown[222.165.180.127]
Reply With Quote
  #5  
Old 22nd February 2006, 19:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Can you see saslauthd running when you do a
Code:
ps aux
?
What authentication method does sasluthd use? pam, shadow, sasldb2, ...?
Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 23rd February 2006, 13:59
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default Can't connect email client

It's pam authentication

root 17706 0.0 0.1 19856 1488 ? Ss Feb20 0:00 /usr/sbin/saslauthd -a pam
root 17707 0.0 0.1 19856 1524 ? S Feb20 0:00 /usr/sbin/saslauthd -a pam
root 17708 0.0 0.1 19856 1524 ? S Feb20 0:00 /usr/sbin/saslauthd -a pam
root 17709 0.0 0.1 19856 1524 ? S Feb20 0:00 /usr/sbin/saslauthd -a pam
root 17710 0.0 0.1 19856 1488 ? S Feb20 0:00 /usr/sbin/saslauthd -a pam
Reply With Quote
  #7  
Old 23rd February 2006, 17:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you enable "Server requires authenticatio." as described on this page? http://mail.cs.uiuc.edu/relay/outlook-config.html

If so, what's in /etc/pam.d/smtp?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 24th February 2006, 08:13
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default Pam authentication

There is no smtp file

su93254144:/etc/pam.d # ls

. chage chsh common-auth common-session imap other pop3 shadow su vsftpd
.. chfn common-account common-password crond login passwd rpasswd sshd useradd webmin
Reply With Quote
  #9  
Old 24th February 2006, 08:36
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default It's working

Thanks guys i got the point.I added the smtp file using pop3 file.It's working now.Thnak again
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
email forwarding locally consumes all resources rdells General 20 1st May 2006 20:43
Recreate email Felipe General 3 13th December 2005 22:45
FTP & Email access jon335 General 3 8th October 2005 04:08
email client configuration davidg General 3 22nd August 2005 17:40
mysqlcheck has found corrupt tables m u r Installation/Configuration 1 18th August 2005 11:47


All times are GMT +2. The time now is 15:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.